summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /app-forensics
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/sleuthkit/sleuthkit-4.5.0.ebuild3
-rw-r--r--app-forensics/sleuthkit/sleuthkit-4.6.5.ebuild1
-rw-r--r--app-forensics/sleuthkit/sleuthkit-4.6.6.ebuild1
-rw-r--r--app-forensics/sleuthkit/sleuthkit-4.6.7.ebuild1
-rw-r--r--app-forensics/sleuthkit/sleuthkit-4.7.0.ebuild1
5 files changed, 6 insertions, 1 deletions
diff --git a/app-forensics/sleuthkit/sleuthkit-4.5.0.ebuild b/app-forensics/sleuthkit/sleuthkit-4.5.0.ebuild
index aba46c1c21ef..6188e6d973c9 100644
--- a/app-forensics/sleuthkit/sleuthkit-4.5.0.ebuild
+++ b/app-forensics/sleuthkit/sleuthkit-4.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,6 +16,7 @@ LICENSE="BSD CPL-1.0 GPL-2+ IBM java? ( Apache-2.0 )"
SLOT="0/13" # subslot = major soname version
KEYWORDS="amd64 hppa ppc x86"
IUSE="aff doc ewf java static-libs test +threads zlib"
+RESTRICT="!test? ( test )"
DEPEND="
dev-db/sqlite:3
diff --git a/app-forensics/sleuthkit/sleuthkit-4.6.5.ebuild b/app-forensics/sleuthkit/sleuthkit-4.6.5.ebuild
index daf357f8c885..1fff100c79b5 100644
--- a/app-forensics/sleuthkit/sleuthkit-4.6.5.ebuild
+++ b/app-forensics/sleuthkit/sleuthkit-4.6.5.ebuild
@@ -23,6 +23,7 @@ LICENSE="BSD CPL-1.0 GPL-2+ IBM java? ( Apache-2.0 )"
SLOT="0/13" # subslot = major soname version
KEYWORDS="~amd64 ~hppa ~ppc ~x86"
IUSE="aff doc ewf java postgres static-libs test +threads zlib"
+RESTRICT="!test? ( test )"
# Note: It is not possible to move the dep on dev-java/jdbc-postgresql
# inside a conditional postgres? block because java sources import
diff --git a/app-forensics/sleuthkit/sleuthkit-4.6.6.ebuild b/app-forensics/sleuthkit/sleuthkit-4.6.6.ebuild
index d8dbcf0335fc..b5c338f420a3 100644
--- a/app-forensics/sleuthkit/sleuthkit-4.6.6.ebuild
+++ b/app-forensics/sleuthkit/sleuthkit-4.6.6.ebuild
@@ -23,6 +23,7 @@ LICENSE="BSD CPL-1.0 GPL-2+ IBM java? ( Apache-2.0 )"
SLOT="0/13" # subslot = major soname version
KEYWORDS="~amd64 ~hppa ~ppc ~x86"
IUSE="aff doc ewf java postgres static-libs test +threads zlib"
+RESTRICT="!test? ( test )"
# Note: It is not possible to move the dep on dev-java/jdbc-postgresql
# inside a conditional postgres? block because java sources import
diff --git a/app-forensics/sleuthkit/sleuthkit-4.6.7.ebuild b/app-forensics/sleuthkit/sleuthkit-4.6.7.ebuild
index 62abebb025c1..87cfa333d4c1 100644
--- a/app-forensics/sleuthkit/sleuthkit-4.6.7.ebuild
+++ b/app-forensics/sleuthkit/sleuthkit-4.6.7.ebuild
@@ -23,6 +23,7 @@ LICENSE="BSD CPL-1.0 GPL-2+ IBM java? ( Apache-2.0 )"
SLOT="0/13" # subslot = major soname version
KEYWORDS="~amd64 ~hppa ~ppc ~x86"
IUSE="aff doc ewf java postgres static-libs test +threads zlib"
+RESTRICT="!test? ( test )"
# Note: It is not possible to move the dep on dev-java/jdbc-postgresql
# inside a conditional postgres? block because java sources import
diff --git a/app-forensics/sleuthkit/sleuthkit-4.7.0.ebuild b/app-forensics/sleuthkit/sleuthkit-4.7.0.ebuild
index d4582505ad14..804c0366a80c 100644
--- a/app-forensics/sleuthkit/sleuthkit-4.7.0.ebuild
+++ b/app-forensics/sleuthkit/sleuthkit-4.7.0.ebuild
@@ -23,6 +23,7 @@ LICENSE="BSD CPL-1.0 GPL-2+ IBM java? ( Apache-2.0 )"
SLOT="0/13" # subslot = major soname version
KEYWORDS="~amd64 ~hppa ~ppc ~x86"
IUSE="aff doc ewf java postgres static-libs test +threads zlib"
+RESTRICT="!test? ( test )"
# Depending specifically on oracle-jdk-bin is an overkill but we have no
# other options right now. OpenJDK would also work, but there is no