summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-10-23 23:21:57 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-10-23 23:31:51 +0900
commit33bdfd975f239c6d6433bc1587991cf9e3d31a64 (patch)
tree64bf651d1b9942a694181b1a82d72e8649cb7eff /app-i18n
parentapp-i18n/uim: fix desktop file (diff)
downloadgentoo-33bdfd975f239c6d6433bc1587991cf9e3d31a64.tar.gz
gentoo-33bdfd975f239c6d6433bc1587991cf9e3d31a64.tar.bz2
gentoo-33bdfd975f239c6d6433bc1587991cf9e3d31a64.zip
app-i18n/uim: fix build with Clang
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/uim/files/uim-1.8.8-c++11.patch23
-rw-r--r--app-i18n/uim/uim-1.8.8-r2.ebuild1
2 files changed, 24 insertions, 0 deletions
diff --git a/app-i18n/uim/files/uim-1.8.8-c++11.patch b/app-i18n/uim/files/uim-1.8.8-c++11.patch
new file mode 100644
index 000000000000..07e082840967
--- /dev/null
+++ b/app-i18n/uim/files/uim-1.8.8-c++11.patch
@@ -0,0 +1,23 @@
+From bb25aac568359efbfb68e52dd8d9ee85e65d754b Mon Sep 17 00:00:00 2001
+From: Haelwenn Monnier <lanodan@users.noreply.github.com>
+Date: Thu, 25 Oct 2018 09:10:16 +0200
+Subject: [PATCH] xim/main.cpp: FIx build against clang
+
+main.cpp:68:55: error: invalid suffix on literal; C++11 requires a space between literal and identifier
+---
+ xim/main.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/xim/main.cpp b/xim/main.cpp
+index a0b0beceb..c5818ca4a 100644
+--- a/xim/main.cpp
++++ b/xim/main.cpp
+@@ -65,7 +65,7 @@ int g_option_mask;
+ int scr_width, scr_height;
+ int host_byte_order;
+
+-#define VERSION_NAME "uim-xim under the way! Version "PACKAGE_VERSION"\n"
++#define VERSION_NAME "uim-xim under the way! Version " PACKAGE_VERSION "\n"
+ const char *version_name=VERSION_NAME;
+ const char *usage=
+ "--help , --version :Show usage or version\n"
diff --git a/app-i18n/uim/uim-1.8.8-r2.ebuild b/app-i18n/uim/uim-1.8.8-r2.ebuild
index 99ed89084645..3e0f4c05b075 100644
--- a/app-i18n/uim/uim-1.8.8-r2.ebuild
+++ b/app-i18n/uim/uim-1.8.8-r2.ebuild
@@ -80,6 +80,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-tinfo.patch
"${FILESDIR}"/${PN}-xkb.patch
"${FILESDIR}"/${PN}-zh-TW.patch
+ "${FILESDIR}"/${P}-c++11.patch
"${FILESDIR}"/${P}-desktop.patch
"${FILESDIR}"/${P}-fno-common.patch
)