summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/cdctl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/cdctl')
-rw-r--r--app-misc/cdctl/Manifest2
-rw-r--r--app-misc/cdctl/cdctl-0.15.ebuild35
-rw-r--r--app-misc/cdctl/cdctl-0.16.ebuild30
-rw-r--r--app-misc/cdctl/files/cdctl-0.15-Makefile.in.patch56
-rw-r--r--app-misc/cdctl/files/cdctl-0.15-cdc_ioctls.patch13
-rw-r--r--app-misc/cdctl/files/cdctl-0.16-Makefile.in.patch55
-rw-r--r--app-misc/cdctl/metadata.xml10
7 files changed, 201 insertions, 0 deletions
diff --git a/app-misc/cdctl/Manifest b/app-misc/cdctl/Manifest
new file mode 100644
index 000000000000..7bb2030b8519
--- /dev/null
+++ b/app-misc/cdctl/Manifest
@@ -0,0 +1,2 @@
+DIST cdctl-0.15.tar.gz 44163 SHA256 6e9b6cbc6824c5fab7e7a45878605296ad8c62692cac6db468d5e42296d51e39 SHA512 7bcaec8f52cafbe84d87dcb740a952520ceccb197b1491a88bb03d6a993a6385d424f67386a7175bb30c5c8b3ac02abf31c2e8843c1cd7d1d808eee70a5906f4 WHIRLPOOL 4e7782421f142a8cc442837ca40c1969cca3467850b701f90bc6e0d9589c7d9ab216dc94dec2633c361b327cf1c37e1e0863480108e925446a6badac5e127b48
+DIST cdctl-0.16.tar.gz 34121 SHA256 b98c17accd72fdc12dd4cd4dfe9f198b961e44c6bc15f62085e71766858eaa7f SHA512 e1c341cf0acabc28c8aedb3265e65ffe90668b83eb44d23577049cc81a160ab0ec8b6e813cf8ffe20aaf83b4d056a8f07c2e958f5a6086db3843b84b36e060b4 WHIRLPOOL 842bd397d8afb3e85e41bb9f6b097324fe9b86f7afcc16524f52fd98f08037e95a031135162c52c3b0790dbd907d68aa015b62f05a20eb925897098fb15dab48
diff --git a/app-misc/cdctl/cdctl-0.15.ebuild b/app-misc/cdctl/cdctl-0.15.ebuild
new file mode 100644
index 000000000000..39b43cfc51bb
--- /dev/null
+++ b/app-misc/cdctl/cdctl-0.15.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to control your cd/dvd drive"
+HOMEPAGE="http://cdctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cdctl/${P}.tar.gz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="x86 ppc amd64 ppc64"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-Makefile.in.patch
+ epatch "${FILESDIR}"/${P}-cdc_ioctls.patch
+}
+
+src_compile() {
+ econf
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS NUTSANDBOLTS PUBLICKEY README
+}
diff --git a/app-misc/cdctl/cdctl-0.16.ebuild b/app-misc/cdctl/cdctl-0.16.ebuild
new file mode 100644
index 000000000000..0ac2f237b195
--- /dev/null
+++ b/app-misc/cdctl/cdctl-0.16.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools toolchain-funcs
+
+DESCRIPTION="Utility to control your cd/dvd drive"
+HOMEPAGE="http://cdctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cdctl/${P}.tar.gz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.16-Makefile.in.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
diff --git a/app-misc/cdctl/files/cdctl-0.15-Makefile.in.patch b/app-misc/cdctl/files/cdctl-0.15-Makefile.in.patch
new file mode 100644
index 000000000000..6d8e11502fcc
--- /dev/null
+++ b/app-misc/cdctl/files/cdctl-0.15-Makefile.in.patch
@@ -0,0 +1,56 @@
+--- Makefile.in.orig 2003-02-20 21:57:38.000000000 -0800
++++ Makefile.in 2003-02-20 22:27:10.000000000 -0800
+@@ -2,10 +2,12 @@
+ CFLAGS=-Wall -g
+ BINS=cdctl sndreset
+ OBJS=cdctl.o version.o ioctls.o iso_header.o
+-DOCS=NEWS NUTSANDBOLTS LICENSE PUBLICKEY README SEGFAULTS
++DOCS=NEWS NUTSANDBOLTS LICENSE PUBLICKEY README
+ MANS=cdctl.1
+ MOS=cdctl.mo
+
++prefix = @prefix@
++exec_prefix = @exec_prefix@
+ bindir = @bindir@
+ mandir = @mandir@
+ datadir = @datadir@
+@@ -16,6 +18,10 @@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = $(INSTALL) -m 644
+
++DESTDIR =
++
++man1dir = $(mandir)/man1
++
+ all: $(BINS)
+
+ cdctl: $(OBJS)
+@@ -26,21 +32,21 @@
+ version.o: version.c
+ iso_header.o: iso_header.c
+
+-install: install-bins install-docs install-mans install-mos
++install: install-bins install-mans install-mos
+
+ install-bins: $(BINS)
+- $(INSTALL) -s $(BINS) $(bindir)
+-
+-install-docs: $(DOCS)
+- $(INSTALL_DATA) $(DOCS) $(datadir)
++ $(INSTALL) -d $(DESTDIR)$(bindir)
++ $(INSTALL) $(BINS) $(DESTDIR)$(bindir)
+
+ install-mans: $(MANS)
+- $(INSTALL_DATA) $(MANS) $(mandir)
++ $(INSTALL) -d $(DESTDIR)$(man1dir)
++ $(INSTALL_DATA) $(MANS) $(DESTDIR)$(man1dir)
+
+ # FIXME: need to deal with other languages besides German
+
+ install-mos: cdctl.mo
+- $(INSTALL_DATA) $(MOS) $(localedir)/de/LC_MESSAGES
++ $(INSTALL) -d $(DESTDIR)$(localedir)/de/LC_MESSAGES
++ $(INSTALL_DATA) $(MOS) $(DESTDIR)$(localedir)/de/LC_MESSAGES
+
+ cdctl.mo: cdctl.po
+ msgfmt cdctl.po -o cdctl.mo
diff --git a/app-misc/cdctl/files/cdctl-0.15-cdc_ioctls.patch b/app-misc/cdctl/files/cdctl-0.15-cdc_ioctls.patch
new file mode 100644
index 000000000000..8e440955907b
--- /dev/null
+++ b/app-misc/cdctl/files/cdctl-0.15-cdc_ioctls.patch
@@ -0,0 +1,13 @@
+diff -Naurp cdctl-0.15-orig/cdctl.c cdctl-0.15/cdctl.c
+--- cdctl-0.15-orig/cdctl.c 2006-08-08 23:18:44.000000000 +0200
++++ cdctl-0.15/cdctl.c 2006-08-08 23:19:33.000000000 +0200
+@@ -337,7 +337,9 @@ int do_print_capabilities(int cdrom) {
+ printf("Can report media change: %i\n", (ret & CDC_MEDIA_CHANGED)?1:0);
+ printf("Can play audio discs : %i\n", (ret & CDC_PLAY_AUDIO)?1:0);
+ printf("Can do a hard reset : %i\n", (ret & CDC_RESET)?1:0);
++#ifdef CDC_IOCTLS
+ printf("Has non-standard ioctls: %i\n", (ret & CDC_IOCTLS)?1:0);
++#endif
+ printf("Can report drive status: %i\n", (ret & CDC_DRIVE_STATUS)?1:0);
+
+ #ifdef CDROM_CHANGER_NSLOTS
diff --git a/app-misc/cdctl/files/cdctl-0.16-Makefile.in.patch b/app-misc/cdctl/files/cdctl-0.16-Makefile.in.patch
new file mode 100644
index 000000000000..f6f4ad3abdcf
--- /dev/null
+++ b/app-misc/cdctl/files/cdctl-0.16-Makefile.in.patch
@@ -0,0 +1,55 @@
+--- cdctl/Makefile.in
++++ cdctl/Makefile.in
+@@ -1,8 +1,8 @@
+ CC=gcc
+-CFLAGS=-Wall -g
++CFLAGS:=-Wall -g
+ BINS=cdctl sndreset
+ OBJS=cdctl.o version.o ioctls.o iso_header.o
+-DOCS=NEWS NUTSANDBOLTS LICENSE PUBLICKEY README SEGFAULTS
++DOCS=NEWS NUTSANDBOLTS LICENSE PUBLICKEY README
+ # NOTE: all man pages are installed in $(mandir)/man1 -- see install-mans
+ MANS=cdctl.1
+ MOS=cdctl.mo
+@@ -22,6 +22,8 @@
+ INSTALL_DIR = $(INSTALL) -d
+ INSTALL_DATA = $(INSTALL) -m 644
+
++DESTDIR =
++
+ all: $(BINS)
+
+ cdctl: $(OBJS)
+@@ -35,25 +37,21 @@
+ indent:
+ indent -kr -cdb -sc *.c
+
+-install: install-bins install-docs install-mans install-mos
++install: install-bins install-mans install-mos
+
+ install-bins: $(BINS)
+- $(INSTALL_DIR) $(bindir)
+- $(INSTALL) -s $(BINS) $(bindir)
+-
+-install-docs: $(DOCS)
+- $(INSTALL_DIR) $(docdir)
+- $(INSTALL_DATA) $(DOCS) $(docdir)
++ $(INSTALL_DIR) $(DESTDIR)$(bindir)
++ $(INSTALL) $(BINS) $(DESTDIR)$(bindir)
+
+ install-mans: $(MANS)
+- $(INSTALL_DIR) $(mandir)/man1
+- $(INSTALL_DATA) $(MANS) $(mandir)/man1
++ $(INSTALL_DIR) $(DESTDIR)/$(mandir)/man1
++ $(INSTALL_DATA) $(MANS) $(DESTDIR)$(mandir)/man1
+
+ # FIXME: need to deal with other languages besides German
+
+ install-mos: cdctl.mo
+- $(INSTALL_DIR) $(localedir)/de/LC_MESSAGES
+- $(INSTALL_DATA) $(MOS) $(localedir)/de/LC_MESSAGES
++ $(INSTALL_DIR) $(DESTDIR)$(localedir)/de/LC_MESSAGES
++ $(INSTALL_DATA) $(MOS) $(DESTDIR)$(localedir)/de/LC_MESSAGES
+
+ cdctl.mo: cdctl.po
+ msgfmt cdctl.po -o cdctl.mo
diff --git a/app-misc/cdctl/metadata.xml b/app-misc/cdctl/metadata.xml
new file mode 100644
index 000000000000..65e05e457683
--- /dev/null
+++ b/app-misc/cdctl/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">cdctl</remote-id>
+ </upstream>
+</pkgmetadata>