summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-01-03 23:08:29 -0600
committerTim Harder <radhermit@gentoo.org>2019-01-03 23:11:43 -0600
commit43138c41b9334e85b5e80508eda81cdeecf0d4b6 (patch)
tree5f64349a9ea6ffc48bfbe82567c387a29566cce0 /app-misc/ckermit
parentdev-perl/Text-Template: Restore ~alpha and ~ppc (diff)
downloadgentoo-43138c41b9334e85b5e80508eda81cdeecf0d4b6.tar.gz
gentoo-43138c41b9334e85b5e80508eda81cdeecf0d4b6.tar.bz2
gentoo-43138c41b9334e85b5e80508eda81cdeecf0d4b6.zip
app-misc/ckermit: version bump to 9.0.302
Closes: https://bugs.gentoo.org/408335 Closes: https://bugs.gentoo.org/669332 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-misc/ckermit')
-rw-r--r--app-misc/ckermit/Manifest1
-rw-r--r--app-misc/ckermit/ckermit-9.0.302.ebuild76
-rw-r--r--app-misc/ckermit/files/ckermit-9.0.302-cleanup.patch94
3 files changed, 171 insertions, 0 deletions
diff --git a/app-misc/ckermit/Manifest b/app-misc/ckermit/Manifest
index 8b5eb7828330..af4966e9a0c1 100644
--- a/app-misc/ckermit/Manifest
+++ b/app-misc/ckermit/Manifest
@@ -1 +1,2 @@
DIST cku211.tar.gz 2878523 BLAKE2B d87164bcd2e11c1146729ff423d8e631599da81bb4544dee3890d6f28d341412c93d228d954935c6321c0a32d67b73c5895d311f761919d5f95ff9114578d137 SHA512 470bf56d5b5f30721d0030ff89a5cd845f365dba81d097942524cc04dd620070678d278d1009fb67bae3cb875715808cbbfc7c0358b9671f30c65ce1d9bd35ad
+DIST cku302.tar.gz 3122219 BLAKE2B 9f63261da2dc2b0fceb0af0fa81da63c87e68b7bf713037cf8675abeb81716fd0dd4cd1f84324562698d9b9126f26b8a651dc79deec37a056fa1047af2d9966e SHA512 2cfc264e5262d29618fdf218fd3407fd9049b16110972cdddb03d114703b7a0ea13c4b0a354f50c2a9f70d4727732fe4d1920b5c656f969bc56c1eb9dc3c43fa
diff --git a/app-misc/ckermit/ckermit-9.0.302.ebuild b/app-misc/ckermit/ckermit-9.0.302.ebuild
new file mode 100644
index 000000000000..8c7e12e0f401
--- /dev/null
+++ b/app-misc/ckermit/ckermit-9.0.302.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic toolchain-funcs
+
+# Columbia University only uses the third component, e.g. cku211.tar.gz for
+# what we would call 8.0.211.
+MY_P="cku$(ver_cut 3)"
+
+DESCRIPTION="combined serial and network communication software package"
+SRC_URI="ftp://kermit.columbia.edu/kermit/archives/${MY_P}.tar.gz"
+HOMEPAGE="http://www.kermitproject.org/"
+
+LICENSE="Kermit"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="ncurses"
+
+DEPEND="ncurses? ( >=sys-libs/ncurses-5.2:= )"
+RDEPEND="${DEPEND}
+ net-dialup/lrzsz"
+
+S=${WORKDIR}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cleanup.patch
+ "${FILESDIR}"/${PN}-8.0.211-build-wart.patch
+)
+
+src_prepare() {
+ default
+
+ tc-export_build_env BUILD_CC
+ sed -i -r \
+ -e 's:"(CC2?) = gcc":"\1=$(CC)":g' \
+ -e 's:"CFLAGS = -O:"CFLAGS = $(CFLAGS):' \
+ makefile || die
+}
+
+src_compile() {
+ # we don't enable any of the telnet/ftp authentication stuff
+ # since there are other packages which do these things better
+ # USE="kerberos pam shadow ssl zlib"
+ append-cppflags -DNO_AUTHENTICATION -DNOLOGIN -DNOFTP
+
+ if use ncurses; then
+ append-cppflags "-DCK_NCURSES"
+ append-cppflags "$($(tc-getPKG_CONFIG) --cflags ncurses)"
+ append-libs "$($(tc-getPKG_CONFIG) --libs ncurses)"
+ fi
+
+ append-cppflags -DHAVE_PTMX -D_XOPEN_SOURCE -D_BSD_SOURCE -D_DEFAULT_SOURCE #202840
+ append-cppflags -DHAVE_CRYPT_H -DHAVE_OPENPTY
+ append-cppflags -DNOARROWKEYS # bug #669332
+ emake \
+ CC="$(tc-getCC)" \
+ KFLAGS="${CPPFLAGS}" \
+ LIBS="-lcrypt -lresolv -lutil ${LIBS}" \
+ LNKFLAGS="${LDFLAGS}" \
+ linuxa
+}
+
+src_install() {
+ emake DESTDIR="${ED}" prefix=/usr manroot=/usr/share install
+ dodoc *.txt
+
+ # make the correct symlink
+ rm "${ED}"/usr/bin/kermit-sshsub || die
+ dosym kermit /usr/bin/kermit-sshsub
+
+ # the ckermit.ini script is calling the wrong kermit binary --
+ # the one from ${D}
+ sed -i "s:${D}::g" "${ED}"/usr/bin/ckermit.ini
+}
diff --git a/app-misc/ckermit/files/ckermit-9.0.302-cleanup.patch b/app-misc/ckermit/files/ckermit-9.0.302-cleanup.patch
new file mode 100644
index 000000000000..c645e75da835
--- /dev/null
+++ b/app-misc/ckermit/files/ckermit-9.0.302-cleanup.patch
@@ -0,0 +1,94 @@
+Various clean-ups and fix makefile dir creation.
+
+--- cku302/ckcmai.c
++++ cku302/ckcmai.c
+@@ -561,6 +561,8 @@
+ #include "ckntap.h"
+ #endif /* NT */
+
++#include <time.h>
++
+ #ifndef NOSERVER
+ /* Text message definitions.. each should be 256 chars long, or less. */
+ #ifdef MINIX
+--- cku302/ckuus5.c
++++ cku302/ckuus5.c
+@@ -7853,7 +7853,7 @@
+ printf(" --bannerfile=%s\n",bannerfile ? bannerfile : "(null)");
+ printf(" --cdfile:%s\n",cdmsgstr ? cdmsgstr : "(null)");
+ printf(" --cdmessage:%d\n",srvcdmsg);
+- printf(" --helpfile:%d\n",helpfile);
++ printf(" --helpfile:%s\n",helpfile ? helpfile : "(null)");
+ if (inserver) {
+ printf("\n");
+ break;
+--- cku302/ckuusx.c
++++ cku302/ckuusx.c
+@@ -57,7 +57,6 @@
+ #include <termcap.h>
+ #endif /* NOHTERMCAP */
+ #endif /* BSD44 */
+-#else /* !BSD44 */
+ #ifdef linux
+ #include <term.h>
+ #endif /* linux */
+--- cku302/makefile
++++ cku302/makefile
+@@ -1047,7 +1047,7 @@
+ else\
+ echo "Creating $(DESTDIR)...";\
+ DESTDIR=`echo $(DESTDIR) | sed 's!/*$$!!'`;\
+- mkdir $$DESTDIR || exit 1;\
++ mkdir -p $$DESTDIR || exit 1;\
+ fi;\
+ chmod 755 $(DESTDIR) || exit 1;\
+ fi;\
+@@ -1066,7 +1066,7 @@
+ echo "$(DESTDIR)$(BINDIR) exists...";\
+ else\
+ echo "Creating $(DESTDIR)$(BINDIR)/...";\
+- mkdir $(DESTDIR)$(BINDIR) || exit 1;\
++ mkdir -p $(DESTDIR)$(BINDIR) || exit 1;\
+ chmod 755 $(DESTDIR)$(BINDIR);\
+ fi;\
+ rm -f $(DESTDIR)$(BINDIR)/kermit;\
+@@ -1104,9 +1104,9 @@
+ if test -d $(DESTDIR)$(MANDIR); then\
+ echo "$(DESTDIR)$(MANDIR) exists...";\
+ else\
+- echo "Creating $(MANDIR)...";\
+- mkdir $(MANDIR) || exit 1;\
+- chmod 755 $(MANDIR) || exit 1;\
++ echo "Creating $(DESTDIR)$(MANDIR)...";\
++ mkdir -p $(DESTDIR)$(MANDIR) || exit 1;\
++ chmod 755 $(DESTDIR)$(MANDIR) || exit 1;\
+ fi;\
+ rm -f $(DESTDIR)$(MANDIR)/kermit.$(MANEXT);\
+ cp ckuker.nr $(DESTDIR)$(MANDIR)/kermit.$(MANEXT) || exit 1;\
+@@ -1125,7 +1125,7 @@
+ echo "$(CERTDIR) exists...";\
+ else\
+ echo "Creating $(CERTDIR)...";\
+- mkdir $(CERTDIR) || exit 1;\
++ mkdir -p $(CERTDIR) || exit 1;\
+ chmod 755 $(CERTDIR) || exit 1;\
+ fi;\
+ echo "Installing certificates file...";\
+@@ -1146,7 +1146,7 @@
+ echo "$(DESTDIR)$(SRCDIR) exists...";\
+ else\
+ echo "Creating $(DESTDIR)$(SRCDIR)/...";\
+- mkdir $(DESTDIR)$(SRCDIR) || exit 1;\
++ mkdir -p $(DESTDIR)$(SRCDIR) || exit 1;\
+ chmod 755 $(DESTDIR)$(SRCDIR);\
+ fi;\
+ echo "Copying source files to $(DESTDIR)$(SRCDIR)...";\
+@@ -1168,7 +1168,7 @@
+ echo "$(DESTDIR)$(INFODIR) exists...";\
+ else\
+ echo "Creating $(DESTDIR)$(INFODIR)/...";\
+- mkdir $(DESTDIR)$(INFODIR) || exit 1;\
++ mkdir -p $(DESTDIR)$(INFODIR) || exit 1;\
+ chmod 755 $(DESTDIR)$(INFODIR);\
+ fi;\
+ echo "Copying text files to $(DESTDIR)$(INFODIR)...";\