summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-mobilephone/anyremote
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-mobilephone/anyremote')
-rw-r--r--app-mobilephone/anyremote/Manifest2
-rw-r--r--app-mobilephone/anyremote/anyremote-6.4.ebuild26
-rw-r--r--app-mobilephone/anyremote/anyremote-6.5.ebuild46
-rw-r--r--app-mobilephone/anyremote/metadata.xml10
4 files changed, 84 insertions, 0 deletions
diff --git a/app-mobilephone/anyremote/Manifest b/app-mobilephone/anyremote/Manifest
new file mode 100644
index 000000000000..3cb998023789
--- /dev/null
+++ b/app-mobilephone/anyremote/Manifest
@@ -0,0 +1,2 @@
+DIST anyremote-6.4.tar.gz 2425993 SHA256 342eee7efdb88925d3729553db6d6314bdc6063b51d317931864f77a46254574 SHA512 7baf48e01356dd6f325ca62e005e04af22b4959f95bffb9144327c40ae6a9ebb295f3aab8b638fbf98439fdf748cd1bcb4fd8d3399f81827b657fe9a7311eae8 WHIRLPOOL b183e05e1826215ccdb15bedfc9faffca2be8cbce81fe355cdfe9479b8d267cd76e005909174cbeaddfd9b7992ee8f96cbd6a82271281f08738999a26680f3a3
+DIST anyremote-6.5.tar.gz 2440051 SHA256 e94cd12bd6c1a04f1f0107266fcfa46d8d8e04d3872c22e76346bea192c31225 SHA512 e6190ec9ea4c66b7b85d77a9e056aeaf83d9730356780e9a54c0d27e31ce89399564b20e4bd62543aa72771049f34d359111d2c015e15fca5891d088391d2b73 WHIRLPOOL bbffc9d3dc662f086d4c4c6fa4a7edc2e86efc60e1c2588e46c3489ff5ecfd5ef93dd54f42c67a3d8f6e17f11565addef6cce75ab2154f229482403dd1aa0c62
diff --git a/app-mobilephone/anyremote/anyremote-6.4.ebuild b/app-mobilephone/anyremote/anyremote-6.4.ebuild
new file mode 100644
index 000000000000..9b586735c3b5
--- /dev/null
+++ b/app-mobilephone/anyremote/anyremote-6.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Anyremote provides wireless bluetooth, infrared or cable remote control service"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="bluetooth dbus"
+
+RDEPEND="bluetooth? ( net-wireless/bluez )
+ dbus? ( sys-apps/dbus )
+ x11-libs/libXtst"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS ChangeLog NEWS README)
+src_configure() {
+ econf --docdir="/usr/share/doc/${PF}/" $(use_enable bluetooth) $(use_enable dbus)
+}
diff --git a/app-mobilephone/anyremote/anyremote-6.5.ebuild b/app-mobilephone/anyremote/anyremote-6.5.ebuild
new file mode 100644
index 000000000000..9ebe7e340238
--- /dev/null
+++ b/app-mobilephone/anyremote/anyremote-6.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Bluetooth, infrared or cable remote control service"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="avahi bluetooth dbus"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/libX11
+ x11-libs/libXtst
+ avahi? ( net-dns/avahi )
+ bluetooth? ( net-wireless/bluez )
+ dbus? (
+ dev-libs/dbus-glib
+ sys-apps/dbus
+ )
+"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}/" \
+ $(use_enable avahi) \
+ $(use_enable bluetooth) \
+ $(use_enable dbus)
+}
+
+src_install() {
+ default
+
+ mv "${ED}"/usr/share/doc/${PF}/{doc-html,html} || die
+}
diff --git a/app-mobilephone/anyremote/metadata.xml b/app-mobilephone/anyremote/metadata.xml
new file mode 100644
index 000000000000..5ee3c69b838f
--- /dev/null
+++ b/app-mobilephone/anyremote/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">anyremote</remote-id>
+ </upstream>
+</pkgmetadata>