summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-mobilephone/smstools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-mobilephone/smstools')
-rw-r--r--app-mobilephone/smstools/Manifest1
-rw-r--r--app-mobilephone/smstools/files/2.2.1-skip-dirlock.patch38
-rw-r--r--app-mobilephone/smstools/files/2.2.13-sendsms-chmod.patch9
-rw-r--r--app-mobilephone/smstools/files/3.1.15-makefile-whitespace.patch11
-rwxr-xr-xapp-mobilephone/smstools/files/smsd.initd21
-rw-r--r--app-mobilephone/smstools/files/smsd.initd222
-rw-r--r--app-mobilephone/smstools/files/smsd.initd331
-rw-r--r--app-mobilephone/smstools/files/smsd.service11
-rw-r--r--app-mobilephone/smstools/files/smsd.tmpfiles1
-rw-r--r--app-mobilephone/smstools/metadata.xml11
-rw-r--r--app-mobilephone/smstools/smstools-3.1.15-r1.ebuild73
-rw-r--r--app-mobilephone/smstools/smstools-3.1.15-r2.ebuild74
12 files changed, 303 insertions, 0 deletions
diff --git a/app-mobilephone/smstools/Manifest b/app-mobilephone/smstools/Manifest
new file mode 100644
index 000000000000..e51e3fdb0e24
--- /dev/null
+++ b/app-mobilephone/smstools/Manifest
@@ -0,0 +1 @@
+DIST smstools3-3.1.15.tar.gz 300088 SHA256 ed00ffaeaa312a5b4f969f4e97a64603a866bbe16e393ea02f5bf05234814d59 SHA512 6a4cc852327fac27b00fc58def4bbc8caa395552586fe1b84f0f4a9f7f6b00008943b85c86de0821036629c58cf04840a189d711b4ac96f7ddaafd6b340b11fa WHIRLPOOL b394c4c620622dcfdf1d0b098a51f589ee59869fbd58c0b778e51f76335a396c3d4972423374f2ee191263cf7c350cf2432e0b120f594f77f17cdbbcc4b4e974
diff --git a/app-mobilephone/smstools/files/2.2.1-skip-dirlock.patch b/app-mobilephone/smstools/files/2.2.1-skip-dirlock.patch
new file mode 100644
index 000000000000..64336eed98a1
--- /dev/null
+++ b/app-mobilephone/smstools/files/2.2.1-skip-dirlock.patch
@@ -0,0 +1,38 @@
+--- src/extras.c.orig 2006-06-15 10:45:59.000000000 +0100
++++ src/extras.c 2006-06-15 10:45:39.000000000 +0100
+@@ -178,20 +178,21 @@
+ stat(filename,&statbuf);
+ if (S_ISDIR(statbuf.st_mode)==0) /* Is this a directory? */
+ {
+- /* File found, check for lock file */
+- if (strstr(filename,".LOCK")==0) /* Is the file a lock file itself? */
+- if (!islocked(filename)) /* no, is there a lock file for this file? */
+- {
+- /* check if the file grows at the moment (another program writes to it) */
+- int groesse1;
+- int groesse2;
+- groesse1=statbuf.st_size;
+- sleep(1);
+- stat(filename,&statbuf);
+- groesse2=statbuf.st_size;
+- if (groesse1==groesse2)
+- found=1;
+- }
++ /* File found, check for lock file and skip portage directory locks */
++ if (strstr(filename,".keep")==0) /* Is it a portage directory lock? */
++ if (strstr(filename,".LOCK")==0) /* Is the file a lock file itself? */
++ if (!islocked(filename)) /* no, is there a lock file for this file? */
++ {
++ /* check if the file grows at the moment (another program writes to it) */
++ int groesse1;
++ int groesse2;
++ groesse1=statbuf.st_size;
++ sleep(1);
++ stat(filename,&statbuf);
++ groesse2=statbuf.st_size;
++ if (groesse1==groesse2)
++ found=1;
++ }
+ }
+ }
+ closedir(dirdata);
diff --git a/app-mobilephone/smstools/files/2.2.13-sendsms-chmod.patch b/app-mobilephone/smstools/files/2.2.13-sendsms-chmod.patch
new file mode 100644
index 000000000000..716e316c487e
--- /dev/null
+++ b/app-mobilephone/smstools/files/2.2.13-sendsms-chmod.patch
@@ -0,0 +1,9 @@
+diff -uNr smstools.ORIG/scripts/sendsms smstools/scripts/sendsms
+--- smstools.ORIG/scripts/sendsms 2006-12-02 15:26:09.000000000 +0000
++++ smstools/scripts/sendsms 2006-12-02 15:26:52.000000000 +0000
+@@ -26,3 +26,5 @@
+ echo "" >> $FILE
+ echo -n "$TEXT" >> $FILE
+
++chmod 660 $FILE
++
diff --git a/app-mobilephone/smstools/files/3.1.15-makefile-whitespace.patch b/app-mobilephone/smstools/files/3.1.15-makefile-whitespace.patch
new file mode 100644
index 000000000000..70455bef6c56
--- /dev/null
+++ b/app-mobilephone/smstools/files/3.1.15-makefile-whitespace.patch
@@ -0,0 +1,11 @@
+--- smstools3/src/Makefile.old 2014-04-25 23:28:46.324045112 +1000
++++ smstools3/src/Makefile 2014-04-25 23:33:26.453061496 +1000
+@@ -43,7 +43,7 @@
+
+ ifneq (,$(findstring SOLARIS,$(CFLAGS)))
+ ifeq (,$(findstring DISABLE_INET_SOCKET,$(CFLAGS)))
+-override LFLAGS += -lsocket -lnsl
++ override LFLAGS += -lsocket -lnsl
+ endif
+ endif
+
diff --git a/app-mobilephone/smstools/files/smsd.initd b/app-mobilephone/smstools/files/smsd.initd
new file mode 100755
index 000000000000..849449dc48bc
--- /dev/null
+++ b/app-mobilephone/smstools/files/smsd.initd
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need localmount
+}
+
+start() {
+ ebegin "Starting smsd"
+ start-stop-daemon -b -m -p /var/run/smsd.pid -c smsd:sms --start --exec /usr/bin/smsd -- \
+ -c /etc/smsd.conf
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping smsd"
+ start-stop-daemon --stop -p /var/run/smsd.pid
+ eend ${?}
+}
diff --git a/app-mobilephone/smstools/files/smsd.initd2 b/app-mobilephone/smstools/files/smsd.initd2
new file mode 100644
index 000000000000..b6117ab1abf5
--- /dev/null
+++ b/app-mobilephone/smstools/files/smsd.initd2
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need localmount
+}
+
+start() {
+ chown smsd:sms /var/log/smsd.log
+ ebegin "Starting smsd"
+ start-stop-daemon -b -u smsd:sms --start --exec /usr/bin/smsd -- \
+ -c /etc/smsd.conf
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping smsd"
+ start-stop-daemon --stop -n smsd
+ eend ${?}
+}
diff --git a/app-mobilephone/smstools/files/smsd.initd3 b/app-mobilephone/smstools/files/smsd.initd3
new file mode 100644
index 000000000000..1f585946a448
--- /dev/null
+++ b/app-mobilephone/smstools/files/smsd.initd3
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need localmount
+}
+
+start() {
+ if ! [ -d /var/run/smsd ]; then
+ ebegin "Creating /var/run/smsd for ${SVCNAME}"
+ mkdir /var/run/smsd \
+ && chown smsd:sms /var/run/smsd \
+ && chmod 770 /var/run/smsd
+ eend $?
+ fi
+
+ chown smsd:sms /var/log/smsd.log
+ ebegin "Starting smsd"
+ start-stop-daemon -b -u smsd:sms --start --exec /usr/bin/smsd -- \
+ -c /etc/smsd.conf -p /var/run/smsd/smsd.pid \
+ -i /var/run/smsd/smsd.working
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping smsd"
+ start-stop-daemon --stop -n smsd
+ eend ${?}
+}
diff --git a/app-mobilephone/smstools/files/smsd.service b/app-mobilephone/smstools/files/smsd.service
new file mode 100644
index 000000000000..1fb436681b4b
--- /dev/null
+++ b/app-mobilephone/smstools/files/smsd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=SMS Server Tools 3
+
+[Service]
+User=smsd
+PIDFile=/run/smsd/smsd.pid
+ExecStart=/usr/bin/smsd -n MAINPROCESS -l/var/log/smsd.log \
+ -p/run/smsd/smsd.pid -i/run/smsd/smsd.working
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-mobilephone/smstools/files/smsd.tmpfiles b/app-mobilephone/smstools/files/smsd.tmpfiles
new file mode 100644
index 000000000000..8978d18f54ad
--- /dev/null
+++ b/app-mobilephone/smstools/files/smsd.tmpfiles
@@ -0,0 +1 @@
+d /run/smsd 0755 smsd sms -
diff --git a/app-mobilephone/smstools/metadata.xml b/app-mobilephone/smstools/metadata.xml
new file mode 100644
index 000000000000..eae00d6bb352
--- /dev/null
+++ b/app-mobilephone/smstools/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+</maintainer>
+<use>
+ <flag name='stats'>Enable statistic reporting</flag>
+</use>
+</pkgmetadata>
diff --git a/app-mobilephone/smstools/smstools-3.1.15-r1.ebuild b/app-mobilephone/smstools/smstools-3.1.15-r1.ebuild
new file mode 100644
index 000000000000..0139828c7ad8
--- /dev/null
+++ b/app-mobilephone/smstools/smstools-3.1.15-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit systemd toolchain-funcs user
+
+DESCRIPTION="Send and receive short messages through GSM modems"
+HOMEPAGE="http://smstools3.kekekasvi.com/"
+SRC_URI="http://smstools3.kekekasvi.com/packages/smstools3-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="stats"
+
+DEPEND=""
+RDEPEND="sys-process/procps
+ stats? ( >=dev-libs/mm-1.4.0 )"
+
+S="${WORKDIR}/${PN}3"
+
+pkg_setup() {
+ enewgroup sms
+ enewuser smsd -1 -1 /var/spool/sms sms
+}
+
+src_prepare() {
+ if use stats; then
+ sed -i -e "s:CFLAGS += -D NOSTATS:#CFLAGS += -D NOSTATS:" \
+ "${S}/src/Makefile" || die
+ fi
+ echo "CFLAGS += ${CFLAGS}" >> src/Makefile || die
+}
+
+src_compile() {
+ cd src || die
+ emake \
+ CC="$(tc-getCC)" \
+ LFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin src/smsd
+ cd scripts || die
+ dobin sendsms sms2html sms2unicode unicode2sms
+ dobin hex2bin hex2dec email2sms
+ dodoc mysmsd smsevent smsresend sms2xml sql_demo \
+ smstest.php checkhandler-utf-8 eventhandler-utf-8 \
+ forwardsms regular_run
+ cd .. || die
+
+ keepdir /var/spool/sms/incoming
+ keepdir /var/spool/sms/outgoing
+ keepdir /var/spool/sms/checked
+ fowners -R smsd:sms /var/spool/sms
+ fperms g+s /var/spool/sms/incoming
+
+ newinitd "${FILESDIR}"/smsd.initd3 smsd
+ insopts -o smsd -g sms -m0644
+ insinto /etc
+ newins examples/smsd.conf.easy smsd.conf
+ dohtml -r doc
+
+ systemd_dounit "${FILESDIR}"/smsd.service
+ systemd_newtmpfilesd "${FILESDIR}"/smsd.tmpfiles smsd.conf
+}
+
+pkg_postinst() {
+ touch "${ROOT}"/var/log/smsd.log || die
+ chown -f smsd:sms "${ROOT}"/var/log/smsd.log
+}
diff --git a/app-mobilephone/smstools/smstools-3.1.15-r2.ebuild b/app-mobilephone/smstools/smstools-3.1.15-r2.ebuild
new file mode 100644
index 000000000000..ee74fa92f8e4
--- /dev/null
+++ b/app-mobilephone/smstools/smstools-3.1.15-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit systemd toolchain-funcs user eutils
+
+DESCRIPTION="Send and receive short messages through GSM modems"
+HOMEPAGE="http://smstools3.kekekasvi.com/"
+SRC_URI="http://smstools3.kekekasvi.com/packages/smstools3-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="stats"
+
+DEPEND=""
+RDEPEND="sys-process/procps
+ stats? ( >=dev-libs/mm-1.4.0 )"
+
+S="${WORKDIR}/${PN}3"
+
+pkg_setup() {
+ enewgroup sms
+ enewuser smsd -1 -1 /var/spool/sms sms
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-makefile-whitespace.patch"
+ if use stats; then
+ sed -i -e "s:CFLAGS += -D NOSTATS:#CFLAGS += -D NOSTATS:" \
+ "${S}/src/Makefile" || die
+ fi
+ echo "CFLAGS += ${CFLAGS}" >> src/Makefile || die
+}
+
+src_compile() {
+ cd src || die
+ emake \
+ CC="$(tc-getCC)" \
+ LFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin src/smsd
+ cd scripts || die
+ dobin sendsms sms2html sms2unicode unicode2sms
+ dobin hex2bin hex2dec email2sms
+ dodoc mysmsd smsevent smsresend sms2xml sql_demo \
+ smstest.php checkhandler-utf-8 eventhandler-utf-8 \
+ forwardsms regular_run
+ cd .. || die
+
+ keepdir /var/spool/sms/incoming
+ keepdir /var/spool/sms/outgoing
+ keepdir /var/spool/sms/checked
+ fowners -R smsd:sms /var/spool/sms
+ fperms g+s /var/spool/sms/incoming
+
+ newinitd "${FILESDIR}"/smsd.initd3 smsd
+ insopts -o smsd -g sms -m0644
+ insinto /etc
+ newins examples/smsd.conf.easy smsd.conf
+ dohtml -r doc
+
+ systemd_dounit "${FILESDIR}"/smsd.service
+ systemd_newtmpfilesd "${FILESDIR}"/smsd.tmpfiles smsd.conf
+}
+
+pkg_postinst() {
+ touch "${ROOT}"/var/log/smsd.log || die
+ chown -f smsd:sms "${ROOT}"/var/log/smsd.log
+}