summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-04-19 23:10:47 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-19 23:10:47 +0300
commit0f773782d7345b58b7b186ee3e1b2db77b0ae3e0 (patch)
treed11b7661b39897fd3757a6de4bf0f6429772b9d1 /app-office
parentdev-python/beartype: add 0.18.4 (diff)
downloadgentoo-0f773782d7345b58b7b186ee3e1b2db77b0ae3e0.tar.gz
gentoo-0f773782d7345b58b7b186ee3e1b2db77b0ae3e0.tar.bz2
gentoo-0f773782d7345b58b7b186ee3e1b2db77b0ae3e0.zip
app-office/worklog-assistant-bin: add 2.3.3900, EAPI=8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/worklog-assistant-bin/Manifest1
-rw-r--r--app-office/worklog-assistant-bin/worklog-assistant-bin-2.3.3900.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-office/worklog-assistant-bin/Manifest b/app-office/worklog-assistant-bin/Manifest
index f9b1a12cb294..be09db0e3d16 100644
--- a/app-office/worklog-assistant-bin/Manifest
+++ b/app-office/worklog-assistant-bin/Manifest
@@ -1 +1,2 @@
DIST worklog-assistant-v2_2.1.3580_amd64.deb 31434440 BLAKE2B 44a85e3cefa652fac6d01d2b3dc0e1a32128d8c7e27b6177d2c3187b97011cf5cce7493d67e9f989e034f26bd88589e3d9960232a5da2dbadf909c26bede2ce9 SHA512 cac38acfd7e00a57f6869d1205920a27f5e6cc0525b09cc7b76350df38d5b6dd673779df22fdf55e8e327cb591a1c4738fe23645a6e42b6d2753af2eb330a646
+DIST worklog-assistant-v2_2.3.3900_amd64.deb 38333978 BLAKE2B 5e12d4ddaf6354e817959752fddf6b9409a47c3dd32de4c8e946ab9dc3c2d44333f43de77fe575300520070d65f6e22bb1f521eda22d3b572585758b92f1c4c9 SHA512 94b2c16e6e802fbe240f58f115626018e3d63feed8704fd6769d21657b6bf98387f325d4986ed4b096e7ca11d9c55b8dd6a471ccc57e68fd2c60bbca16a10ebb
diff --git a/app-office/worklog-assistant-bin/worklog-assistant-bin-2.3.3900.ebuild b/app-office/worklog-assistant-bin/worklog-assistant-bin-2.3.3900.ebuild
new file mode 100644
index 000000000000..1d0c08bba197
--- /dev/null
+++ b/app-office/worklog-assistant-bin/worklog-assistant-bin-2.3.3900.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Hassle-free time tracking for JIRA self-hosted and OnDemand"
+HOMEPAGE="https://worklogassistant.com"
+SRC_URI="https://worklogassistant.com/downloads/${PN%-bin}-v2_${PV}_amd64.deb"
+S=${WORKDIR}
+
+LICENSE="worklog-assistant"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="fetch bindist strip"
+
+QA_PREBUILT="opt/Worklog Assistant/*"
+
+src_prepare() {
+ default
+
+ rm -r etc/ || die
+}
+
+src_install() {
+ mv * "${ED}" || die
+
+ dosym -r "/opt/Worklog Assistant/bin/Worklog Assistant" /opt/bin/WorklogAssistant
+}