summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/gnupod
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/gnupod')
-rw-r--r--app-pda/gnupod/Manifest1
-rw-r--r--app-pda/gnupod/gnupod-0.99.8-r1.ebuild53
-rw-r--r--app-pda/gnupod/metadata.xml5
3 files changed, 59 insertions, 0 deletions
diff --git a/app-pda/gnupod/Manifest b/app-pda/gnupod/Manifest
new file mode 100644
index 000000000000..0221334d5db3
--- /dev/null
+++ b/app-pda/gnupod/Manifest
@@ -0,0 +1 @@
+DIST gnupod-0.99.8.tgz 207572 SHA256 bd566295a2e14352e6d05f5c816cab36b0e80d3ab36d29c4bbb45c581d3f3c31 SHA512 ac9ceadff371e052b6deb4067aa73e190ad109feb3337cc205d521fbab11b5bc1415e44907761711eeaaf7fcea6a1a841c08e2177fa912446cfe7495d2a5182b WHIRLPOOL 30a05398864c61f46621021cc1e6d5784651d690574ffef344c2df9cb4e4b6b74571a0b2b962502126170a42adea77a519351a615af0adccd4882e8d13834c93
diff --git a/app-pda/gnupod/gnupod-0.99.8-r1.ebuild b/app-pda/gnupod/gnupod-0.99.8-r1.ebuild
new file mode 100644
index 000000000000..0d46b9097087
--- /dev/null
+++ b/app-pda/gnupod/gnupod-0.99.8-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="A collection of Perl-scripts for iPod"
+HOMEPAGE="http://www.gnu.org/software/gnupod/"
+SRC_URI="http://blinkenlights.ch/gnupod-dist/stable/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="aac ffmpeg flac mp3 ogg"
+
+RDEPEND="dev-perl/TimeDate
+ dev-perl/XML-Parser
+ >=dev-perl/MP3-Info-1.01
+ dev-perl/Unicode-String
+ dev-perl/Digest-SHA1
+ dev-perl/libwww-perl
+ ffmpeg? ( virtual/ffmpeg )
+ flac? ( dev-perl/Audio-FLAC-Header
+ media-libs/flac
+ aac? ( >=media-libs/faac-1.24 )
+ mp3? ( media-sound/lame )
+ !aac? ( media-sound/lame ) )
+ ogg? ( dev-perl/Ogg-Vorbis-Header-PurePerl
+ media-sound/vorbis-tools
+ aac? ( >=media-libs/faac-1.24 )
+ mp3? ( media-sound/lame )
+ !aac? ( media-sound/lame ) )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf
+}
+
+src_install() {
+ perl_set_version
+ sed -i -e "s:\$INC\[0\]/\$modi:${D}${VENDOR_ARCH}/\$modi:g" \
+ tools/gnupod_install.pl || die
+
+ dodir /usr/bin
+ dodir ${VENDOR_ARCH}/GNUpod
+ dodir /usr/share/info
+ einstall
+
+ dodoc CHANGES README* doc/gnupodrc.example doc/gnutunesdb.example
+ dohtml doc/gnupod.html
+}
diff --git a/app-pda/gnupod/metadata.xml b/app-pda/gnupod/metadata.xml
new file mode 100644
index 000000000000..228404d3a4b2
--- /dev/null
+++ b/app-pda/gnupod/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>pda</herd>
+</pkgmetadata>