summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/iripdb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/iripdb')
-rw-r--r--app-pda/iripdb/Manifest1
-rw-r--r--app-pda/iripdb/iripdb-0.1.3b.ebuild34
-rw-r--r--app-pda/iripdb/metadata.xml15
3 files changed, 50 insertions, 0 deletions
diff --git a/app-pda/iripdb/Manifest b/app-pda/iripdb/Manifest
new file mode 100644
index 000000000000..8040c877321f
--- /dev/null
+++ b/app-pda/iripdb/Manifest
@@ -0,0 +1 @@
+DIST iRipDB-0.1.3b.zip 32000 SHA256 cbaaeed9549805009801160003473fc1e8899aa8531167ca95a5acb6fccd4f17 SHA512 7d3811e12a8570a07d2381bf6e97c9818b0da5b38dca95fc66441635343d827395d16fcdc7cea49179c062888ecbd88722f379ed59664919e10050618e66e8d5 WHIRLPOOL 0a06fd34526a78d12c2761f54150033c6d0487f7a4324319553fde90ddadecd17eb4738932ba5c57c457837a7b5da774b62fe84c3c4ac6bf57ea33e4c59111f8
diff --git a/app-pda/iripdb/iripdb-0.1.3b.ebuild b/app-pda/iripdb/iripdb-0.1.3b.ebuild
new file mode 100644
index 000000000000..075396afd75c
--- /dev/null
+++ b/app-pda/iripdb/iripdb-0.1.3b.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/iripdb/iRipDB}
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="iRipDB allows generating the DB files necessary for the iRiver iHP-1xx series of MP3/Ogg HD Players"
+HOMEPAGE="http://www.fataltourist.com/iripdb/"
+SRC_URI="http://www.fataltourist.com/iripdb/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+RDEPEND="media-libs/taglib
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_compile() {
+ echo "$(tc-getCXX) ${CXXFLAGS} -c -o main.o main.cpp"
+ $(tc-getCXX) ${CXXFLAGS} -c -o main.o -I/usr/include/taglib main.cpp
+ echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS} -o iripdb main.o -lz -lm -ltag -lstdc++"
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o iripdb main.o -lz -lm -ltag -lstdc++
+}
+
+src_install() {
+ dobin iripdb || die
+ dodoc AUTHORS README doc/iRivDB_structure || die
+}
diff --git a/app-pda/iripdb/metadata.xml b/app-pda/iripdb/metadata.xml
new file mode 100644
index 000000000000..15c9404f4888
--- /dev/null
+++ b/app-pda/iripdb/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+ <longdescription lang="en">
+ iRipDB allows generating the DB files necessary for the iRiver iHP-1xx
+ series of MP3/Ogg HD Player on Linux and Windows. That will allow you
+ to navigate your files through the artist/album/genre menus. It supports
+ adding MP3 and Ogg files at this point. It's released under the GNU's
+ General Public License and, at this moment only in source code form.
+ </longdescription>
+</pkgmetadata>