summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-02-23 12:59:19 -0600
committerBen Kohler <bkohler@gentoo.org>2021-02-24 07:54:16 -0600
commit28c1813cbde2be3b1e95700d7a1e3a1327616c01 (patch)
tree5b814f20bd2da0a9e10c8e48c395acea3839e4b8 /app-portage
parentpackage.mask: unmask signal-desktop-bin (diff)
downloadgentoo-28c1813cbde2be3b1e95700d7a1e3a1327616c01.tar.gz
gentoo-28c1813cbde2be3b1e95700d7a1e3a1327616c01.tar.bz2
gentoo-28c1813cbde2be3b1e95700d7a1e3a1327616c01.zip
app-portage/elogviewer: bump to 3.1, add python3_9 support
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/elogviewer/Manifest1
-rw-r--r--app-portage/elogviewer/elogviewer-3.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-portage/elogviewer/Manifest b/app-portage/elogviewer/Manifest
index df98e588981b..711cefee880c 100644
--- a/app-portage/elogviewer/Manifest
+++ b/app-portage/elogviewer/Manifest
@@ -1 +1,2 @@
DIST elogviewer-3.0.tar.gz 28349 BLAKE2B 44f3ca5b28d075bb8349450cc817fd8ccdd1d1dc7eb948a9d65ab3b423191eca04cc479b2d6bec0bf6bc7f1120eccd257fdf61bb736919129ee756c2f4bd4366 SHA512 7eb59849a06632053ee0f7d1d76d9848220dbb8ad48d04c80fea5e64304f86c1a99987f525c6df682c832bd8453e07781a5c95ad2dee0539e954400730f47e36
+DIST elogviewer-3.1.tar.gz 28650 BLAKE2B b15d94095def5fb7fdcf77ad1e7bf1fc35af6bbd999d89b7f90bed8ef9739182c8e4af0033aee92453d6b0731ac5d8c168e3900abe0a4466d584bfd9bc64917a SHA512 b99bc165ab08755273ead73fdd3602c9266a9bb243c46d99805c1f8b07f7e8ea9b0583aedb9b7ab717461f2ed3bd27dcf0a5677f2d908d3fcc03769794a64d5b
diff --git a/app-portage/elogviewer/elogviewer-3.1.ebuild b/app-portage/elogviewer/elogviewer-3.1.ebuild
new file mode 100644
index 000000000000..7e2097ac19e0
--- /dev/null
+++ b/app-portage/elogviewer/elogviewer-3.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+DISABLE_AUTOFORMATTING=true
+
+inherit desktop python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="Elog viewer for Gentoo"
+HOMEPAGE="https://github.com/Synss/elogviewer"
+SRC_URI="https://github.com/Synss/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[gui,widgets,${PYTHON_MULTI_USEDEP}]
+ >=sys-apps/portage-2.1[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+
+DOC_CONTENTS="In order to use this software, you need to activate
+Portage's elog features. Required is
+ PORTAGE_ELOG_SYSTEM=\"save\"
+and at least one of
+ PORTAGE_ELOG_CLASSES=\"warn error info log qa\"
+More information on the elog system can be found in
+/usr/share/portage/config/make.conf.example
+
+To operate properly this software needs the directory
+${PORT_LOGDIR:-/var/log/portage}/elog created, belonging to group portage.
+To start the software as a user, add yourself to the portage group."
+
+PATCHES=( "${FILESDIR}/elogviewer-3.0-segfault.patch"
+)
+
+src_compile() {
+ rm -f Makefile
+}
+
+src_install() {
+ python_newscript elogviewer.py elogviewer
+
+ make_desktop_entry ${PN} ${PN} ${PN} System
+
+ doman elogviewer.1
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ ewarn "The elogviewer's configuration file is now saved in:"
+ ewarn "~/.config/elogviewer/ (was ~/.config/Mathias\ Laurin/)."
+ ewarn "Please migrate any user specific settings to the new config file."
+}