summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-04-18 14:44:37 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-04-19 11:57:05 +0300
commit9f100d0bf8469a87e4924464262149494c224275 (patch)
tree4f69cc5731dc2b30cf7c7567c168892ee20ee9df /app-portage
parentmedia-video/vlc: Stabilize 3.0.20-r10 arm64, #927203 (diff)
downloadgentoo-9f100d0bf8469a87e4924464262149494c224275.tar.gz
gentoo-9f100d0bf8469a87e4924464262149494c224275.tar.bz2
gentoo-9f100d0bf8469a87e4924464262149494c224275.zip
app-portage/pkg-testing-tools: add 0.2.4
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Closes: https://github.com/gentoo/gentoo/pull/36309 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/pkg-testing-tools/Manifest1
-rw-r--r--app-portage/pkg-testing-tools/pkg-testing-tools-0.2.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-portage/pkg-testing-tools/Manifest b/app-portage/pkg-testing-tools/Manifest
index 9e4440d957bc..be1e12c99c39 100644
--- a/app-portage/pkg-testing-tools/Manifest
+++ b/app-portage/pkg-testing-tools/Manifest
@@ -1,2 +1,3 @@
DIST pkg-testing-tools-0.1.2.gh.tar.gz 6180 BLAKE2B 7674573d165e8e04ef4555301bb15e6f3e7b6834096e4b9dcadf74bfc40dabcff5b694a323d6e1c62fa20d965be4f9f8c0b9459c5dacbd01f914669594aa15b4 SHA512 8d5933be8cd596089d4f8f5609d597330a1619b12f08049985b48519ecf10c3fd40971ee76b3bee793c082b8b96832aa2f5a2f6db8e1ca127a374986540e5ffc
DIST pkg-testing-tools-0.2.2.gh.tar.gz 10896 BLAKE2B 8b48ef2c2a6d1700869b77e84fe6af74d5a748eb56881ff3c2ce9921f942e51745bd48d6e091a3b86704b610713ba5563198c2e9b31693cae6d25972fbcdbb20 SHA512 a9d0745a828e539ff948205fdbfc34150c380d23692498aa3e0fcec0bf9f46c2a01a57f1d5cac4b44a5c1f7c3ca3c1c346d8058a6ea54c390e51bf44cd5fb612
+DIST pkg-testing-tools-0.2.4.gh.tar.gz 12361 BLAKE2B e60b322627f92ebccc33907d395763604e5531805c0ef3625c4b4511d2aa1a71dbaa71d6eb0bb2028738fcd13535fed4ffd4bdef189c528fddfbaac1d4e1044a SHA512 6dc28922940e281bbcd4fc065cb573dfb66cf0223d5aa11c514c24992512f6bf6e33200e8acb2a07ce87d648dd51844e43865b2e4bb64ed9ae9c6500259623c2
diff --git a/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.4.ebuild b/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.4.ebuild
new file mode 100644
index 000000000000..c8cd079994a1
--- /dev/null
+++ b/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Packages testing tools for Gentoo"
+HOMEPAGE="https://github.com/APN-Pucky/pkg-testing-tools"
+
+REPO=APN-Pucky
+LICENSE="BSD"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${REPO}/${PN}"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+ SRC_URI="https://github.com/APN-Pucky/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+fi
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ sys-apps/portage[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest