summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2024-05-01 14:24:13 +0200
committerDaniel Pielmeier <billie@gentoo.org>2024-05-01 14:24:13 +0200
commitfe1c95eea1941ef1d72ba9fd757927bbbae0530a (patch)
tree15c9bf582d72c89542b49cf1bf2f43c0b303501d /app-portage
parentdev-libs/libburn: drop 1.5.6 (diff)
downloadgentoo-fe1c95eea1941ef1d72ba9fd757927bbbae0530a.tar.gz
gentoo-fe1c95eea1941ef1d72ba9fd757927bbbae0530a.tar.bz2
gentoo-fe1c95eea1941ef1d72ba9fd757927bbbae0530a.zip
app-portage/pfl: drop-3.4, fix variable order
Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/pfl/Manifest1
-rw-r--r--app-portage/pfl/pfl-3.4.ebuild49
-rw-r--r--app-portage/pfl/pfl-3.5.2.ebuild4
3 files changed, 2 insertions, 52 deletions
diff --git a/app-portage/pfl/Manifest b/app-portage/pfl/Manifest
index 6968f5eba7d6..d936122f0edc 100644
--- a/app-portage/pfl/Manifest
+++ b/app-portage/pfl/Manifest
@@ -1,2 +1 @@
-DIST pfl-3.4.tar.gz 18651 BLAKE2B 09793883a1ed6f70da2f01fb81cfafa407ed43584a826f2cd8fde6d75b544ed803a220fc517e649774100da32e64d01fad8ff0dcbaff9068f57cdf7bd4414169 SHA512 c21b43f234a778d74e05cd45b7ccb48b131d6998e632d044a4bccc2f772099d02d1c5e7ab75fc6f9deb14e2f1ed1f31bac51e917e628065b4a36d73b8d77336f
DIST pfl-3.5.2.tar.gz 21248 BLAKE2B 28f4f05bc533f4b27cdbef7f2706ed99f885983e4f9e4f2580e07b772bef471eeca197a41d03059e28c2053869de4cb5295a9923dcba6f598bbf6e6be5e57185 SHA512 5f38b627cd5928396fe8202dd822756ed63b6dd80d98d1ee3da9998eb750070e9a921d652bbc7ed852e4944005f9d6c61c14c67be01c591f5c82ca50f869465e
diff --git a/app-portage/pfl/pfl-3.4.ebuild b/app-portage/pfl/pfl-3.4.ebuild
deleted file mode 100644
index 2020142b2ed2..000000000000
--- a/app-portage/pfl/pfl-3.4.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1 systemd
-
-DESCRIPTION="Searchable online file/package database for Gentoo"
-HOMEPAGE="https://www.portagefilelist.de https://github.com/portagefilelist/client"
-SRC_URI="https://github.com/portagefilelist/client/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="+network-cron"
-
-RDEPEND="
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/termcolor[${PYTHON_USEDEP}]
- sys-apps/portage[${PYTHON_USEDEP}]
- network-cron? ( sys-apps/util-linux[caps] )
-"
-
-S="${WORKDIR}/client-${PV}"
-
-python_install_all() {
- if use network-cron ; then
- exeinto /etc/cron.weekly
- doexe cron/pfl
- fi
-
- systemd_dounit systemd/pfl.{service,timer}
-
- keepdir /var/lib/${PN}
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- if [[ ! -e "${EROOT}/var/lib/${PN}/pfl.info" ]]; then
- touch "${EROOT}/var/lib/${PN}/pfl.info" || die
- fi
- chown -R portage:portage "${EROOT}/var/lib/${PN}" || die
- chmod 775 "${EROOT}/var/lib/${PN}" || die
-}
diff --git a/app-portage/pfl/pfl-3.5.2.ebuild b/app-portage/pfl/pfl-3.5.2.ebuild
index 2020142b2ed2..a3a178118186 100644
--- a/app-portage/pfl/pfl-3.5.2.ebuild
+++ b/app-portage/pfl/pfl-3.5.2.ebuild
@@ -13,6 +13,8 @@ DESCRIPTION="Searchable online file/package database for Gentoo"
HOMEPAGE="https://www.portagefilelist.de https://github.com/portagefilelist/client"
SRC_URI="https://github.com/portagefilelist/client/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/client-${PV}"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
@@ -25,8 +27,6 @@ RDEPEND="
network-cron? ( sys-apps/util-linux[caps] )
"
-S="${WORKDIR}/client-${PV}"
-
python_install_all() {
if use network-cron ; then
exeinto /etc/cron.weekly