summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-shells/push
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-shells/push')
-rw-r--r--app-shells/push/Manifest2
-rw-r--r--app-shells/push/metadata.xml22
-rw-r--r--app-shells/push/push-1.5-r1.ebuild21
-rw-r--r--app-shells/push/push-1.5.ebuild21
-rw-r--r--app-shells/push/push-1.6.ebuild21
5 files changed, 87 insertions, 0 deletions
diff --git a/app-shells/push/Manifest b/app-shells/push/Manifest
new file mode 100644
index 000000000000..9f977a2aef96
--- /dev/null
+++ b/app-shells/push/Manifest
@@ -0,0 +1,2 @@
+DIST push-1.5.tar.gz 1971 SHA256 7c9068a619bcc49e3e13f819e23e1c05464729df0529753557f23f65e922fdad SHA512 77f4afd1a8226b0b4104008fcea2a61e5c9a7930b08266e069c387c806ef86e8d5641d70ece6dfd02557c956fc916134551d10777e5730973657d767370f8a26 WHIRLPOOL e1d71d7d9369bf23fe9046a34f7c9cd4f7ff79b4db3e13a9cef089113e31f7db2ecb6ff13e899e1db7726359b68260776723f73201d3db0472d267b8db7515b2
+DIST push-1.6.tar.gz 1955 SHA256 713dea172ede55971ff82da932782503c2aa6703eba73c1ac317ec4c8eb22e80 SHA512 4623f51249138bacb7251fb5d5d1ae8dd070de7ce628e42b6eed90a4b6ffd36d28eb58b116f5b1833bc1affa8db539da9b94d104ffe03c6bd1e294b56c393c86 WHIRLPOOL 787f65542e92fd10c411969d03ec17b45a90b35e9c8e17b9fb3e732fb1d97813f04c3a03cc329a469a5bea2a194f879f4c600e2e534dd8c778f7f712d4c171b1
diff --git a/app-shells/push/metadata.xml b/app-shells/push/metadata.xml
new file mode 100644
index 000000000000..904fe4e422c6
--- /dev/null
+++ b/app-shells/push/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ <description>Upstream developer, assign bugs</description>
+ </maintainer>
+ <maintainer>
+ <email>axs@gentoo.org</email>
+ <description>Proxy committer, CC bugs</description>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/push</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/push/push-1.5-r1.ebuild b/app-shells/push/push-1.5-r1.ebuild
new file mode 100644
index 000000000000..ddf8f3624dc3
--- /dev/null
+++ b/app-shells/push/push-1.5-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit vcs-snapshot
+
+DESCRIPTION="A POSIX shell function to treat a variable like an array, quoting args"
+HOMEPAGE="https://github.com/vaeth/push/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE=""
+
+src_install() {
+ insinto /usr/bin
+ doins push.sh
+ dodoc README
+}
diff --git a/app-shells/push/push-1.5.ebuild b/app-shells/push/push-1.5.ebuild
new file mode 100644
index 000000000000..9cf5f1f1f8e3
--- /dev/null
+++ b/app-shells/push/push-1.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit vcs-snapshot
+
+DESCRIPTION="A POSIX shell function to treat a variable like an array, quoting args"
+HOMEPAGE="https://github.com/vaeth/push/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE=""
+
+src_install() {
+ insinto /usr/bin
+ doins push.sh
+ dodoc README
+}
diff --git a/app-shells/push/push-1.6.ebuild b/app-shells/push/push-1.6.ebuild
new file mode 100644
index 000000000000..d2bb450174c1
--- /dev/null
+++ b/app-shells/push/push-1.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit vcs-snapshot
+
+DESCRIPTION="A POSIX shell function to treat a variable like an array, quoting args"
+HOMEPAGE="https://github.com/vaeth/push/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE=""
+
+src_install() {
+ insinto /usr/bin
+ doins push.sh
+ dodoc README
+}