summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-24 00:31:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 11:09:36 +0100
commit8757085ff45841a5801ef65faa258bb2866233d8 (patch)
treef1892d691daa00dac9e4a11b570f96b2e4218ae0 /app-shells
parentprofiles: Unmask app-text/poppler-0.84.0 (diff)
downloadgentoo-8757085ff45841a5801ef65faa258bb2866233d8.tar.gz
gentoo-8757085ff45841a5801ef65faa258bb2866233d8.tar.bz2
gentoo-8757085ff45841a5801ef65faa258bb2866233d8.zip
*/*: Switch polynomial-c maintained packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fish/fish-3.0.2.ebuild11
-rw-r--r--app-shells/fish/fish-9999.ebuild11
2 files changed, 10 insertions, 12 deletions
diff --git a/app-shells/fish/fish-3.0.2.ebuild b/app-shells/fish/fish-3.0.2.ebuild
index 540ec26c1feb..3a16d56f7c07 100644
--- a/app-shells/fish/fish-3.0.2.ebuild
+++ b/app-shells/fish/fish-3.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils readme.gentoo-r1
+inherit cmake readme.gentoo-r1
DESCRIPTION="Friendly Interactive SHell"
HOMEPAGE="http://fishshell.com/"
@@ -45,30 +45,29 @@ src_prepare() {
# workaround for https://github.com/fish-shell/fish-shell/issues/4883
sed -i 's#${TEST_INSTALL_DIR}/${CMAKE_INSTALL_PREFIX}#${TEST_INSTALL_DIR}#' \
cmake/Tests.cmake || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_BINDIR="${EPREFIX}/bin"
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
-DCURSES_NEED_NCURSES=ON
-DINTERNAL_WCWIDTH=OFF
-DBUILD_DOCS="$(usex doc)"
-DWITH_GETTEXT="$(usex nls)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
keepdir /usr/share/fish/vendor_{completions,conf,functions}.d
readme.gentoo_create_doc
}
src_test() {
- cmake-utils_src_make -j1 test
+ cmake_build -j1 test
}
pkg_postinst() {
diff --git a/app-shells/fish/fish-9999.ebuild b/app-shells/fish/fish-9999.ebuild
index cf5816108b09..e718e3cbc309 100644
--- a/app-shells/fish/fish-9999.ebuild
+++ b/app-shells/fish/fish-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils readme.gentoo-r1
+inherit cmake readme.gentoo-r1
DESCRIPTION="Friendly Interactive SHell"
HOMEPAGE="http://fishshell.com/"
@@ -42,30 +42,29 @@ src_prepare() {
# workaround for https://github.com/fish-shell/fish-shell/issues/4883
sed -i 's#${TEST_INSTALL_DIR}/${CMAKE_INSTALL_PREFIX}#${TEST_INSTALL_DIR}#' \
cmake/Tests.cmake || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_BINDIR="${EPREFIX}/bin"
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
-DCURSES_NEED_NCURSES=ON
-DINTERNAL_WCWIDTH=OFF
-DBUILD_DOCS="$(usex doc)"
-DWITH_GETTEXT="$(usex nls)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
keepdir /usr/share/fish/vendor_{completions,conf,functions}.d
readme.gentoo_create_doc
}
src_test() {
- cmake-utils_src_make -j1 test
+ cmake_build -j1 test
}
pkg_postinst() {