summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-08-31 18:06:35 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-08-31 18:06:52 -0500
commit99bd66095559014e402453a1fbe0a771805631f1 (patch)
tree09486ff0625631024216803761ac709a94ff64c7 /app-shells
parentsys-apps/portage: drop iproute2 dep from 9999 (diff)
downloadgentoo-99bd66095559014e402453a1fbe0a771805631f1.tar.gz
gentoo-99bd66095559014e402453a1fbe0a771805631f1.tar.bz2
gentoo-99bd66095559014e402453a1fbe0a771805631f1.zip
app-shells/powerline: initial add
Package-Manager: Portage-2.3.69, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/powerline/Manifest1
-rw-r--r--app-shells/powerline/metadata.xml17
-rw-r--r--app-shells/powerline/powerline-2.7.ebuild26
-rw-r--r--app-shells/powerline/powerline-9999.ebuild26
4 files changed, 70 insertions, 0 deletions
diff --git a/app-shells/powerline/Manifest b/app-shells/powerline/Manifest
new file mode 100644
index 000000000000..9a7609785670
--- /dev/null
+++ b/app-shells/powerline/Manifest
@@ -0,0 +1 @@
+DIST powerline-status-2.7.tar.gz 233726 BLAKE2B fc7b7d6aa5d8e050af07aeee0aa0b7f6f01b7483ea910b87a7027cd55f726d42e41a008feb07429b21ebbd890b12eb56581b8e47fc30a58de6b902bf14d999cb SHA512 053ab74d250b7d835a5f8ec9cb7da4e890f0f50d31be9bab4b393a85e087a6fc010e58d6b3fa530cf39c10671345d032ca1fa9c0f7887a89fea8a4e69b7f1517
diff --git a/app-shells/powerline/metadata.xml b/app-shells/powerline/metadata.xml
new file mode 100644
index 000000000000..aa2c5f9bee3f
--- /dev/null
+++ b/app-shells/powerline/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Powerline is a statusline plugin for vim, and provides statuslines and
+ prompts for several other applications, including zsh, bash, fish,
+ tmux, IPython, Awesome, i3 and Qtile.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">powerline-status</remote-id>
+ <remote-id type="github">powerline/powerline</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/powerline/powerline-2.7.ebuild b/app-shells/powerline/powerline-2.7.ebuild
new file mode 100644
index 000000000000..79ff69b517e6
--- /dev/null
+++ b/app-shells/powerline/powerline-2.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="The ultimate statusline/prompt utility."
+HOMEPAGE="https://github.com/powerline/powerline"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/powerline/powerline"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}-status/${PN}-status-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+S="${WORKDIR}/${PN}-status-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
diff --git a/app-shells/powerline/powerline-9999.ebuild b/app-shells/powerline/powerline-9999.ebuild
new file mode 100644
index 000000000000..79ff69b517e6
--- /dev/null
+++ b/app-shells/powerline/powerline-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="The ultimate statusline/prompt utility."
+HOMEPAGE="https://github.com/powerline/powerline"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/powerline/powerline"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}-status/${PN}-status-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+S="${WORKDIR}/${PN}-status-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""