summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-25 22:41:58 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-25 23:03:26 +0200
commit9fc1440e59daaf23ed781c232b397759cd2f1188 (patch)
tree9adaf8c626e33eab0299858960e81fe3bfe2fd6a /app-shells
parentapp-containers/earthly: drop old 0.8.5 (diff)
downloadgentoo-9fc1440e59daaf23ed781c232b397759cd2f1188.tar.gz
gentoo-9fc1440e59daaf23ed781c232b397759cd2f1188.tar.bz2
gentoo-9fc1440e59daaf23ed781c232b397759cd2f1188.zip
app-shells/ugit: bump to 0.4.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/ugit/Manifest1
-rw-r--r--app-shells/ugit/ugit-0.4.4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-shells/ugit/Manifest b/app-shells/ugit/Manifest
index d42781180b14..63438f451618 100644
--- a/app-shells/ugit/Manifest
+++ b/app-shells/ugit/Manifest
@@ -1 +1,2 @@
DIST ugit-0.4.3.tar.gz 105253 BLAKE2B c1d38fc005a2e577923b57eca1290add3742153155618dff7d88ebe41faeea0a0046da87f89f6bcf675c61e9f5125a840bb690ce6ade4f0f080db4326bb9ec20 SHA512 9ea573029cd3191809a5da60a1533f5f026c1facc9da74a957a166129ba92ba92b4076de2654cc90dfd66563d2858bb25f43d8a3be92404776ce049aed2f6c93
+DIST ugit-0.4.4.tar.gz 149708 BLAKE2B 5cc59d36c0647f472cbb4787cca400684d0dcb1ead476a733aa3fed49b5bf4392d33c206aae912f6e67af6bbe8732f9bfd6870b6c0a6c14b6cebcc2cadb0a2a1 SHA512 a01ba28186c68671817e71b0cc33f191cc22abea9c8ceedc881de573bfdc8c13c81ec4fb03e964be2e39b84a32dfeee61c6d11e7595b8e8fa50912b117f41e77
diff --git a/app-shells/ugit/ugit-0.4.4.ebuild b/app-shells/ugit/ugit-0.4.4.ebuild
new file mode 100644
index 000000000000..f321df3b91f8
--- /dev/null
+++ b/app-shells/ugit/ugit-0.4.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PowerShell wrapper for git, automate repos and output git as objects"
+HOMEPAGE="https://ugit.start-automating.com/
+ https://github.com/StartAutomating/ugit/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/StartAutomating/${PN}.git"
+else
+ SRC_URI="https://github.com/StartAutomating/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="${PV}"
+
+RDEPEND="
+ dev-vcs/git
+ virtual/pwsh:*
+"
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/${PN}/${PV}"
+ doins "${PN}.psd1"
+ doins *.ps1 *.ps1xml *.psm1
+ doins -r Commands Extensions Types en-us
+
+ dodoc *.md
+}