summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-02-08 14:27:46 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-02-08 14:52:34 +0300
commita1b023b1aca3f233578196fa7f7409b4565b2611 (patch)
tree6421de02ba893b1cdd4bcb4fd5edd786a42f2e65 /app-shells
parentmedia-libs/opus: stable 1.3.1-r1 for ppc, bug #708324 (diff)
downloadgentoo-a1b023b1aca3f233578196fa7f7409b4565b2611.tar.gz
gentoo-a1b023b1aca3f233578196fa7f7409b4565b2611.tar.bz2
gentoo-a1b023b1aca3f233578196fa7f7409b4565b2611.zip
app-shells/zsh-syntax-highlighting: Initial commit
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh-syntax-highlighting/Manifest1
-rw-r--r--app-shells/zsh-syntax-highlighting/metadata.xml8
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.7.0_beta1.ebuild42
3 files changed, 51 insertions, 0 deletions
diff --git a/app-shells/zsh-syntax-highlighting/Manifest b/app-shells/zsh-syntax-highlighting/Manifest
new file mode 100644
index 000000000000..a557f61f9dd0
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/Manifest
@@ -0,0 +1 @@
+DIST zsh-syntax-highlighting-0.7.0_beta1.tar.gz 130063 BLAKE2B cf0f6319af22b47cb8a280de682a69b0479dc59033be5ce84840507b77dd2df0441b8d260af55bccb303c87d7f5a7e4cc6db9f46860aee040b4b8115c76f5e07 SHA512 1692015aad58103c752e2dd4161ea87f26aaa09d34eb2faec1f651fea1d9bfad29226455468017160a5393a87c1f7ed0514b09b0802b1810377beef72bfa6c87
diff --git a/app-shells/zsh-syntax-highlighting/metadata.xml b/app-shells/zsh-syntax-highlighting/metadata.xml
new file mode 100644
index 000000000000..203fa55c746f
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>zlogene@gentoo.org</email>
+ <name>Mikle Kolyada</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.7.0_beta1.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.7.0_beta1.ebuild
new file mode 100644
index 000000000000..8ca8ffb2e2b8
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.7.0_beta1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+if [[ -z ${PV%%*9999} ]]; then
+ EGIT_REPO_URI="https://github.com/zsh-users/${PN}.git"
+ inherit git-r3
+else
+ MY_PV=$(ver_rs 3 -)
+ SRC_URI="https://github.com/zsh-users/zsh-syntax-highlighting/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+DESCRIPTION="Fish shell like syntax highlighting for zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-functions/zsh-syntax-highlighting.zsh
+at the end of your ~/.zshrc"
+
+src_prepare() {
+ sed -i -e 's/COPYING.md//' Makefile || die
+ default
+}
+
+src_install() {
+ emake \
+ SHARE_DIR="${ED}/usr/share/zsh/site-functions" \
+ DOC_DIR="${ED}/usr/share/doc/${PF}" \
+ install
+ readme.gentoo_create_doc
+}