summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-12-12 10:21:01 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-12-12 10:21:22 +0100
commitf754ef499d5a5b833495749369c28593e4f041f8 (patch)
tree803d86ee1fa17e75ce1fb211d5293c54b08f0150 /app-shells
parentapp-shells/zsh: Revbump to fix ncurses detection (diff)
downloadgentoo-f754ef499d5a5b833495749369c28593e4f041f8.tar.gz
gentoo-f754ef499d5a5b833495749369c28593e4f041f8.tar.bz2
gentoo-f754ef499d5a5b833495749369c28593e4f041f8.zip
app-shells/zsh: Synced live ebuild
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh/zsh-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-shells/zsh/zsh-9999.ebuild b/app-shells/zsh/zsh-9999.ebuild
index 73b57b6dba70..503a4d64a9e4 100644
--- a/app-shells/zsh/zsh-9999.ebuild
+++ b/app-shells/zsh/zsh-9999.ebuild
@@ -3,10 +3,10 @@
EAPI=7
-inherit flag-o-matic prefix
+inherit autotools flag-o-matic prefix
if [[ ${PV} == 9999* ]] ; then
- inherit git-r3 autotools
+ inherit git-r3
EGIT_REPO_URI="https://git.code.sf.net/p/zsh/code"
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
@@ -64,10 +64,11 @@ src_prepare() {
default
+ hprefixify configure.ac
if [[ ${PV} == 9999* ]] ; then
sed -i "/^VERSION=/s/=.*/=${PV}/" Config/version.mk || die
- eautoreconf
fi
+ eautoreconf
}
src_configure() {
@@ -80,6 +81,7 @@ src_configure() {
--enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions
--enable-function-subdirs
--with-tcsetpgrp
+ --with-term-lib="$(usex unicode 'tinfow ncursesw' 'tinfo ncurses')"
$(use_enable maildir maildir-support)
$(use_enable pcre)
$(use_enable caps cap)