summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-11-21 00:16:46 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-11-27 05:45:50 +1100
commitf76f3775cec41cc173da7815c77b344ba5c93299 (patch)
tree92e51d37418ab399b719f74bf39fe3fb57e3040a /app-text/goldendict
parentsys-process/glances: Fix PyPI link (diff)
downloadgentoo-f76f3775cec41cc173da7815c77b344ba5c93299.tar.gz
gentoo-f76f3775cec41cc173da7815c77b344ba5c93299.tar.bz2
gentoo-f76f3775cec41cc173da7815c77b344ba5c93299.zip
app-text/goldendict: Add 1.5.0_rc2 to have a Qt5 version
Ebuild taken from qt overlay. Package-Manager: portage-2.3.0
Diffstat (limited to 'app-text/goldendict')
-rw-r--r--app-text/goldendict/Manifest1
-rw-r--r--app-text/goldendict/files/goldendict-1.5.0-qtsingleapplication-unbundle.patch18
-rw-r--r--app-text/goldendict/goldendict-1.5.0_rc2.ebuild87
-rw-r--r--app-text/goldendict/metadata.xml2
4 files changed, 107 insertions, 1 deletions
diff --git a/app-text/goldendict/Manifest b/app-text/goldendict/Manifest
index 1a5b715e2607..57ad4ccdc177 100644
--- a/app-text/goldendict/Manifest
+++ b/app-text/goldendict/Manifest
@@ -1 +1,2 @@
DIST goldendict-1.0.1-src.tar.bz2 2705932 SHA256 b3fb0405a5edb38f02ef881b48c36e46e2eacf641b0caf8d99403f595a4be9a6 SHA512 6c35f804063e14ffc9fe9fbd86e710582c550d10fcabb83e7fb0f65ccad1e18eaa31578a96f0aea67276453239b8035f5a694c7d081f9a6f7a822d2b75ebce55 WHIRLPOOL f642692c5ac921d031e89a4512ac63eb665d5b3d02f2a4aea911566131188f877c173d4624eef073e3580e30d8291c1f0196d870738daf2be469783838305c4c
+DIST goldendict-1.5.0_rc2.tar.gz 19413751 SHA256 bccee0a3d3902f8fa31e439e220a405065fff774e5f8c581be2b0743d3f83fde SHA512 b88067a90df42b07d926231f624be8796f031b872443a45f9744ceeea27f39325bc665090f773528a26ad8391ae2423a29c602068bf2cc4ed5870a07646d2362 WHIRLPOOL f385a8536360b9401a67284d95be65d98d5f6b57d5af73852f5ec1af95c4ce36c9903e9ed04dbd67e7bf035b5b6745378344cc5efbb4923ce4ea31988f95f6ff
diff --git a/app-text/goldendict/files/goldendict-1.5.0-qtsingleapplication-unbundle.patch b/app-text/goldendict/files/goldendict-1.5.0-qtsingleapplication-unbundle.patch
new file mode 100644
index 000000000000..01fdb3b2a297
--- /dev/null
+++ b/app-text/goldendict/files/goldendict-1.5.0-qtsingleapplication-unbundle.patch
@@ -0,0 +1,18 @@
+--- a/goldendict.pro
++++ b/goldendict.pro
+@@ -36,7 +36,8 @@
+ QT += sql
+ CONFIG += exceptions \
+ rtti \
+- stl
++ stl \
++ qtsingleapplication
+ OBJECTS_DIR = build
+ UI_DIR = build
+ MOC_DIR = build
+@@ -632,5 +633,3 @@
+ TS_OUT ~= s/.ts/.qm/g
+ PRE_TARGETDEPS += $$TS_OUT
+
+-include( qtsingleapplication/src/qtsingleapplication.pri )
+-
diff --git a/app-text/goldendict/goldendict-1.5.0_rc2.ebuild b/app-text/goldendict/goldendict-1.5.0_rc2.ebuild
new file mode 100644
index 000000000000..fa47bf43be6d
--- /dev/null
+++ b/app-text/goldendict/goldendict-1.5.0_rc2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PV=${PV^^}
+MY_PV=${MY_PV/_/-}
+inherit eutils qmake-utils
+
+DESCRIPTION="Feature-rich dictionary lookup program"
+HOMEPAGE="http://goldendict.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ffmpeg libav"
+
+RDEPEND="
+ app-arch/bzip2
+ >=app-text/hunspell-1.2:=
+ dev-libs/eb
+ dev-libs/lzo
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qthelp:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsingleapplication[qt5]
+ dev-qt/qtsvg:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ media-libs/libvorbis
+ media-libs/tiff:0
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXtst
+ ffmpeg? (
+ media-libs/libao
+ libav? ( media-video/libav:0= )
+ !libav? ( media-video/ffmpeg:0= )
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}/${PN}-1.5.0-qtsingleapplication-unbundle.patch" )
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+
+ # fix installation path
+ sed -i \
+ -e '/PREFIX = /s:/usr/local:/usr:' \
+ ${PN}.pro || die
+
+ # add trailing semicolon
+ sed -i -e '/^Categories/s/$/;/' redist/${PN}.desktop || die
+}
+
+src_configure() {
+ local myconf=()
+
+ if ! use ffmpeg && ! use libav ; then
+ myconf+=( DISABLE_INTERNAL_PLAYER=1 )
+ fi
+
+ eqmake5 "${myconf[@]}"
+}
+
+src_install() {
+ dobin ${PN}
+ domenu redist/${PN}.desktop
+ doicon redist/icons/${PN}.png
+
+ insinto /use/share/apps/${PN}/locale
+ doins locale/*.qm
+
+ insinto /usr/share/${PN}/help
+ doins help/*.qch
+}
diff --git a/app-text/goldendict/metadata.xml b/app-text/goldendict/metadata.xml
index 0746d64ca9c4..fce10001488a 100644
--- a/app-text/goldendict/metadata.xml
+++ b/app-text/goldendict/metadata.xml
@@ -14,6 +14,6 @@
<name>Proxy Maintainers</name>
</maintainer>
<upstream>
- <remote-id type="sourceforge">goldendict</remote-id>
+ <remote-id type="github">goldendict/goldendict</remote-id>
</upstream>
</pkgmetadata>