summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-17 10:35:54 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-17 10:35:54 +0100
commit70beeaaeeaaa0f22f829508526ae282904ad189b (patch)
tree3facd0bdbaaee2918e728917edd0428b9fd4e7bc /app-text
parentapp-doc/geant-docs: Remove old (diff)
downloadgentoo-70beeaaeeaaa0f22f829508526ae282904ad189b.tar.gz
gentoo-70beeaaeeaaa0f22f829508526ae282904ad189b.tar.bz2
gentoo-70beeaaeeaaa0f22f829508526ae282904ad189b.zip
app-text/bibutils: Bump to 6.10
Closes: https://bugs.gentoo.org/761430 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/bibutils/Manifest1
-rw-r--r--app-text/bibutils/bibutils-6.10.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-text/bibutils/Manifest b/app-text/bibutils/Manifest
index ebad9e12db70..d5f41c15c884 100644
--- a/app-text/bibutils/Manifest
+++ b/app-text/bibutils/Manifest
@@ -1 +1,2 @@
+DIST bibutils_6.10_src.tgz 590002 BLAKE2B 91ea6c961978d381a65c1d5071c541409609dd9fdeb664cd7e66eb4871c2ecd0dfd6b06857294ae6ec049751a5939be23518782a5e1f14fdf848918849269402 SHA512 43cf107ee6d1bf6bf27a6bf46e1f4cbd83a4b78ef355730a9f37282fac399ee21d78538248730be85c0a8f724344782dcc6ab68e50f857d8ac4ea24cc4102911
DIST bibutils_6.7_src.tgz 580792 BLAKE2B 29c5863bc414ef7b2f362d95352c0e042c1bcc3275017df82b0206d96520b3f5c3fe1e12563577b84a8bd94b0677bf1ad04ecbd80dcbcc194a71037bbd6facba SHA512 08db07408eee26bce42dbd00b7e821ef41dc12c7ce847425e81145927bcfc6ea7180ff719056e089917811aa9675a09dd52e1e02b8187b8618f67647efcb1236
diff --git a/app-text/bibutils/bibutils-6.10.ebuild b/app-text/bibutils/bibutils-6.10.ebuild
new file mode 100644
index 000000000000..fca15d38d420
--- /dev/null
+++ b/app-text/bibutils/bibutils-6.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="Interconverts between various bibliography formats using common XML intermediate"
+HOMEPAGE="https://sourceforge.net/p/bibutils/home/Bibutils/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ ./configure \
+ --dynamic \
+ --install-dir "${ED}/usr/bin" \
+ --install-lib "${ED}/usr/$(get_libdir)" || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ DISTRO_CFLAGS="${CFLAGS}" \
+ LDFLAGSIN="${LDFLAGS}"
+}
+
+src_test() {
+ emake \
+ CC="$(tc-getCC)" \
+ DISTRO_CFLAGS="${CFLAGS}" \
+ LDFLAGSIN="${LDFLAGS}" test
+}