summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-07 09:45:26 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-07 09:49:12 +0300
commit8581bbbfb9b8b1e8e958ad765cf31fbe4cae242e (patch)
tree2fb79d32a5a8fa30429477666350782a6fd624f7 /app-text
parentdev-python/argparse-manpage: enable py3.10, fix DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-8581bbbfb9b8b1e8e958ad765cf31fbe4cae242e.tar.gz
gentoo-8581bbbfb9b8b1e8e958ad765cf31fbe4cae242e.tar.bz2
gentoo-8581bbbfb9b8b1e8e958ad765cf31fbe4cae242e.zip
app-text/rpl: add 1.9.1, enable py3.{9,10}, EAPI=8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/rpl/Manifest1
-rw-r--r--app-text/rpl/rpl-1.9.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-text/rpl/Manifest b/app-text/rpl/Manifest
index 0dfff1ab427a..c439d5104780 100644
--- a/app-text/rpl/Manifest
+++ b/app-text/rpl/Manifest
@@ -1 +1,2 @@
DIST rpl-1.6.7.tar.gz 21867 BLAKE2B ac523aa836312d6ed6db9eabaf9b6499ce00047ce1a4d35bf398f769036d65aa5b52c410b2110cf5bb14c31d782bc1c424bcd1b2a26692de28ca70fd452b18f1 SHA512 f853eae0ce0a82d864e72ecf3fd3f20fba10553357b23d0012ed22ee0efd57bbefea71095775f7215323d829057f6579aadfc006b6a893972e05039784dc5add
+DIST rpl-1.9.1.gh.tar.gz 22858 BLAKE2B 583a29fd34d7a0d2b3a35b0966a6bd42ac2851750806a97846785dc0331bd5d2199ffba3309184e64a4aa7194f9ae4b9ecb2acc500830b841bd34e2184ec1798 SHA512 be480c6788fa1eb672b892d798deb7d263eae227dac5d93a55f28ebf3b4a43f896eb10edd00e52aad1cd57f4a80faf4a4552b4762b26da273cd05f0c5bce754a
diff --git a/app-text/rpl/rpl-1.9.1.ebuild b/app-text/rpl/rpl-1.9.1.ebuild
new file mode 100644
index 000000000000..dcc99262524d
--- /dev/null
+++ b/app-text/rpl/rpl-1.9.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Intelligent recursive search/replace utility"
+HOMEPAGE="http://rpl.sourceforge.net/ https://github.com/rrthomas/rpl"
+SRC_URI="https://github.com/rrthomas/rpl/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/argparse-manpage[${PYTHON_USEDEP}]
+ sys-apps/help2man[nls]
+"
+
+python_compile_all() {
+ # Compile man file
+ emake rpl.1
+}