summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-23 19:36:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-23 21:19:22 +0100
commitcf17628569b182b2d27a8f969dc9539d35e7d32b (patch)
tree45d30745ce49125ae931fec59312d24e895935da /app-text
parentapp-backup/backintime: drop 1.3.1 (diff)
downloadgentoo-cf17628569b182b2d27a8f969dc9539d35e7d32b.tar.gz
gentoo-cf17628569b182b2d27a8f969dc9539d35e7d32b.tar.bz2
gentoo-cf17628569b182b2d27a8f969dc9539d35e7d32b.zip
app-text/libwps: add 0.4.13
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libwps/Manifest1
-rw-r--r--app-text/libwps/libwps-0.4.13.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-text/libwps/Manifest b/app-text/libwps/Manifest
index 94014b449366..3e32446625cc 100644
--- a/app-text/libwps/Manifest
+++ b/app-text/libwps/Manifest
@@ -1 +1,2 @@
DIST libwps-0.4.12.tar.xz 713008 BLAKE2B c95bdab54f8853cd1d13b59904ee4064cded3741cb91f2b067f139d80cdae6ea19bac68e6855cad74878403bc1a04c6f4bdd3181407b69b7e50f1e7bf4255f58 SHA512 d23667681f443b0c718b55006bee881e8a07d6b071cda742a783a89e9ed0e4c60c66c7dc9612a3fb4a419ff6d6e572f5981cec1d9470422e10cf9837e92a4649
+DIST libwps-0.4.13.tar.xz 717188 BLAKE2B 966d0e57668577620fc5fe8c222096fa1b51f3d2c149dab7fc182c2fe81b69363cfbcc2ff930d2719f9fcf735306d612a00ae863ff1a0d2f03fcd6c67b054489 SHA512 c88357cdb11a68148c9344cf3688d57d793089732ee9828d6ea5e86536eb5f60668326fa520e7609a48298051435f6cc570d0c58aa4aa96581a51c16f914a1d0
diff --git a/app-text/libwps/libwps-0.4.13.ebuild b/app-text/libwps/libwps-0.4.13.ebuild
new file mode 100644
index 000000000000..4737dd0f497e
--- /dev/null
+++ b/app-text/libwps/libwps-0.4.13.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Microsoft Works file word processor format import filter library"
+HOMEPAGE="https://sourceforge.net/p/libwps/wiki/Home/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="debug doc tools"
+
+DEPEND="dev-libs/librevenge"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_with doc docs)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}