summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-19 16:31:09 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-09-14 23:22:34 +0200
commit3fa6b58fd3c8c50ef9fe5df432af26c29072327b (patch)
tree298f74872bb6ee676b5543861229793f3062c077 /app-vim/easy-align
parentapp-vim/dirdiff: EAPI8 bump (diff)
downloadgentoo-3fa6b58fd3c8c50ef9fe5df432af26c29072327b.tar.gz
gentoo-3fa6b58fd3c8c50ef9fe5df432af26c29072327b.tar.bz2
gentoo-3fa6b58fd3c8c50ef9fe5df432af26c29072327b.zip
app-vim/easy-align: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-vim/easy-align')
-rw-r--r--app-vim/easy-align/easy-align-2.10.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-vim/easy-align/easy-align-2.10.0-r2.ebuild b/app-vim/easy-align/easy-align-2.10.0-r2.ebuild
new file mode 100644
index 000000000000..05c1978fbbdc
--- /dev/null
+++ b/app-vim/easy-align/easy-align-2.10.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+MY_PN="vim-${PN}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="vim plugin: a simple alignment plugin"
+HOMEPAGE="https://github.com/junegunn/vim-easy-align
+ https://www.vim.org/scripts/script.php?script_id=4520"
+SRC_URI="https://github.com/junegunn/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ default
+ rm -rv test || die
+}