summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-02-01 18:47:50 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-02-11 00:11:11 +0100
commitac7866bb70bd1b9041519280f79d3fbb36ff07bc (patch)
tree34d1eeb5a7d1206a59b3bc8c268eb4c5be38b997 /app-vim/fluxbox-syntax
parentdev-libs/libunistring: Drop old versions (diff)
downloadgentoo-ac7866bb70bd1b9041519280f79d3fbb36ff07bc.tar.gz
gentoo-ac7866bb70bd1b9041519280f79d3fbb36ff07bc.tar.bz2
gentoo-ac7866bb70bd1b9041519280f79d3fbb36ff07bc.zip
app-vim/fluxbox-syntax: EAPI 6 bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11 RepoMan-Options: --force
Diffstat (limited to 'app-vim/fluxbox-syntax')
-rw-r--r--app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r1.ebuild b/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r1.ebuild
new file mode 100644
index 000000000000..1165be5cb0ab
--- /dev/null
+++ b/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: fluxbox files syntax and indent"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=679"
+LICENSE="vim"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+
+RDEPEND="app-vim/genindent"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting and indent settings for fluxbox
+menus and similar files. Upstream don't provide us with an ftdetect file,
+but a simple one has been created for you by this ebuild. You can manually
+set the filetype using :set filetype=fluxbox if necessary."
+
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ mkdir ftdetect || die
+ echo "au BufNewFile,BufRead /*/*fluxbox/*menu set filetype=fluxbox" \
+ > ftdetect/fluxbox.vim || die
+}