summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/gist
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/gist')
-rw-r--r--app-vim/gist/Manifest3
-rw-r--r--app-vim/gist/gist-6.8.ebuild19
-rw-r--r--app-vim/gist/gist-7.0.ebuild19
-rw-r--r--app-vim/gist/gist-7.1.ebuild19
-rw-r--r--app-vim/gist/metadata.xml5
5 files changed, 65 insertions, 0 deletions
diff --git a/app-vim/gist/Manifest b/app-vim/gist/Manifest
new file mode 100644
index 000000000000..bc3512add84a
--- /dev/null
+++ b/app-vim/gist/Manifest
@@ -0,0 +1,3 @@
+DIST gist-6.8.tar.bz2 9199 SHA256 f0406a79644bf946b1eefc88acc7994e9b945971326a23b9190f3e6d0d3e5cba SHA512 707dd30e1f60cac62ae5c496d5939f6545db0e79fcd033863b7a9180f3f10287897c397ade0bf74cef00b6de7c2892b9f7dc4f66c11649d1cdcedeab06909210 WHIRLPOOL 3432e97e0a6d00a1c8c3c74e16f35aba91136fb934c3f3ff0825e59b380142fed1ccfc52b35a5d33a457e0df1ab87008e439037dfaf950b3c079fdddc49adc3b
+DIST gist-7.0.tar.bz2 9360 SHA256 959d8caeb893e8d17d58956557d79aaa6bcdf5dc03fafd749f86a9528dd5ab93 SHA512 fd5122690f11fe78cb22ac2f43ea6cf52d4b25c930ba9c239f899100b6728875b707f13c621c09f13ecd0ee386208ba7bbc93209f6d265b2a5e26429a022ce7e WHIRLPOOL b4a14d94402d0f7fe60c76964ac3b0ab7f9058629af986dde6991432f6e36169453d0bc78429e5f7541d7fc7e3928eb36132f4915e35902332aad6aa8b4d19b1
+DIST gist-7.1.tar.bz2 9398 SHA256 1864e90da1c68b9941e2104c42c96404b18d59f9c89cdcca76ff9e48fd79b897 SHA512 47492ab5c31d29e6a939c9631f2bac67c3ea0a2d2af783df3fa589a20ec2bb5d7e0f961c370b81a5ad3e05952140e0cc9a8c5a8e034b5ff8f9afd9447b8a3807 WHIRLPOOL c533ab9052daee3412284dcc2e560a877eb34524afa3e8fd1fe065eacfae483f77e118988ec6f3921d0605b31f8dab5c8c5acc59d61d01f7661554e0b441ccfb
diff --git a/app-vim/gist/gist-6.8.ebuild b/app-vim/gist/gist-6.8.ebuild
new file mode 100644
index 000000000000..b16220ed7ee0
--- /dev/null
+++ b/app-vim/gist/gist-6.8.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: interact with gists (gist.github.com)"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2423"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-vim/webapi
+ net-misc/curl
+ dev-vcs/git"
+
+VIM_PLUGIN_HELPFILES="Gist.vim"
diff --git a/app-vim/gist/gist-7.0.ebuild b/app-vim/gist/gist-7.0.ebuild
new file mode 100644
index 000000000000..b16220ed7ee0
--- /dev/null
+++ b/app-vim/gist/gist-7.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: interact with gists (gist.github.com)"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2423"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-vim/webapi
+ net-misc/curl
+ dev-vcs/git"
+
+VIM_PLUGIN_HELPFILES="Gist.vim"
diff --git a/app-vim/gist/gist-7.1.ebuild b/app-vim/gist/gist-7.1.ebuild
new file mode 100644
index 000000000000..17b482c3d1eb
--- /dev/null
+++ b/app-vim/gist/gist-7.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: interact with gists (gist.github.com)"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2423"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE=""
+
+RDEPEND="app-vim/webapi
+ net-misc/curl
+ dev-vcs/git"
+
+VIM_PLUGIN_HELPFILES="Gist.vim"
diff --git a/app-vim/gist/metadata.xml b/app-vim/gist/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/gist/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>