summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-19 17:21:41 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-09-14 23:22:39 +0200
commitaaae2529b7c6b26c0cb7ecfd07ba6a2c7dfa76d7 (patch)
treec4f9a5c0273993130b8ae28bd1c37307c648c18a /app-vim/info
parentapp-vim/indentpython: EAPI8 bump (diff)
downloadgentoo-aaae2529b7c6b26c0cb7ecfd07ba6a2c7dfa76d7.tar.gz
gentoo-aaae2529b7c6b26c0cb7ecfd07ba6a2c7dfa76d7.tar.bz2
gentoo-aaae2529b7c6b26c0cb7ecfd07ba6a2c7dfa76d7.zip
app-vim/info: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-vim/info')
-rw-r--r--app-vim/info/info-1.7-r3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-vim/info/info-1.7-r3.ebuild b/app-vim/info/info-1.7-r3.ebuild
new file mode 100644
index 000000000000..5b11956b2c7a
--- /dev/null
+++ b/app-vim/info/info-1.7-r3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: GNU info documentation browser"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=21"
+
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~s390 ~sparc ~x86"
+
+VIM_PLUGIN_HELPTEXT="This plugin adds the :Info command."
+
+src_prepare() {
+ default
+
+ # The 'h' key is a bad choice for help. 'H' would have been a
+ # much better choice. I sent this suggestion to the maintainer,
+ # but no reply.
+ sed -i 's/\(noremap <buffer> \)h/\1H/' plugin/info.vim || die 'sed failed'
+}