summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-06-29 11:14:50 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-06-29 11:20:39 +0000
commita284ec5f1bc47733dcb9a187456d14165d96b9d7 (patch)
tree314eb48993f5c0ebfad31b44802c56405c050a6b /app-vim/locateopen
parentapp-vim/foldutil: EAPI 6 bump. (diff)
downloadgentoo-a284ec5f1bc47733dcb9a187456d14165d96b9d7.tar.gz
gentoo-a284ec5f1bc47733dcb9a187456d14165d96b9d7.tar.bz2
gentoo-a284ec5f1bc47733dcb9a187456d14165d96b9d7.zip
app-vim/locateopen: EAPI 6 bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-vim/locateopen')
-rw-r--r--app-vim/locateopen/locateopen-1.3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-vim/locateopen/locateopen-1.3-r1.ebuild b/app-vim/locateopen/locateopen-1.3-r1.ebuild
new file mode 100644
index 000000000000..14268465894f
--- /dev/null
+++ b/app-vim/locateopen/locateopen-1.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: open a file without supplying a path"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=858"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="${RDEPEND} sys-apps/mlocate"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides commands that hook vim into mlocate:
+\ :LocateEdit filename
+\ :LocateSplit filename
+\ :LocateSource filename
+\ :LocateRead filename
+To configure:
+\ :let g:locateopen_ignorecase = 1 \" enable ignore case mode
+\ :let g:locateopen_smartcase = 0 \" disable smart case mode
+\ :let g:locateopen_alwaysprompt = 1 \" show menu for one match"