summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-07 02:40:00 +0000
committerSam James <sam@gentoo.org>2021-12-07 02:44:27 +0000
commit3edbfea01655be5799727cc08afb81d487ab17a4 (patch)
tree588f0b33ee6d4d6ca58f57c40577069cd25178e1 /app-vim/lustyexplorer
parentapp-vim/tlib: add 1.27 (diff)
downloadgentoo-3edbfea01655be5799727cc08afb81d487ab17a4.tar.gz
gentoo-3edbfea01655be5799727cc08afb81d487ab17a4.tar.bz2
gentoo-3edbfea01655be5799727cc08afb81d487ab17a4.zip
app-vim/lustyexplorer: add 5.0
Going through some app-vim/* bump bugs given upstream seem to be deprecating and removing some old functionality, this is needed to keep things working. Closes: https://bugs.gentoo.org/827948 Thanks-to: <hoelbezier@riseup.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-vim/lustyexplorer')
-rw-r--r--app-vim/lustyexplorer/Manifest1
-rw-r--r--app-vim/lustyexplorer/lustyexplorer-5.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-vim/lustyexplorer/Manifest b/app-vim/lustyexplorer/Manifest
index 2e8f3daaf9eb..3662898fd4e9 100644
--- a/app-vim/lustyexplorer/Manifest
+++ b/app-vim/lustyexplorer/Manifest
@@ -1 +1,2 @@
+DIST lusty-explorer-5.0.zip 21036 BLAKE2B 6f9918242b5a12a2fd58017c54f10489113b21858e1522e0ff74a7cca41045c08144cb7b69bef2aa5e67998d74bb8472d547421cb737d2fdf79ec1ce4c51db9d SHA512 42aa2dea2d96c88cf65891a08a798c185849695c49663260fd133c34b63311d1db9073d3db2d6e4d1fd6907fdd4cf89335dacb0a5bbaa994924751f5a1be66cf
DIST lustyexplorer-4.3.tar.bz2 17373 BLAKE2B 643eb4c7573932fa63030766670d7c398e307b72e08e93e53e31b7f21086a80196c8d4d7811032b8b945306fcdc7d86d59eb6b48ce0b79f38e628d6b4bec7519 SHA512 24ffa1fe5c1698dfa6093c7cfed2f08540ce130258df5e8ec135356ecea4c1f607f11e643ab859f551e63ecbbf6fc8a615a9514e1d4798b752cc97146c29c661
diff --git a/app-vim/lustyexplorer/lustyexplorer-5.0.ebuild b/app-vim/lustyexplorer/lustyexplorer-5.0.ebuild
new file mode 100644
index 000000000000..c2f6ad8affa6
--- /dev/null
+++ b/app-vim/lustyexplorer/lustyexplorer-5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+MY_PN="lusty-explorer"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="vim plugin: dynamic filesystem and buffer explorer"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1890"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=26146 -> ${MY_P}.zip"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="bufexplorer.vim"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="lusty-explorer.txt"
+
+BDEPEND="app-arch/unzip"
+RDEPEND="|| (
+ app-editors/vim[ruby]
+ app-editors/gvim[ruby]
+)"
+
+src_prepare() {
+ default
+
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc || die
+ sed -e '0,/"$/d' -e '/" GetLatest.\+$/,9999d' -e 's/^" \?//' \
+ -e "s/\(Name Of File: \)\([^.]\+\)\.vim/\1*\2.txt*/" \
+ plugin/lusty-explorer.vim > doc/lusty-explorer.txt
+}