summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/pathogen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/pathogen')
-rw-r--r--app-vim/pathogen/Manifest2
-rw-r--r--app-vim/pathogen/metadata.xml8
-rw-r--r--app-vim/pathogen/pathogen-2.2.ebuild16
-rw-r--r--app-vim/pathogen/pathogen-2.3.ebuild15
4 files changed, 41 insertions, 0 deletions
diff --git a/app-vim/pathogen/Manifest b/app-vim/pathogen/Manifest
new file mode 100644
index 000000000000..f3019f2a4586
--- /dev/null
+++ b/app-vim/pathogen/Manifest
@@ -0,0 +1,2 @@
+DIST pathogen-2.2.tar.gz 5968 SHA256 35fc1413005611130ed1b7543f7a7afc0eadb9956300d301ced006071c6f1cd2 SHA512 b3892fc11215bbc63fdaee2ab533fad025f373f344483223fea4bbbbf256873f8464d7ee35f4a065e3663f6552b973fe59bf87e46463f0ad09c95eeb08bb953e WHIRLPOOL defd4f1972a020416bafbb2fb82f920503c11d16b8287695399f3bf6ffb3da2ba5be55eb14835741d677b8e2c70d331751d4365d542bf183d72a4d403e11625e
+DIST pathogen-2.3.tar.gz 6136 SHA256 3a2ec24f47dbb59dd4f3fea12f89cf64add951da4646dedced54b7284fdc38ac SHA512 da603a4d111dce6fba1542e3301a8e180def545d1f81339bc60782698c777625500e158d0f15c01ac0144e6a3045bb2d2d2ed19bfe661c233a0633a9aa14b749 WHIRLPOOL ab99d35d078e65eda60d5b3d96fa77f0913a97bcec19aceb2a104e493561e2fff8874c8fa3bb67f2875356ddcfe827972d84bacc5cb72ba42fd33613495a60bb
diff --git a/app-vim/pathogen/metadata.xml b/app-vim/pathogen/metadata.xml
new file mode 100644
index 000000000000..d6a3a74a31b0
--- /dev/null
+++ b/app-vim/pathogen/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="github">tpope/vim-pathogen</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/pathogen/pathogen-2.2.ebuild b/app-vim/pathogen/pathogen-2.2.ebuild
new file mode 100644
index 000000000000..fd1f6c49fabb
--- /dev/null
+++ b/app-vim/pathogen/pathogen-2.2.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: manage your runtimepath"
+HOMEPAGE="https://github.com/tpope/vim-pathogen/ http://www.vim.org/scripts/script.php?script_id=2332"
+SRC_URI="https://github.com/tpope/vim-pathogen/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="amd64 x86 ~x64-macos"
+IUSE=""
+
+S=${WORKDIR}/vim-${P}
diff --git a/app-vim/pathogen/pathogen-2.3.ebuild b/app-vim/pathogen/pathogen-2.3.ebuild
new file mode 100644
index 000000000000..9ec64cc8c30f
--- /dev/null
+++ b/app-vim/pathogen/pathogen-2.3.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: manage your runtimepath"
+HOMEPAGE="https://github.com/tpope/vim-pathogen/ http://www.vim.org/scripts/script.php?script_id=2332"
+SRC_URI="https://github.com/tpope/vim-pathogen/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="amd64 x86 ~x64-macos"
+
+S=${WORKDIR}/vim-${P}