summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-19 17:55:07 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-09-14 23:22:45 +0200
commit7dc86f0ee77e808dad094fc71cf752b20fb5b032 (patch)
tree0b2766045fec447ed9455312b37b13640a464055 /app-vim/showmarks
parentapp-vim/session: EAPI8 bump (diff)
downloadgentoo-7dc86f0ee77e808dad094fc71cf752b20fb5b032.tar.gz
gentoo-7dc86f0ee77e808dad094fc71cf752b20fb5b032.tar.bz2
gentoo-7dc86f0ee77e808dad094fc71cf752b20fb5b032.zip
app-vim/showmarks: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-vim/showmarks')
-rw-r--r--app-vim/showmarks/showmarks-2.2-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-vim/showmarks/showmarks-2.2-r2.ebuild b/app-vim/showmarks/showmarks-2.2-r2.ebuild
new file mode 100644
index 000000000000..247c654173bb
--- /dev/null
+++ b/app-vim/showmarks/showmarks-2.2-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: show location marks visually"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=152"
+
+LICENSE="public-domain"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+
+VIM_PLUGIN_HELPFILES="showmarks.txt"
+
+src_prepare() {
+ default
+
+ mkdir "${S}"/doc || die "can't make doc dir"
+
+ # This plugin uses an 'automatic HelpExtractor' variant. This causes
+ # problems for us during the unmerge. Fortunately, sed can fix this
+ # for us.
+ sed -e '1,/^" HelpExtractorDoc:$/d' \
+ "${S}"/plugin/showmarks.vim > "${S}"/doc/showmarks.txt \
+ || die "help extraction failed"
+ sed -i -e '/^" HelpExtractor:$/,$d' "${S}"/plugin/showmarks.vim \
+ || die "help extract remove failed"
+}