summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-10-31 00:45:06 -0400
committerTim Harder <radhermit@gentoo.org>2016-10-31 00:45:06 -0400
commit0776c76c7b97b12a3d85416e87225466ab9a7529 (patch)
treef90504a8676a597ce252e0e0b5ff3524c78494bd /app-vim/splice
parentapp-vim/gist: version bump to 7.3 (diff)
downloadgentoo-0776c76c7b97b12a3d85416e87225466ab9a7529.tar.gz
gentoo-0776c76c7b97b12a3d85416e87225466ab9a7529.tar.bz2
gentoo-0776c76c7b97b12a3d85416e87225466ab9a7529.zip
app-vim/splice: version bump to 1.1.0
Diffstat (limited to 'app-vim/splice')
-rw-r--r--app-vim/splice/Manifest1
-rw-r--r--app-vim/splice/splice-1.1.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-vim/splice/Manifest b/app-vim/splice/Manifest
index 34d2edaa0c3b..fcaa3e7b2653 100644
--- a/app-vim/splice/Manifest
+++ b/app-vim/splice/Manifest
@@ -1 +1,2 @@
DIST splice-1.0.1.tar.bz2 12369 SHA256 30e7d947defb29971d8c750670bbdae6625e2238d4f892e6b5590609d6a6a81a SHA512 65826a9054163f59d8dc0a558e3b748f27015bb6075e8d158214e6824c922599552a69c7d09364599285d6effdfc42fa6dd98e858a8bfa47ebc21a4d18394ede WHIRLPOOL a8e4405f5169857c07b81f0a778757aebd198f4c0e73f4cf239a451dfae64911d5fb164121413799a750646df609fcb864a08393510d012a84383261f6c006ab
+DIST splice-1.1.0.tar.gz 15513 SHA256 5f4b8324b873230124b93462581ca438c517a14076703ec36ec91a561ecb1504 SHA512 3008c5628ca7b05be451521f9e1f0f2d8dcc8c968e95f2791e76a355b2c9f3b85c62faa319a2f1427f223094b3e606577d19a61b2384b78cbd6d40f497e4ad37 WHIRLPOOL 83807c37e17c204e84fde1d02bc7f9645f259f7f6bc24d05fc9d41f0d2f2a366ea77c46615ae2a92811ee19ef1b7ccbedeb1c23a9bac0a1a413fa03113df306e
diff --git a/app-vim/splice/splice-1.1.0.ebuild b/app-vim/splice/splice-1.1.0.ebuild
new file mode 100644
index 000000000000..a4d376cca1ee
--- /dev/null
+++ b/app-vim/splice/splice-1.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit vim-plugin python-single-r1 vcs-snapshot
+
+DESCRIPTION="vim plugin: resolve conflicts during three-way merges"
+HOMEPAGE="https://bitbucket.org/sjl/splice.vim http://vim.sourceforge.net/scripts/script.php?script_id=4026"
+SRC_URI="https://bitbucket.org/sjl/${PN}.vim/get/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm .[a-z]* Makefile LICENSE.markdown package.sh || die
+ rm -r site || die
+}
+
+src_install() {
+ vim-plugin_src_install
+ python_optimize "${ED}"/usr/share/vim/vimfiles/autoload/splicelib
+}