summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/taglist
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/taglist')
-rw-r--r--app-vim/taglist/Manifest2
-rw-r--r--app-vim/taglist/files/taglist-3.4-ebuilds.patch12
-rw-r--r--app-vim/taglist/metadata.xml5
-rw-r--r--app-vim/taglist/taglist-4.5.ebuild23
-rw-r--r--app-vim/taglist/taglist-4.6.ebuild20
5 files changed, 62 insertions, 0 deletions
diff --git a/app-vim/taglist/Manifest b/app-vim/taglist/Manifest
new file mode 100644
index 000000000000..7ef37dcc3fc2
--- /dev/null
+++ b/app-vim/taglist/Manifest
@@ -0,0 +1,2 @@
+DIST taglist-4.5.tar.bz2 39272 SHA256 94170e61c3a05f5d1ed8e8475ab2e3eeafc264629d245f1a8717ec2ddc8ca84c SHA512 71b9fe005753e1a211db0f264cd48a4aa3a2fbccfe97bab392c5ecc68db317c591aecdd7586cbecdf11950fd4dcc56d6f94f15599df7aec020924fa6f064035e WHIRLPOOL 7cd850668152f1516501f63361b3206ce79fe9fce2dfe6f78f42cd294e9eaf4db093674c1ad05db874aef83da2ecb1b7527b0e0c5bf79494d9e120f5564cff1b
+DIST taglist-4.6.tar.bz2 40344 SHA256 30716a97b4667a862849dee122b843c2522c649e60553e8cbe2277bb93ccb6a3 SHA512 64686f2685cf4f9b09eeb7e1981a1b9d514cce2f6ea4bdf3e3613037d9818556ad6ed95740a84b4d73eba3fa1d5d58a41f15e1bc0a1403c50a810f5a704f3073 WHIRLPOOL 4e7b154e1c693cfee821e55e9b4d8f2b26f1c5dbacce6015757ee4b13586927ba5dca2ab726e23ad090944e55e0cce9676c01c8c21efa9ece967cb24d8bd5acd
diff --git a/app-vim/taglist/files/taglist-3.4-ebuilds.patch b/app-vim/taglist/files/taglist-3.4-ebuilds.patch
new file mode 100644
index 000000000000..8fcc928d4497
--- /dev/null
+++ b/app-vim/taglist/files/taglist-3.4-ebuilds.patch
@@ -0,0 +1,12 @@
+--- taglist-3.4/plugin/taglist.vim.orig 2004-10-02 00:12:58.400215576 +0100
++++ taglist-3.4/plugin/taglist.vim 2004-10-02 00:26:28.535056360 +0100
+@@ -205,6 +205,9 @@
+ let s:tlist_def_cobol_settings = 'cobol;d:data;f:file;g:group;p:paragraph;' .
+ \ 'P:program;s:section'
+
++" ebuilds
++let s:tlist_def_ebuild_settings = 'sh;f:function'
++
+ " eiffel language
+ let s:tlist_def_eiffel_settings = 'eiffel;c:class;f:feature'
+
diff --git a/app-vim/taglist/metadata.xml b/app-vim/taglist/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/taglist/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>
diff --git a/app-vim/taglist/taglist-4.5.ebuild b/app-vim/taglist/taglist-4.5.ebuild
new file mode 100644
index 000000000000..5fbdd6f1a409
--- /dev/null
+++ b/app-vim/taglist/taglist-4.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: ctags-based source code browser"
+HOMEPAGE="http://vim-taglist.sourceforge.net/"
+
+LICENSE="vim"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND="dev-util/ctags"
+
+VIM_PLUGIN_HELPFILES="taglist-intro"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.4-ebuilds.patch
+ [[ -f plugin/${PN}.vim.orig ]] && rm plugin/${PN}.vim.orig
+}
diff --git a/app-vim/taglist/taglist-4.6.ebuild b/app-vim/taglist/taglist-4.6.ebuild
new file mode 100644
index 000000000000..d1f9b9773341
--- /dev/null
+++ b/app-vim/taglist/taglist-4.6.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: ctags-based source code browser"
+HOMEPAGE="http://vim-taglist.sourceforge.net/"
+LICENSE="vim"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+
+RDEPEND="dev-util/ctags"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.4-ebuilds.patch
+}