summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2023-04-09 10:30:58 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2023-04-09 15:13:05 +0200
commitaeb8215fcfbf5828cdd9e052f69baef3a08343e4 (patch)
tree514da1c85e96843383b9f7e11de56966fcc566c0 /app-vim/vimclojure
parentdev-java/json-simple: drop 1.1-r2 (diff)
downloadgentoo-aeb8215fcfbf5828cdd9e052f69baef3a08343e4.tar.gz
gentoo-aeb8215fcfbf5828cdd9e052f69baef3a08343e4.tar.bz2
gentoo-aeb8215fcfbf5828cdd9e052f69baef3a08343e4.zip
app-vim/vimclojure: drop 2.3.6-r3
Closes: https://bugs.gentoo.org/850067 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/30528 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'app-vim/vimclojure')
-rw-r--r--app-vim/vimclojure/vimclojure-2.3.6-r3.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/app-vim/vimclojure/vimclojure-2.3.6-r3.ebuild b/app-vim/vimclojure/vimclojure-2.3.6-r3.ebuild
deleted file mode 100644
index 00329ea89431..000000000000
--- a/app-vim/vimclojure/vimclojure-2.3.6-r3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit vim-plugin
-
-MY_PN="VimClojure"
-
-DESCRIPTION="vim plugin: Clojure syntax highlighting, filetype and indent settings"
-HOMEPAGE="https://github.com/vim-scripts/VimClojure"
-SRC_URI="https://github.com/vim-scripts/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="amd64 x86"
-LICENSE="BSD"
-SLOT="0"
-
-RDEPEND="dev-lang/clojure"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-DOCS=( README README.markdown )
-
-# Files with similar names are already installed by app-vim/slimv.
-DUPLICATE_FILES=(
- indent/clojure.vim
- ftdetect/clojure.vim
-)
-
-src_prepare() {
- default
-
- # Remove .bat files.
- find . -type f -name \*.bat -exec rm -v {} \; || die
-
- # Let's simply rename ${DUPLICATE_FILES[@]}.
- local f
- for f in "${DUPLICATE_FILES[@]}"; do
- [[ -f "${f}" ]] || die "Couldn't find ${f}"
- bname="${f##*/}"
- path="${f%/*}"
- noext="${bname%%.*}"
- newname="${path}/${PN}_${noext}.vim"
- mv -v "${f}" "${newname}" || die
- done
-}
-
-src_install() {
- rm -rv doc/LICENSE.txt bin || die
- vim-plugin_src_install
-}