summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna Vyalkova <cyber+gentoo@sysrq.in>2022-06-21 12:33:19 +0500
committerJoonas Niilola <juippis@gentoo.org>2022-06-22 14:29:06 +0300
commitce3ab8cc69ccbee826021fa181bd069b313f1a58 (patch)
treec1d844517fc20444fe09fbd1abf73d40bd7bcf34 /app-vim/vspec
parentsys-libs/libsmbios: update LICENSE (diff)
downloadgentoo-ce3ab8cc69ccbee826021fa181bd069b313f1a58.tar.gz
gentoo-ce3ab8cc69ccbee826021fa181bd069b313f1a58.tar.bz2
gentoo-ce3ab8cc69ccbee826021fa181bd069b313f1a58.zip
app-vim/vspec: new package, add 1.9.2
Signed-off-by: Anna Vyalkova <cyber+gentoo@sysrq.in> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-vim/vspec')
-rw-r--r--app-vim/vspec/Manifest1
-rw-r--r--app-vim/vspec/metadata.xml14
-rw-r--r--app-vim/vspec/vspec-1.9.2.ebuild52
3 files changed, 67 insertions, 0 deletions
diff --git a/app-vim/vspec/Manifest b/app-vim/vspec/Manifest
new file mode 100644
index 000000000000..5d2aab7c21ed
--- /dev/null
+++ b/app-vim/vspec/Manifest
@@ -0,0 +1 @@
+DIST vspec-1.9.2.tar.gz 28882 BLAKE2B 016b91e2eb9ef5b6d8ebf563ddd620ce9e57dc4a9d013a67b3d5cf644325c49f02aaef8b3a114b6802494ca026989ff56ab1f0cb5e398f6cc9eb91fee96797ea SHA512 0c453743f73cfc5990fcb7222cc6fc1b96b93b15b4ef701562f84ae8ef2961c0e2e256f32a400218518463b932a3efdba33e3ca0b418f3ac6969ab38aeaf348c
diff --git a/app-vim/vspec/metadata.xml b/app-vim/vspec/metadata.xml
new file mode 100644
index 000000000000..c8d770d94a01
--- /dev/null
+++ b/app-vim/vspec/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kana/vim-vspec</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vspec/vspec-1.9.2.ebuild b/app-vim/vspec/vspec-1.9.2.ebuild
new file mode 100644
index 000000000000..03193b3b04a1
--- /dev/null
+++ b/app-vim/vspec/vspec-1.9.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo vim-plugin
+
+DESCRIPTION="A testing framework for Vim script"
+HOMEPAGE="
+ https://www.vim.org/scripts/script.php?script_id=3012
+ https://github.com/kana/vim-vspec
+"
+SRC_URI="https://github.com/kana/vim-${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/vim-${P}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-lang/perl:*"
+BDEPEND="test? ( ${RDEPEND} )"
+
+VIM_PLUGIN_HELPFILES="vspec.txt"
+
+# Uncomment on the next release
+#DOCS=( {README,TUTORIAL_CI}.md )
+
+src_prepare() {
+ vim-plugin_src_prepare
+
+ # remove failing tests
+ rm t/{indent,syntax}.vim || die
+}
+
+src_test() {
+ export LC_ALL=C
+ edo ./bin/prove-vspec
+}
+
+src_install() {
+ # fix paths for the binary to be installed; don't do it in src_prepare
+ # as it will make the tests fail
+ sed "s|\$0|${EPREFIX}/usr/share/vim/vimfiles/bin/vspec|g" \
+ -i bin/vspec || die
+
+ vim-plugin_src_install bin
+
+ fperms +x /usr/share/vim/vimfiles/bin/{vspec,prove-vspec}
+ dosym -r {/usr/share/vim/vimfiles,/usr}/bin/vspec
+ dosym -r {/usr/share/vim/vimfiles,/usr}/bin/prove-vspec
+}