summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/youcompleteme
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/youcompleteme')
-rw-r--r--app-vim/youcompleteme/Manifest1
-rw-r--r--app-vim/youcompleteme/metadata.xml8
-rw-r--r--app-vim/youcompleteme/youcompleteme-20130910.ebuild88
-rw-r--r--app-vim/youcompleteme/youcompleteme-99999999.ebuild105
4 files changed, 202 insertions, 0 deletions
diff --git a/app-vim/youcompleteme/Manifest b/app-vim/youcompleteme/Manifest
new file mode 100644
index 000000000000..a903e652f00e
--- /dev/null
+++ b/app-vim/youcompleteme/Manifest
@@ -0,0 +1 @@
+DIST youcompleteme-20130910.tar.xz 2340104 SHA256 00906c92ba3c0f113c73398997008d9c8b3f31d617f5da233f25174a6d488bac SHA512 c1022a27ced00e8ba8e9aa25029a0032805331cf0f80342aaaf9d7d4ec7780a098ffbd315068f19f6c98b00c4b4b43e59c7fa40070057e097ca40f6398b53b6b WHIRLPOOL 867c3f0c08473246c52377bdb9ac52b96af1d1b3a970cb087784e54082afe19e6549c54bb37f460d379b5fac8f5f7aa4bccb1e24b0984a98c08750469ff518c6
diff --git a/app-vim/youcompleteme/metadata.xml b/app-vim/youcompleteme/metadata.xml
new file mode 100644
index 000000000000..0398088bee2e
--- /dev/null
+++ b/app-vim/youcompleteme/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>vim</herd>
+<use>
+ <flag name="clang">Enable semantic support for C-family languages using <pkg>sys-devel/clang</pkg></flag>
+</use>
+</pkgmetadata>
diff --git a/app-vim/youcompleteme/youcompleteme-20130910.ebuild b/app-vim/youcompleteme/youcompleteme-20130910.ebuild
new file mode 100644
index 000000000000..4a78befe4b53
--- /dev/null
+++ b/app-vim/youcompleteme/youcompleteme-20130910.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit multilib python-single-r1 cmake-utils vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="git://github.com/Valloric/YouCompleteMe.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="http://dev.gentoo.org/~radhermit/vim/${P}.tar.xz"
+fi
+
+DESCRIPTION="vim plugin: a code-completion engine for Vim"
+HOMEPAGE="http://valloric.github.io/YouCompleteMe/"
+
+LICENSE="GPL-3"
+IUSE="+clang test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ clang? ( >=sys-devel/clang-3.3 )
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ )"
+
+CMAKE_IN_SOURCE_BUILD=1
+CMAKE_USE_DIR=${S}/cpp
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ if ! use test ; then
+ sed -i '/^add_subdirectory( tests )/d' cpp/ycm/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_use clang CLANG_COMPLETER)
+ $(cmake-utils_use_use clang SYSTEM_LIBCLANG)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ # TODO: use system gmock/gtest
+ cd "${S}"/cpp
+ emake ycm_core_tests
+ cd ycm/tests || die
+ LD_LIBRARY_PATH="${EROOT}"/usr/$(get_libdir)/llvm \
+ "${S}"/cpp/ycm/tests/ycm_core_tests || die
+
+ cd "${S}"/python/ycm
+ nosetests || die
+}
+
+src_install() {
+ dodoc *.md
+ rm -r *.md *.sh COPYING.txt cpp || die
+ find python -name *test* -exec rm -rf {} + || die
+ rm python/libclang.so || die
+
+ vim-plugin_src_install
+
+ python_optimize "${ED}"
+ python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog
+ elog "optional dependencies:"
+ elog " dev-python/jedi (better python autocompletion)"
+ elog
+ fi
+}
diff --git a/app-vim/youcompleteme/youcompleteme-99999999.ebuild b/app-vim/youcompleteme/youcompleteme-99999999.ebuild
new file mode 100644
index 000000000000..2d9f013d1128
--- /dev/null
+++ b/app-vim/youcompleteme/youcompleteme-99999999.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit multilib python-single-r1 cmake-utils vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="git://github.com/Valloric/YouCompleteMe.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="http://dev.gentoo.org/~radhermit/vim/${P}.tar.xz"
+fi
+
+DESCRIPTION="vim plugin: a code-completion engine for Vim"
+HOMEPAGE="http://valloric.github.io/YouCompleteMe/"
+
+LICENSE="GPL-3"
+IUSE="+clang test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ clang? ( >=sys-devel/clang-3.3 )
+ dev-libs/boost[python,threads,${PYTHON_USEDEP}]
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/futures[${PYTHON_USEDEP}]
+ dev-python/jedi[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/sh[${PYTHON_USEDEP}]
+ dev-python/waitress[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ test? (
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ dev-cpp/gmock
+ dev-cpp/gtest
+ )
+"
+
+CMAKE_IN_SOURCE_BUILD=1
+CMAKE_USE_DIR=${S}/third_party/ycmd/cpp
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ if ! use test ; then
+ sed -i '/^add_subdirectory( tests )/d' third_party/ycmd/cpp/ycm/CMakeLists.txt || die
+ fi
+ for third_party_module in requests pythonfutures; do
+ rm -r "${S}"/third_party/${third_party_module} || die "Failed to remove third party module ${third_party_module}"
+ done
+ # Argparse is included in python 2.7
+ for third_party_module in argparse bottle jedi waitress sh requests; do
+ rm -r "${S}"/third_party/ycmd/third_party/${third_party_module} || die "Failed to remove third party module ${third_party_module}"
+ done
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_use clang CLANG_COMPLETER)
+ $(cmake-utils_use_use clang SYSTEM_LIBCLANG)
+ -DUSE_SYSTEM_BOOST=ON
+ -DUSE_SYSTEM_GMOCK=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd "${S}/third_party/ycmd/cpp/ycm/tests"
+ LD_LIBRARY_PATH="${EROOT}"/usr/$(get_libdir)/llvm \
+ ./ycm_core_tests || die
+
+ cd "${S}"/python/ycm
+
+ local dirs=( "${S}"/third_party/*/ "${S}"/third_party/ycmd/third_party/*/ )
+ local -x PYTHONPATH=${PYTHONPATH}:$(IFS=:; echo "${dirs[*]}")
+
+ nosetests || die
+}
+
+src_install() {
+ dodoc *.md third_party/ycmd/*.md
+ rm -r *.md *.sh COPYING.txt third_party/ycmd/cpp || die
+ rm -r third_party/ycmd/{*.md,*.sh} || die
+ find python -name *test* -exec rm -rf {} + || die
+ find "${S}" -name '.git*' -exec rm -rf {} + || die
+ rm third_party/ycmd/libclang.so || die
+
+ vim-plugin_src_install
+
+ python_optimize "${ED}"
+ python_fix_shebang "${ED}"
+}