summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-02 06:42:28 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-02 06:50:01 -0400
commit075714ca804fa3d009899d382fee9e1787681c6a (patch)
tree0a4dbb97ca96270ad65b59fb29fe8200e81d7369 /app-vim
parentdev-libs/libvterm: Drop old versions (diff)
downloadgentoo-075714ca804fa3d009899d382fee9e1787681c6a.tar.gz
gentoo-075714ca804fa3d009899d382fee9e1787681c6a.tar.bz2
gentoo-075714ca804fa3d009899d382fee9e1787681c6a.zip
app-vim/syntastic: Version bump to 3.10.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/syntastic/Manifest1
-rw-r--r--app-vim/syntastic/syntastic-3.10.0.ebuild33
-rw-r--r--app-vim/syntastic/syntastic-9999.ebuild2
3 files changed, 35 insertions, 1 deletions
diff --git a/app-vim/syntastic/Manifest b/app-vim/syntastic/Manifest
index 815dca2da899..1304f3387848 100644
--- a/app-vim/syntastic/Manifest
+++ b/app-vim/syntastic/Manifest
@@ -1 +1,2 @@
+DIST syntastic-3.10.0.tar.gz 268037 BLAKE2B 90f055a919d8b2407bda2daa3570e3fc9e2970905f65eca52f0a3a01c878eb98e2197ed017d272af298b42206f93fc73cfcdd196a638f9c536d4af44de6209d2 SHA512 c19f2f7b709bbd9aab30da0f493e773e3e56d97efa0e558af7a97fcda1bb2f091355e06d24971f1bde5b321e027b6fc279b1d473599b77db0e996bf7a247fcd8
DIST syntastic-3.9.0.tar.gz 263275 BLAKE2B 574cf958b859a108cdfdffed29b3ff0f0903dac5c7fbc497e2c69831ee35532d317bde0ab827dda828ee7cb3cc13ab9176c9ea6ea233e03e7b3fcb5b7c49757e SHA512 04cee939226940bb95935434b7aba42a3419b8b7b73d5fa9052a6aaccec5d0724c4e3634edd56573d0080b31baf49c1a00811c6f88e4fbbdea7e761e5707dcb5
diff --git a/app-vim/syntastic/syntastic-3.10.0.ebuild b/app-vim/syntastic/syntastic-3.10.0.ebuild
new file mode 100644
index 000000000000..d109f7f00959
--- /dev/null
+++ b/app-vim/syntastic/syntastic-3.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vim-syntastic/syntastic.git"
+else
+ SRC_URI="https://github.com/vim-syntastic/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: syntax checking using external tools"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2736 https://github.com/vim-syntastic/syntastic/"
+LICENSE="WTFPL-2"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ default
+ rm -r _assets || die
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Syntastic has many optional dependencies depending on the type"
+ elog "of syntax checking being performed. Look in the related files in"
+ elog "the syntax_checkers directory to help figure out what programs"
+ elog "different languages need."
+ fi
+}
diff --git a/app-vim/syntastic/syntastic-9999.ebuild b/app-vim/syntastic/syntastic-9999.ebuild
index d35f80b3f9ed..d109f7f00959 100644
--- a/app-vim/syntastic/syntastic-9999.ebuild
+++ b/app-vim/syntastic/syntastic-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7