summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-10-08 07:54:46 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-10-08 07:56:22 +0000
commitaf5bff75b3af9ac8534514899df94e5d8f0f56ce (patch)
treeafe9943c0f957ba85dff51796856156551376497 /app-vim
parentdev-java/jrobin: Stable for amd64. Stable for x86 using the ALLARCHES policy. (diff)
downloadgentoo-af5bff75b3af9ac8534514899df94e5d8f0f56ce.tar.gz
gentoo-af5bff75b3af9ac8534514899df94e5d8f0f56ce.tar.bz2
gentoo-af5bff75b3af9ac8534514899df94e5d8f0f56ce.zip
app-vim/vimclojure: Initial commit. Fixes bug 292301.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimclojure/Manifest1
-rw-r--r--app-vim/vimclojure/metadata.xml8
-rw-r--r--app-vim/vimclojure/vimclojure-2.3.6.ebuild30
3 files changed, 39 insertions, 0 deletions
diff --git a/app-vim/vimclojure/Manifest b/app-vim/vimclojure/Manifest
new file mode 100644
index 000000000000..19d9b16ae744
--- /dev/null
+++ b/app-vim/vimclojure/Manifest
@@ -0,0 +1 @@
+DIST 2.3.6.zip 44737 SHA256 7c1a9197e8ed2540c921a4e448c88d784740de891cfe58c57e19e9c5c499cd5b SHA512 daf4f691500c3b901a57849c6f07b500c49f7086e0733921f589e362a53a0d07b99eab7d6ea42f1828822942b294f51a684eec93ebab1797438da4b81199ca9d WHIRLPOOL b908cf86313cdd3521f15c2090cbb9f4f2a8a7c656ff1a152fa3707f62e1c6a49fbf6dcf2d596107e6cb2ab579f9aa3e5aec60d04fc91a8f08396bb813b43481
diff --git a/app-vim/vimclojure/metadata.xml b/app-vim/vimclojure/metadata.xml
new file mode 100644
index 000000000000..b97972bbc105
--- /dev/null
+++ b/app-vim/vimclojure/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <maintainer>
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/vimclojure/vimclojure-2.3.6.ebuild b/app-vim/vimclojure/vimclojure-2.3.6.ebuild
new file mode 100644
index 000000000000..52d177f62ae9
--- /dev/null
+++ b/app-vim/vimclojure/vimclojure-2.3.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN="VimClojure"
+
+DESCRIPTION="vim plugin: Clojure syntax highlighting, filetype and indent settings"
+HOMEPAGE="https://github.com/vim-scripts/VimClojure"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/archive/${PV}.zip"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ find "${S}" -type f -name \*.bat -exec rm -v {} \; || die
+}
+
+src_install() {
+ local my_license="doc/LICENSE.txt"
+ dodoc ${my_license}
+ rm -v ${my_license} || die
+ vim-plugin_src_install
+}