summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2017-03-26 22:02:54 +0200
committerTupone Alfredo <tupone@gentoo.org>2017-03-26 22:02:54 +0200
commit14755823acb49bf2d36e0d3d5dfa4ee48ffc3a8c (patch)
treedb58af1128706e1d1e7cdd6d3bab4735989cf25b /dev-ada/xmlada
parentdev-php/phpunit: Mark ~hppa (bug #613766). (diff)
downloadgentoo-14755823acb49bf2d36e0d3d5dfa4ee48ffc3a8c.tar.gz
gentoo-14755823acb49bf2d36e0d3d5dfa4ee48ffc3a8c.tar.bz2
gentoo-14755823acb49bf2d36e0d3d5dfa4ee48ffc3a8c.zip
dev-ada/xmlada: Add dev-ada/xmlada
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ada/xmlada')
-rw-r--r--dev-ada/xmlada/Manifest1
-rw-r--r--dev-ada/xmlada/files/xmlada-2016-gentoo.patch38
-rw-r--r--dev-ada/xmlada/metadata.xml20
-rw-r--r--dev-ada/xmlada/xmlada-2016.ebuild42
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-ada/xmlada/Manifest b/dev-ada/xmlada/Manifest
new file mode 100644
index 000000000000..63b4b662dc0f
--- /dev/null
+++ b/dev-ada/xmlada/Manifest
@@ -0,0 +1 @@
+DIST xmlada-gpl-2016-src.tar.gz 1440671 SHA256 ea64d8da2c5fb01a257fc5bf474b8d4ec40b01dc15b320b9fe260ff2db668ba4 SHA512 d1d7c3d91731394235aed4b80c91b1babe30d5f184282fae8087ee556318475e3923ed628b805693fc89a4d9bb219b0fb0937bc5024a742226da0245d36ed652 WHIRLPOOL b6ebb927d801394ad0b62d9538142c420ab33627582059466d4f64b12c3a45b1b5b489019aef715a59101370220a78507fe03d97c9e67233dfcc4f3aad1f16d7
diff --git a/dev-ada/xmlada/files/xmlada-2016-gentoo.patch b/dev-ada/xmlada/files/xmlada-2016-gentoo.patch
new file mode 100644
index 000000000000..e167c1df1452
--- /dev/null
+++ b/dev-ada/xmlada/files/xmlada-2016-gentoo.patch
@@ -0,0 +1,38 @@
+--- xmlada-2016-src/Makefile.in.old 2016-12-04 21:58:57.251338692 +0100
++++ xmlada-2016-src/Makefile.in 2016-12-04 21:59:31.332755615 +0100
+@@ -7,7 +7,7 @@
+ PACKAGE_TARNAME=@PACKAGE_TARNAME@
+ VERSION=@PACKAGE_VERSION@
+ BUILDS_SHARED=@GNAT_BUILDS_SHARED@
+-prefix=@prefix@
++prefix=$(DESTDIR)@prefix@
+
+ # Set a default value (ignored if set in the environment)
+ PROCESSORS?=0
+@@ -49,13 +49,13 @@
+ endif
+
+ static:
+- ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} xmlada.gpr
++ ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} xmlada.gpr -cargs $(ADAFLAGS)
+
+ shared relocatable:
+- ${GPRBUILD} -p -XLIBRARY_TYPE=relocatable ${GPROPTS} xmlada.gpr
++ ${GPRBUILD} -p -XLIBRARY_TYPE=relocatable ${GPROPTS} xmlada.gpr -cargs $(ADAFLAGS)
+
+ static-pic:
+- ${GPRBUILD} -p -XLIBRARY_TYPE=static-pic ${GPROPTS} xmlada.gpr
++ ${GPRBUILD} -p -XLIBRARY_TYPE=static-pic ${GPROPTS} xmlada.gpr -cargs $(ADAFLAGS)
+
+ # Rebuild the tests (and not the XML/Ada code itself)
+ test: force
+--- xmlada-gpl-2016-src/shared.gpr.in.old 2017-03-26 21:48:46.613541125 +0200
++++ xmlada-gpl-2016-src/shared.gpr.in 2017-03-26 21:49:32.713754025 +0200
+@@ -76,6 +76,7 @@
+ when "profile" =>
+ for Switches ("Ada") use warnings & ("-g", "-pg");
+ end case;
++ for Driver ("Ada") use External ("ADA", "gcc");
+ end compiler;
+
+ package binder is
diff --git a/dev-ada/xmlada/metadata.xml b/dev-ada/xmlada/metadata.xml
new file mode 100644
index 000000000000..521d595c3ffb
--- /dev/null
+++ b/dev-ada/xmlada/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <use>
+ <flag name="shared">Build shared library</flag>
+ <flag name="static">Build static library</flag>
+ <flag name="static-pic">Build static library with pic code</flag>
+ </use>
+ <longdescription lang="en">
+ XML/Ada is a set of modules that provide a simple manipulation of XML streams. It supports the whole XML 1.1 specifications, and can parse any file that follows this standard (including the contents of the DTD, although no validation of the document is done based on those).
+
+ It also provides support for a number of other standard associated with XML, like SAX, DOM and XML schemas.
+
+ In addition, it includes a module to manipulate Unicode streams, since this is required by the XML standard.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-ada/xmlada/xmlada-2016.ebuild b/dev-ada/xmlada/xmlada-2016.ebuild
new file mode 100644
index 000000000000..fa4667143e1c
--- /dev/null
+++ b/dev-ada/xmlada/xmlada-2016.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multiprocessing
+
+MYP=${PN}-gpl-${PV}
+
+DESCRIPTION="Set of modules that provide a simple manipulation of XML streams"
+HOMEPAGE="http://libre.adacore.com/"
+SRC_URI="http://mirrors.cdn.adacore.com/art/57399978c7a447658e0affc0 -> ${MYP}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+shared static static-pic"
+REQUIRED_USE="|| ( shared static static-pic )"
+
+RDEPEND="dev-ada/gprbuild"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MYP}-src
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_compile () {
+ for kind in shared static static-pic; do
+ if use ${kind}; then
+ emake PROCESSORS=$(makeopts_jobs) ${kind}
+ fi
+ done
+}
+
+src_install () {
+ for kind in shared static static-pic; do
+ if use ${kind}; then
+ emake PROCESSORS=$(makeopts_jobs) DESTDIR="${D}" install-${kind}
+ fi
+ done
+ einstalldocs
+}