summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-01 10:00:27 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-01 10:02:02 +0200
commit755e2e74b59343ea17fa6b7582ced53cd83dfd0f (patch)
treee9b2954a209e84f61273cbfc9f4cb26e00a65cf5 /dev-ada
parentpackage.mask: remove some masked for removal packages (diff)
downloadgentoo-755e2e74b59343ea17fa6b7582ced53cd83dfd0f.tar.gz
gentoo-755e2e74b59343ea17fa6b7582ced53cd83dfd0f.tar.bz2
gentoo-755e2e74b59343ea17fa6b7582ced53cd83dfd0f.zip
package.mask: remove some masked for removal packages
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/asis-gpl/Manifest3
-rw-r--r--dev-ada/asis-gpl/asis-gpl-3.4.6.2006.ebuild113
-rw-r--r--dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r1.ebuild121
-rw-r--r--dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r2.ebuild123
-rw-r--r--dev-ada/asis-gpl/asis-gpl-4.1.3.2008-r1.ebuild127
-rw-r--r--dev-ada/asis-gpl/asis-gpl-4.1.3.2008.ebuild123
-rw-r--r--dev-ada/asis-gpl/metadata.xml17
7 files changed, 0 insertions, 627 deletions
diff --git a/dev-ada/asis-gpl/Manifest b/dev-ada/asis-gpl/Manifest
deleted file mode 100644
index f4f21740f3f1..000000000000
--- a/dev-ada/asis-gpl/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST asis-gpl-2006.tar.bz2 1546623 SHA256 66825814792b1ddce9a6e3cc43c7426f9a563d9dbaa1b254884139b51279ebf4 SHA512 6afba6c335329670977b0aee5275928a039968ef5120978e619959f30981fd5da971c6f72a1848399061fa03490c96ff1ad7bae6c197e667ad4bc798847952af WHIRLPOOL 06d5198dbd38c8c048175ff4464496d585eb4752007d074fda1f3e77cec8e8df49fa6c6b952ac1ef2df8609742773490301a9a4149ad435ec91d09629eea3a39
-DIST asis-gpl-2007-src.tgz 2268673 SHA256 6b8f5d3372bcfa83a49e991550f8e7ecb66d3fc59cac3d1cbc835eee32da189b SHA512 93c45c4cf056038eac70e14b07a9e1cd1de45ca8339b512633f9427622bfe669787b53c66124a46d6bdaaefaf8602b09e2e0345bfc6cdd758e52d32d63fd5fcc WHIRLPOOL f81712992035da6a8097be894c4202ab8159b8514b8828a5bf2b7922b2cd29e38e2cb7bc4bf3758d99889ca127035648946207e8c41592f873abb62020023d48
-DIST asis-gpl-2008-src.tgz 2324780 SHA256 74e306f4c24c79d2bd9395c3ec03edbbdaeb2741e962e7398116b45aa4c4869f SHA512 8513b3211c8021da54d1c79c3d10155c75a29be4780465666cd6e18c4c0e0565e5e5c15eaa1b21c0e18f6cc4342c7dcabcdf55b3f483a5587f227c3c6cf87fa2 WHIRLPOOL 9cf5fb78b79e4551ef10181b2b04d327421b3575223a9684d8d81ccf6e3df8ea2c9d0555ebee457fa059e6d7cb6a398ab7b2ab820ffa6a5f3b54e9ad63eb16b9
diff --git a/dev-ada/asis-gpl/asis-gpl-3.4.6.2006.ebuild b/dev-ada/asis-gpl/asis-gpl-3.4.6.2006.ebuild
deleted file mode 100644
index 92d4d7c3bfe3..000000000000
--- a/dev-ada/asis-gpl/asis-gpl-3.4.6.2006.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils flag-o-matic gnatbuild
-
-ACT_Ver=$(get_version_component_range 4)
-Gnat_Name="gnat-gpl"
-
-DESCRIPTION="The Ada Semantic Interface Specification (tools tied to compiler)"
-SRC_URI="mirror://gentoo/${PN}-${ACT_Ver}.tar.bz2"
-HOMEPAGE="https://libre.adacore.com/"
-LICENSE="GPL-2"
-
-KEYWORDS="~amd64 ~x86"
-
-IUSE="doc"
-RDEPEND="=dev-lang/gnat-gpl-${PV}*"
-DEPEND="${RDEPEND}
- doc? ( virtual/latex-base
- app-text/texi2html )"
-
-S="${WORKDIR}/asis-${ACT_Ver}"
-
-# it may be even better to force plain -O2 -pipe -ftracer here
-replace-flags -O3 -O2
-
-pkg_setup() {
- currGnat=$(eselect gnat show | grep "gnat-" | awk '{ print $1 }')
- if [[ "${currGnat}" != "${CTARGET}-${Gnat_Name}-${SLOT}" ]]; then
- echo
- eerror "The active gnat profile does not correspond to the selected"
- eerror "version of asis! Please install the appropriate gnat (if you"
- eerror "did not so yet) and run:"
- eerror "eselect gnat set ${CTARGET}-${Gnat_Name}-${SLOT}"
- eerror "env-update && source /etc/profile"
- eerror "and then emerge =dev-ada/${P} again.."
- echo
- die
- fi
-}
-
-# we need to override the eclass defined src_unpack
-src_unpack() {
- unpack ${A}
-}
-
-src_compile() {
- # Build the shared library first, we need -fPIC here
- gnatmake -Pasis_bld -XBLD=prod -XOPSYS=default_Unix -cargs ${CFLAGS} -fPIC \
- || die "building libasis.a failed"
- gnatgcc -shared -Wl,-soname,libasis-${ACT_Ver}.so \
- -o obj/libasis-${ACT_Ver}.so obj/*.o -lc \
- || die "building libasis.so failed"
-
- # build tools
- for fn in tools/*; do
- pushd ${fn}
- gnatmake -P${fn:6}.gpr || die "building ${fn:6} failed"
- popd
- done
-
- # common stuff is just docs in this case
- if use doc; then
- emake -C documentation all || die "Failed while compiling documentation"
- fi
-}
-
-src_install () {
- # we need to adjust some vars defined in gnatbuild.eclass so that they use
- # gnat-gpl instead of asis
- LIBPATH=${LIBPATH/${PN}/${Gnat_Name}}
- BINPATH=${BINPATH/${PN}/${Gnat_Name}}
- DATAPATH=${DATAPATH/${PN}/${Gnat_Name}}
-
- # install the lib
- mkdir -p "${D}${LIBPATH}"/adalib
- chmod 0755 obj/libasis-${ACT_Ver}.so
- cp obj/libasis-${ACT_Ver}.so "${D}${LIBPATH}"/adalib
- insinto ${LIBPATH}/adalib
- doins obj/*.ali lib/libasis.a
- # make appropriate symlinks
- pushd "${D}${LIBPATH}"/adalib
- ln -s libasis-${ACT_Ver}.so libasis.so
- popd
- # sources
- insinto ${LIBPATH}/adainclude
- doins gnat/*.ad[sb]
- doins asis/*.ad[sb]
-
- # tools
- mkdir -p "${D}${BINPATH}"
- for fn in tools/{asistant,gnat*}; do
- cp ${fn}/${fn:6} "${D}${BINPATH}"
- done
-
- # docs and examples
- dodoc documentation/*.txt
- dohtml documentation/*.html
- # info's should go into gnat-gpl dirs
- insinto ${DATAPATH}/info/
- doins documentation/*.info
-
- insinto /usr/share/doc/${PF}
- doins -r documentation/*.pdf examples/ tutorial/ templates/
-}
-
-pkg_postinst() {
- echo
- elog "The ASIS is installed for the active gnat compiler at gnat's location."
- elog "No further configuration is necessary. Enjoy."
- echo
-}
diff --git a/dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r1.ebuild b/dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r1.ebuild
deleted file mode 100644
index 549d864d115c..000000000000
--- a/dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r1.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils flag-o-matic gnatbuild
-
-ACT_Ver=$(get_version_component_range 4)
-Gnat_Name="gnat-gpl"
-
-DESCRIPTION="The Ada Semantic Interface Specification (semantic analysis and tools tied to compiler)"
-SRC_URI="mirror://gentoo/${PN}-${ACT_Ver}-src.tgz"
-HOMEPAGE="https://libre.adacore.com/"
-LICENSE="GPL-2"
-
-KEYWORDS="~amd64 ~x86"
-
-IUSE="doc"
-RDEPEND="=dev-lang/gnat-gpl-${PV}*"
-DEPEND="${RDEPEND}
- doc? ( virtual/latex-base
- app-text/texi2html )"
-
-S="${WORKDIR}/asis-${ACT_Ver}-src"
-
-# it may be even better to force plain -O2 -pipe -ftracer here
-replace-flags -O3 -O2
-
-# we need to adjust some vars defined in gnatbuild.eclass so that they use
-# gnat-gpl instead of asis
-LIBPATH=${LIBPATH/${PN}/${Gnat_Name}}
-BINPATH=${BINPATH/${PN}/${Gnat_Name}}
-DATAPATH=${DATAPATH/${PN}/${Gnat_Name}}
-
-QA_EXECSTACK="${BINPATH:1}/*
- ${LIBPATH:1}/adalib/libasis-${ACT_Ver}.so"
-
-pkg_setup() {
- currGnat=$(eselect gnat show | grep "gnat-" | awk '{ print $1 }')
- if [[ "${currGnat}" != "${CTARGET}-${Gnat_Name}-${SLOT}" ]]; then
- echo
- eerror "The active gnat profile does not correspond to the selected"
- eerror "version of asis! Please install the appropriate gnat (if you"
- eerror "did not so yet) and run:"
- eerror "eselect gnat set ${CTARGET}-${Gnat_Name}-${SLOT}"
- eerror "env-update && source /etc/profile"
- eerror "and then emerge =dev-ada/${P} again.."
- echo
- die
- fi
-}
-
-# we need to override the eclass defined src_unpack
-# and change gcc to gnatgcc where appropriate
-src_unpack() {
- unpack ${A}
- cd "${S}"
- for fn in asis/a4g-gnat_int.adb gnat/snames.adb tools/tool_utils/asis_ul-common.adb; do
- sed -i -e "s:\"gcc:\"gnatgcc:" ${fn}
- done
-}
-
-src_compile() {
- # Build the shared library first, we need -fPIC here
- gnatmake -Pasis_bld -XBLD=prod -XOPSYS=default_Unix -cargs ${CFLAGS} -fPIC \
- || die "building libasis.a failed"
- gnatgcc -shared -Wl,-soname,libasis-${ACT_Ver}.so \
- -o obj/libasis-${ACT_Ver}.so obj/*.o -lc \
- || die "building libasis.so failed"
-
- # build tools
- for fn in tools/*; do
- pushd ${fn}
- gnatmake -P${fn:6}.gpr || die "building ${fn:6} failed"
- popd
- done
-
- # common stuff is just docs in this case
- if use doc; then
- emake -C documentation all || die "Failed while compiling documentation"
- fi
-}
-
-src_install () {
- # install the lib
- mkdir -p "${D}${LIBPATH}"/adalib
- chmod 0755 obj/libasis-${ACT_Ver}.so
- cp obj/libasis-${ACT_Ver}.so "${D}${LIBPATH}"/adalib
- insinto ${LIBPATH}/adalib
- doins obj/*.ali lib/libasis.a
- # make appropriate symlinks
- pushd "${D}${LIBPATH}"/adalib
- ln -s libasis-${ACT_Ver}.so libasis.so
- popd
- # sources
- insinto ${LIBPATH}/adainclude
- doins gnat/*.ad[sb]
- doins asis/*.ad[sb]
-
- # tools
- mkdir -p "${D}${BINPATH}"
- for fn in tools/{asistant,gnat*}; do
- cp ${fn}/${fn:6} "${D}${BINPATH}"
- done
-
- # docs and examples
- dodoc documentation/*.txt
- dohtml documentation/*.html
- # info's should go into gnat-gpl dirs
- insinto ${DATAPATH}/info/
- doins documentation/*.info
-
- insinto /usr/share/doc/${PF}
- doins -r documentation/*.pdf examples/ tutorial/ templates/
-}
-
-pkg_postinst() {
- echo
- elog "The ASIS is installed for the active gnat compiler at gnat's location."
- elog "No further configuration is necessary. Enjoy."
- echo
-}
diff --git a/dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r2.ebuild b/dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r2.ebuild
deleted file mode 100644
index 00cd4390645c..000000000000
--- a/dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r2.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils flag-o-matic gnatbuild
-
-ACT_Ver=$(get_version_component_range 4)
-Gnat_Name="gnat-gpl"
-
-DESCRIPTION="The Ada Semantic Interface Specification (semantic analysis and tools tied to compiler)"
-SRC_URI="mirror://gentoo/${PN}-${ACT_Ver}-src.tgz"
-HOMEPAGE="https://libre.adacore.com/"
-LICENSE="GPL-2"
-
-KEYWORDS="~amd64 ~x86"
-
-IUSE="doc"
-RDEPEND="=dev-lang/gnat-gpl-${PV}*"
-DEPEND="${RDEPEND}
- doc? ( virtual/latex-base
- app-text/texi2html )"
-
-S="${WORKDIR}/asis-${ACT_Ver}-src"
-
-# it may be even better to force plain -O2 -pipe -ftracer here
-replace-flags -O3 -O2
-
-# we need to adjust some vars defined in gnatbuild.eclass so that they use
-# gnat-gpl instead of asis
-LIBPATH=${LIBPATH/${PN}/${Gnat_Name}}
-BINPATH=${BINPATH/${PN}/${Gnat_Name}}
-DATAPATH=${DATAPATH/${PN}/${Gnat_Name}}
-
-QA_EXECSTACK="${BINPATH:1}/*
- ${LIBPATH:1}/adalib/libasis-${ACT_Ver}.so"
-
-pkg_setup() {
- currGnat=$(eselect gnat show | grep "gnat-" | awk '{ print $1 }')
- if [[ "${currGnat}" != "${CTARGET}-${Gnat_Name}-${SLOT}" ]]; then
- echo
- eerror "The active gnat profile does not correspond to the selected"
- eerror "version of asis! Please install the appropriate gnat (if you"
- eerror "did not so yet) and run:"
- eerror "eselect gnat set ${CTARGET}-${Gnat_Name}-${SLOT}"
- eerror "env-update && source /etc/profile"
- eerror "and then emerge =dev-ada/${P} again.."
- echo
- die
- fi
-}
-
-# we need to override the eclass defined src_unpack
-# and change gcc to gnatgcc where appropriate
-src_unpack() {
- unpack ${A}
- cd "${S}"
- for fn in asis/a4g-gnat_int.adb gnat/snames.adb \
- tools/tool_utils/asis_ul-common.adb \
- tools/gnatmetric/metrics-compute.adb; do
- sed -i -e "s:\"gcc:\"gnatgcc:" ${fn}
- done
-}
-
-src_compile() {
- # Build the shared library first, we need -fPIC here
- gnatmake -Pasis_bld -XBLD=prod -XOPSYS=default_Unix -cargs ${CFLAGS} -fPIC \
- || die "building libasis.a failed"
- gnatgcc -shared -Wl,-soname,libasis-${ACT_Ver}.so \
- -o obj/libasis-${ACT_Ver}.so obj/*.o -lc \
- || die "building libasis.so failed"
-
- # build tools
- for fn in tools/*; do
- pushd ${fn}
- gnatmake -P${fn:6}.gpr || die "building ${fn:6} failed"
- popd
- done
-
- # common stuff is just docs in this case
- if use doc; then
- emake -C documentation all || die "Failed while compiling documentation"
- fi
-}
-
-src_install () {
- # install the lib
- mkdir -p "${D}${LIBPATH}"/adalib
- chmod 0755 obj/libasis-${ACT_Ver}.so
- cp obj/libasis-${ACT_Ver}.so "${D}${LIBPATH}"/adalib
- insinto ${LIBPATH}/adalib
- doins obj/*.ali lib/libasis.a
- # make appropriate symlinks
- pushd "${D}${LIBPATH}"/adalib
- ln -s libasis-${ACT_Ver}.so libasis.so
- popd
- # sources
- insinto ${LIBPATH}/adainclude
- doins gnat/*.ad[sb]
- doins asis/*.ad[sb]
-
- # tools
- mkdir -p "${D}${BINPATH}"
- for fn in tools/{asistant,gnat*}; do
- cp ${fn}/${fn:6} "${D}${BINPATH}"
- done
-
- # docs and examples
- dodoc documentation/*.txt
- dohtml documentation/*.html
- # info's should go into gnat-gpl dirs
- insinto ${DATAPATH}/info/
- doins documentation/*.info
-
- insinto /usr/share/doc/${PF}
- doins -r documentation/*.pdf examples/ tutorial/ templates/
-}
-
-pkg_postinst() {
- echo
- elog "The ASIS is installed for the active gnat compiler at gnat's location."
- elog "No further configuration is necessary. Enjoy."
- echo
-}
diff --git a/dev-ada/asis-gpl/asis-gpl-4.1.3.2008-r1.ebuild b/dev-ada/asis-gpl/asis-gpl-4.1.3.2008-r1.ebuild
deleted file mode 100644
index 04d7ddbd9d2b..000000000000
--- a/dev-ada/asis-gpl/asis-gpl-4.1.3.2008-r1.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# NOTE: gnat-gpl-2007 and 2008 have "incompatible bugs"
-# so, we separate asis following the separation of gnat
-SLOT="4.1-2008"
-
-inherit eutils flag-o-matic gnatbuild
-
-ACT_Ver=$(get_version_component_range 4)
-Gnat_Name="gnat-gpl"
-
-DESCRIPTION="The Ada Semantic Interface Specification (semantic analysis and tools tied to compiler)"
-SRC_URI="mirror://gentoo/${PN}-${ACT_Ver}-src.tgz"
-HOMEPAGE="https://libre.adacore.com/"
-LICENSE="GPL-2"
-
-KEYWORDS="~amd64 ~x86"
-
-IUSE="doc"
-RDEPEND="=dev-lang/gnat-gpl-${PV}*"
-DEPEND="${RDEPEND}
- doc? ( virtual/latex-base
- app-text/texi2html )"
-
-S="${WORKDIR}/asis-${ACT_Ver}-src"
-
-# it may be even better to force plain -O2 -pipe -ftracer here
-replace-flags -O3 -O2
-
-# we need to adjust some vars defined in gnatbuild.eclass so that they use
-# gnat-gpl instead of asis
-LIBPATH=${LIBPATH/${PN}/${Gnat_Name}}
-BINPATH=${BINPATH/${PN}/${Gnat_Name}}
-DATAPATH=${DATAPATH/${PN}/${Gnat_Name}}
-
-QA_EXECSTACK="${BINPATH:1}/*
- ${LIBPATH:1}/adalib/libasis-${ACT_Ver}.so"
-
-pkg_setup() {
- currGnat=$(eselect gnat show | grep "gnat-" | awk '{ print $1 }')
- if [[ "${currGnat}" != "${CTARGET}-${Gnat_Name}-${SLOT}" ]]; then
- echo
- eerror "The active gnat profile does not correspond to the selected"
- eerror "version of asis! Please install the appropriate gnat (if you"
- eerror "did not so yet) and run:"
- eerror "eselect gnat set ${CTARGET}-${Gnat_Name}-${SLOT}"
- eerror "env-update && source /etc/profile"
- eerror "and then emerge =dev-ada/${P} again.."
- echo
- die
- fi
-}
-
-# we need to override the eclass defined src_unpack
-# and change gcc to gnatgcc where appropriate
-src_unpack() {
- unpack ${A}
- cd "${S}"
- for fn in asis/a4g-gnat_int.adb gnat/snames.adb \
- tools/tool_utils/asis_ul-common.adb \
- tools/gnatmetric/metrics-compute.adb; do
- sed -i -e "s:\"gcc:\"gnatgcc:" ${fn}
- done
-}
-
-src_compile() {
- # Build the shared library first, we need -fPIC here
- gnatmake -Pasis_bld -XBLD=prod -XOPSYS=default_Unix -cargs ${CFLAGS} -fPIC \
- || die "building libasis.a failed"
- gnatgcc -shared -Wl,-soname,libasis-${ACT_Ver}.so \
- -o obj/libasis-${ACT_Ver}.so obj/*.o -lc \
- || die "building libasis.so failed"
-
- # build tools
- for fn in tools/*; do
- pushd ${fn}
- gnatmake -P${fn:6}.gpr || die "building ${fn:6} failed"
- popd
- done
-
- # common stuff is just docs in this case
- if use doc; then
- emake -C documentation all || die "Failed while compiling documentation"
- fi
-}
-
-src_install () {
- # install the lib
- mkdir -p "${D}${LIBPATH}"/adalib
- chmod 0755 obj/libasis-${ACT_Ver}.so
- cp obj/libasis-${ACT_Ver}.so "${D}${LIBPATH}"/adalib
- insinto ${LIBPATH}/adalib
- doins obj/*.ali lib/libasis.a
- # make appropriate symlinks
- pushd "${D}${LIBPATH}"/adalib
- ln -s libasis-${ACT_Ver}.so libasis.so
- popd
- # sources
- insinto ${LIBPATH}/adainclude
- doins gnat/*.ad[sb]
- doins asis/*.ad[sb]
-
- # tools
- mkdir -p "${D}${BINPATH}"
- for fn in tools/{asistant,gnat*}; do
- cp ${fn}/${fn:6} "${D}${BINPATH}"
- done
-
- # docs and examples
- dodoc documentation/*.txt
- dohtml documentation/*.html
- # info's should go into gnat-gpl dirs
- insinto ${DATAPATH}/info/
- doins documentation/*.info
-
- insinto /usr/share/doc/${PF}
- doins -r documentation/*.pdf tutorial/ templates/
-}
-
-pkg_postinst() {
- echo
- elog "The ASIS is installed for the active gnat compiler at gnat's location."
- elog "No further configuration is necessary. Enjoy."
- echo
-}
diff --git a/dev-ada/asis-gpl/asis-gpl-4.1.3.2008.ebuild b/dev-ada/asis-gpl/asis-gpl-4.1.3.2008.ebuild
deleted file mode 100644
index 885498f07486..000000000000
--- a/dev-ada/asis-gpl/asis-gpl-4.1.3.2008.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils flag-o-matic gnatbuild
-
-ACT_Ver=$(get_version_component_range 4)
-Gnat_Name="gnat-gpl"
-
-DESCRIPTION="The Ada Semantic Interface Specification (semantic analysis and tools tied to compiler)"
-SRC_URI="mirror://gentoo/${PN}-${ACT_Ver}-src.tgz"
-HOMEPAGE="https://libre.adacore.com/"
-LICENSE="GPL-2"
-
-KEYWORDS="~amd64 ~x86"
-
-IUSE="doc"
-RDEPEND="=dev-lang/gnat-gpl-${PV}*"
-DEPEND="${RDEPEND}
- doc? ( virtual/latex-base
- app-text/texi2html )"
-
-S="${WORKDIR}/asis-${ACT_Ver}-src"
-
-# it may be even better to force plain -O2 -pipe -ftracer here
-replace-flags -O3 -O2
-
-# we need to adjust some vars defined in gnatbuild.eclass so that they use
-# gnat-gpl instead of asis
-LIBPATH=${LIBPATH/${PN}/${Gnat_Name}}
-BINPATH=${BINPATH/${PN}/${Gnat_Name}}
-DATAPATH=${DATAPATH/${PN}/${Gnat_Name}}
-
-QA_EXECSTACK="${BINPATH:1}/*
- ${LIBPATH:1}/adalib/libasis-${ACT_Ver}.so"
-
-pkg_setup() {
- currGnat=$(eselect gnat show | grep "gnat-" | awk '{ print $1 }')
- if [[ "${currGnat}" != "${CTARGET}-${Gnat_Name}-${SLOT}" ]]; then
- echo
- eerror "The active gnat profile does not correspond to the selected"
- eerror "version of asis! Please install the appropriate gnat (if you"
- eerror "did not so yet) and run:"
- eerror "eselect gnat set ${CTARGET}-${Gnat_Name}-${SLOT}"
- eerror "env-update && source /etc/profile"
- eerror "and then emerge =dev-ada/${P} again.."
- echo
- die
- fi
-}
-
-# we need to override the eclass defined src_unpack
-# and change gcc to gnatgcc where appropriate
-src_unpack() {
- unpack ${A}
- cd "${S}"
- for fn in asis/a4g-gnat_int.adb gnat/snames.adb \
- tools/tool_utils/asis_ul-common.adb \
- tools/gnatmetric/metrics-compute.adb; do
- sed -i -e "s:\"gcc:\"gnatgcc:" ${fn}
- done
-}
-
-src_compile() {
- # Build the shared library first, we need -fPIC here
- gnatmake -Pasis_bld -XBLD=prod -XOPSYS=default_Unix -cargs ${CFLAGS} -fPIC \
- || die "building libasis.a failed"
- gnatgcc -shared -Wl,-soname,libasis-${ACT_Ver}.so \
- -o obj/libasis-${ACT_Ver}.so obj/*.o -lc \
- || die "building libasis.so failed"
-
- # build tools
- for fn in tools/*; do
- pushd ${fn}
- gnatmake -P${fn:6}.gpr || die "building ${fn:6} failed"
- popd
- done
-
- # common stuff is just docs in this case
- if use doc; then
- emake -C documentation all || die "Failed while compiling documentation"
- fi
-}
-
-src_install () {
- # install the lib
- mkdir -p "${D}${LIBPATH}"/adalib
- chmod 0755 obj/libasis-${ACT_Ver}.so
- cp obj/libasis-${ACT_Ver}.so "${D}${LIBPATH}"/adalib
- insinto ${LIBPATH}/adalib
- doins obj/*.ali lib/libasis.a
- # make appropriate symlinks
- pushd "${D}${LIBPATH}"/adalib
- ln -s libasis-${ACT_Ver}.so libasis.so
- popd
- # sources
- insinto ${LIBPATH}/adainclude
- doins gnat/*.ad[sb]
- doins asis/*.ad[sb]
-
- # tools
- mkdir -p "${D}${BINPATH}"
- for fn in tools/{asistant,gnat*}; do
- cp ${fn}/${fn:6} "${D}${BINPATH}"
- done
-
- # docs and examples
- dodoc documentation/*.txt
- dohtml documentation/*.html
- # info's should go into gnat-gpl dirs
- insinto ${DATAPATH}/info/
- doins documentation/*.info
-
- insinto /usr/share/doc/${PF}
- doins -r documentation/*.pdf tutorial/ templates/
-}
-
-pkg_postinst() {
- echo
- elog "The ASIS is installed for the active gnat compiler at gnat's location."
- elog "No further configuration is necessary. Enjoy."
- echo
-}
diff --git a/dev-ada/asis-gpl/metadata.xml b/dev-ada/asis-gpl/metadata.xml
deleted file mode 100644
index 75bb6042044e..000000000000
--- a/dev-ada/asis-gpl/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>ada@gentoo.org</email>
- <name>Gentoo Resources for Ada</name>
-</maintainer>
-<longdescription>
- Ada Semantic Interface Specification is a published international ISO
- standard (ISO/IEC 15291:1999). ASIS represents a compiler independent
- toolset consisting of a set of standard Ada interfaces which allow extraction
- of information about user source programs. This information was previously
- only available inside the Ada compilers themselves or exported in
- non-standard, and thus non portable mechanisms.
- This is the ACT version.
-</longdescription>
-</pkgmetadata>