summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/lib_mysqludf_sys
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/lib_mysqludf_sys')
-rw-r--r--dev-db/lib_mysqludf_sys/Manifest1
-rw-r--r--dev-db/lib_mysqludf_sys/lib_mysqludf_sys-0.0.3.ebuild59
-rw-r--r--dev-db/lib_mysqludf_sys/metadata.xml7
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-db/lib_mysqludf_sys/Manifest b/dev-db/lib_mysqludf_sys/Manifest
new file mode 100644
index 000000000000..7a99237b4058
--- /dev/null
+++ b/dev-db/lib_mysqludf_sys/Manifest
@@ -0,0 +1 @@
+DIST lib_mysqludf_sys_0.0.3.tar.gz 9136 SHA256 174f43d1df5372c84d98981031f02a2b9e090954ac473f543bff79f9a87c2c4d SHA512 17154007bc315b7f5c98ed4eb0f6305a1c2bbd4a66a3b6985ed4547baddffcaac71a384fcce0780e26968021439f32534160661a5db756a012763b2ac74a3060 WHIRLPOOL 5c4a626a12507af799c8b54c457d01556b80c91582aa22668e733ca6013ea70693feeaade8908ab3650cb84db7f0997df5b102ec5eb75b0eb0353c9e970639a6
diff --git a/dev-db/lib_mysqludf_sys/lib_mysqludf_sys-0.0.3.ebuild b/dev-db/lib_mysqludf_sys/lib_mysqludf_sys-0.0.3.ebuild
new file mode 100644
index 000000000000..ca363b97ff7c
--- /dev/null
+++ b/dev-db/lib_mysqludf_sys/lib_mysqludf_sys-0.0.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="MySQL UDFs that allows one to interact with the operating system"
+HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_sys/"
+SRC_URI="http://www.mysqludf.org/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/mysql-5.1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+# compile helper
+_compile() {
+ local CC="$(tc-getCC)"
+ echo "${CC} ${@}" && "${CC}" "${@}"
+}
+
+pkg_setup() {
+ MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
+ MYSQL_INCLUDE="$(mysql_config --include)"
+}
+
+src_prepare() {
+ # remove precompiled object
+ rm -f -- ${PN}.so
+}
+
+src_compile() {
+ _compile ${CFLAGS} -Wall -fPIC ${MYSQL_INCLUDE} \
+ -shared ${LDFLAGS} -o ${PN}.so ${PN}.c
+}
+
+src_install() {
+ exeinto "${MYSQL_PLUGINDIR}"
+ doexe ${PN}.so
+ dodoc ${PN}.sql
+ dohtml ${PN}.html
+}
+
+pkg_postinst() {
+ elog
+ elog "Please have a look at the documentation, how to"
+ elog "enable/disable the UDF functions of ${PN}."
+ elog
+ elog "The documentation is located here:"
+ elog "/usr/share/doc/${PF}"
+ elog
+}
diff --git a/dev-db/lib_mysqludf_sys/metadata.xml b/dev-db/lib_mysqludf_sys/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/dev-db/lib_mysqludf_sys/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>