summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/wxsqlite3
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/wxsqlite3')
-rw-r--r--dev-db/wxsqlite3/Manifest1
-rw-r--r--dev-db/wxsqlite3/files/wxsqlite3-3.0.6.1.pc.in14
-rw-r--r--dev-db/wxsqlite3/metadata.xml11
-rw-r--r--dev-db/wxsqlite3/wxsqlite3-3.0.6.1-r1.ebuild60
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-db/wxsqlite3/Manifest b/dev-db/wxsqlite3/Manifest
new file mode 100644
index 000000000000..c971129d0f62
--- /dev/null
+++ b/dev-db/wxsqlite3/Manifest
@@ -0,0 +1 @@
+DIST wxsqlite3-3.0.6.1.tar.gz 2707120 SHA256 c1d828782c72b86733ddfc8c1591040db8cb3c814871816374a7989727290996 SHA512 b7f496f7a9f8bbb9aa32049689efba9cc32dae868f56f26837c2dcb4546c88a488955c6d71776b4f9996090680d92e23834d6757ccd77e9507a55dc7e60e2f04 WHIRLPOOL b459c75929f209a17ca0cc757afe2ed2e4404c9654bd8db6c8fb61571746b6ce20c1623d4c8698569c9a35fd11ed77635e2a408c31701324fa09b84585660412
diff --git a/dev-db/wxsqlite3/files/wxsqlite3-3.0.6.1.pc.in b/dev-db/wxsqlite3/files/wxsqlite3-3.0.6.1.pc.in
new file mode 100644
index 000000000000..fe30b1f5d467
--- /dev/null
+++ b/dev-db/wxsqlite3/files/wxsqlite3-3.0.6.1.pc.in
@@ -0,0 +1,14 @@
+# Package Information for pkg-config
+
+prefix=/usr
+wxver=@WXVERSION@
+includedir=${prefix}/include/wx-${wxver}/
+libdir=${prefix}/@LIBDIR@
+
+Name: wxsqlite3-@WXVERSION@
+Description: SQLite3 C++ wrapper for use in programs based on the wxWidgets
+Version: @VERSION@
+#Requires: sqlite3
+Libs: -L${libdir} -lwxcode_gtk2u@WXDEBUG@_wxsqlite3-@WXVERSION@
+Libs.private: -lpthread
+Cflags: -I${includedir}
diff --git a/dev-db/wxsqlite3/metadata.xml b/dev-db/wxsqlite3/metadata.xml
new file mode 100644
index 000000000000..d41322c5106e
--- /dev/null
+++ b/dev-db/wxsqlite3/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>wxwidgets</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">wxcode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/wxsqlite3/wxsqlite3-3.0.6.1-r1.ebuild b/dev-db/wxsqlite3/wxsqlite3-3.0.6.1-r1.ebuild
new file mode 100644
index 000000000000..90afd06d64a8
--- /dev/null
+++ b/dev-db/wxsqlite3/wxsqlite3-3.0.6.1-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+
+inherit eutils multilib wxwidgets
+
+DESCRIPTION="C++ wrapper around the public domain SQLite 3.x database"
+HOMEPAGE="http://wxcode.sourceforge.net/components/wxsqlite3/"
+SRC_URI="mirror://sourceforge/wxcode/${P}.tar.gz"
+
+LICENSE="wxWinLL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ x11-libs/wxGTK:2.8[X,debug=]
+ dev-db/sqlite:3"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P%.1}"
+
+src_prepare() {
+ local wxdebug
+
+ rm -rf sqlite3 || die
+ cp configure28 configure || die
+ use debug && wxdebug="d"
+ sed \
+ -e "s:@WXDEBUG@:${wxdebug}:g" \
+ -e "s:@WXVERSION@:${WX_GTK_VER}:g" \
+ -e "s:@LIBDIR@:$(get_libdir):g" \
+ -e "s:@VERSION@:${PV}:g" \
+ "${FILESDIR}"/${P}.pc.in > ${PN}.pc || die
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --enable-unicode \
+ --with-wx-config="${WX_CONFIG}" \
+ --with-wxshared \
+ --with-sqlite3-prefix="${PREFIX}/usr"
+}
+
+src_install() {
+ default
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins ${PN}.pc
+
+ dodoc Readme.txt
+ dohtml -r docs/html/*
+ docinto samples
+ dodoc -r samples/*
+}