summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2020-09-27 21:16:14 +0200
committerSven Wegener <swegener@gentoo.org>2020-09-27 21:31:37 +0200
commit99f61f962f7b236438a87da6f3c2466d455d7bf2 (patch)
treef23e1213c51b3bf5207fc2cd908dc419d9c819dd /dev-embedded
parentapp-shells/dash-0.5.11.2: fix compilation on Solaris (diff)
downloadgentoo-99f61f962f7b236438a87da6f3c2466d455d7bf2.tar.gz
gentoo-99f61f962f7b236438a87da6f3c2466d455d7bf2.tar.bz2
gentoo-99f61f962f7b236438a87da6f3c2466d455d7bf2.zip
dev-embedded/libjaylink: Switch live ebuild to EAPI 7
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/libjaylink/libjaylink-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-embedded/libjaylink/libjaylink-9999.ebuild b/dev-embedded/libjaylink/libjaylink-9999.ebuild
index d3b0e28e8e2c..9190af8cdbc0 100644
--- a/dev-embedded/libjaylink/libjaylink-9999.ebuild
+++ b/dev-embedded/libjaylink/libjaylink-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="7"
EGIT_REPO_URI="https://gitlab.zapb.de/libjaylink/libjaylink.git"
-inherit git-r3 autotools eutils ltprune
+inherit git-r3 autotools
DESCRIPTION="Library to access J-Link devices"
HOMEPAGE="https://gitlab.zapb.de/libjaylink/libjaylink"
@@ -19,7 +19,8 @@ DEPEND="virtual/libusb:1"
RDEPEND="${DEPEND}"
src_prepare() {
- eautoreconf || die
+ eapply_user
+ eautoreconf
}
src_configure() {
@@ -28,5 +29,5 @@ src_configure() {
src_install() {
default
- prune_libtool_files
+ use static-libs || find "${D}" -name '*.la' -delete || die
}