summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/tiled
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/tiled')
-rw-r--r--dev-games/tiled/Manifest2
-rw-r--r--dev-games/tiled/metadata.xml11
-rw-r--r--dev-games/tiled/tiled-0.11.0.ebuild52
-rw-r--r--dev-games/tiled/tiled-0.12.3.ebuild59
4 files changed, 124 insertions, 0 deletions
diff --git a/dev-games/tiled/Manifest b/dev-games/tiled/Manifest
new file mode 100644
index 000000000000..0e36e5770d96
--- /dev/null
+++ b/dev-games/tiled/Manifest
@@ -0,0 +1,2 @@
+DIST tiled-0.11.0.tar.gz 2324668 SHA256 0d4b028902dfe08f18b542bfd9eaaf08886c1f685b2e176f438c3bf9d72e410d SHA512 c3eb230225a144938069b54bcedfe9927dd42358ca91d8922f56a4e566f0041b4b33aef3d87ef4b3b58634e9e98efd98a7132f419c2dd18d563f28393df066f8 WHIRLPOOL f28764e1d0904acecef826b4c35d7f56513c9b0cee682fbe1abf45989a1c6076d9eaa0285dff3daa64d88b8061dd3aec1fbae52208e1ea3510a2b4f167ed2270
+DIST tiled-0.12.3.tar.gz 2372813 SHA256 8078b266cc4902451e14b1efb6c8eba69f610e5056fcb74d1d30b5b236253200 SHA512 a8b5cb2201806e6b5a0e5079a9e12fbffcbb79f2df0a193e3c3e80424df1c8c4c94ae23c1553a82a1813d4bc65d9da54d79faa41a8983233aa67023e2348cc4b WHIRLPOOL 6deb8f40aea684619c5aee3746080f0543c8a7d3dfc37d76afbd447bc34923afdbb4b676553e6e33d187a0702dfa0514ec4b567a02a95dbd4a5e87bc28c7fa92
diff --git a/dev-games/tiled/metadata.xml b/dev-games/tiled/metadata.xml
new file mode 100644
index 000000000000..0b4750a0187c
--- /dev/null
+++ b/dev-games/tiled/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>kensington@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">tiled</remote-id>
+ <remote-id type="github">bjorn/tiled</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-games/tiled/tiled-0.11.0.ebuild b/dev-games/tiled/tiled-0.11.0.ebuild
new file mode 100644
index 000000000000..d33d1a1992e7
--- /dev/null
+++ b/dev-games/tiled/tiled-0.11.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="cs de en es fr he it ja lv nl pt pt_BR ru zh zh_TW"
+PYTHON_COMPAT=( python2_7 )
+inherit multilib l10n python-single-r1 qt4-r2
+
+DESCRIPTION="A general purpose tile map editor"
+HOMEPAGE="http://www.mapeditor.org/"
+SRC_URI="https://github.com/bjorn/tiled/archive/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND=">=dev-qt/qtcore-4.7:4
+ >=dev-qt/qtgui-4.7:4
+ >=dev-qt/qtopengl-4.7:4
+ sys-libs/zlib
+ python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS COPYING NEWS README.md )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ rm -r src/zlib || die
+ sed -e "s/^LANGUAGES =.*/LANGUAGES = $(l10n_get_locales)/" \
+ -i translations/translations.pro || die
+}
+
+src_configure() {
+ eqmake4 LIBDIR="/usr/$(get_libdir)" PREFIX="/usr" DISABLE_PYTHON_PLUGIN="$(usex !python)"
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}
diff --git a/dev-games/tiled/tiled-0.12.3.ebuild b/dev-games/tiled/tiled-0.12.3.ebuild
new file mode 100644
index 000000000000..a3f88b8f7bcf
--- /dev/null
+++ b/dev-games/tiled/tiled-0.12.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit fdo-mime multilib python-single-r1 qt4-r2
+
+DESCRIPTION="A general purpose tile map editor"
+HOMEPAGE="http://www.mapeditor.org/"
+SRC_URI="https://github.com/bjorn/tiled/archive/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND=">=dev-qt/qtcore-4.7:4
+ >=dev-qt/qtgui-4.7:4
+ >=dev-qt/qtopengl-4.7:4
+ sys-libs/zlib
+ python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS COPYING NEWS README.md )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ rm -r src/zlib || die
+}
+
+src_configure() {
+ eqmake4 LIBDIR="/usr/$(get_libdir)" PREFIX="/usr" DISABLE_PYTHON_PLUGIN="$(usex !python)"
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}