summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/aeson-qq
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/aeson-qq')
-rw-r--r--dev-haskell/aeson-qq/Manifest2
-rw-r--r--dev-haskell/aeson-qq/aeson-qq-0.7.4.ebuild31
-rw-r--r--dev-haskell/aeson-qq/aeson-qq-0.8.0.ebuild33
-rw-r--r--dev-haskell/aeson-qq/metadata.xml20
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-haskell/aeson-qq/Manifest b/dev-haskell/aeson-qq/Manifest
new file mode 100644
index 000000000000..dafb73444a0e
--- /dev/null
+++ b/dev-haskell/aeson-qq/Manifest
@@ -0,0 +1,2 @@
+DIST aeson-qq-0.7.4.tar.gz 4202 SHA256 9b4c5583e21007aade87ac75d5c5ee95ef910641c0fddea67b25b42ddb4dcc72 SHA512 4ca302f27d03698d661bf04c8fa2cfb2d725988e694f62bddfd0ae544e64c6b4980b796cf4b85e13fd9ae289922b242e649abc71df2588306cd024d38e7d90fb WHIRLPOOL ad1707f9d8480fdecdd46475c2c5b4404a3a2765e09d0dcbe11dc29e349b86ac0a5151906dd795ab95c33f1e75b999b70fb5641dd31f364759bddc6b4619358f
+DIST aeson-qq-0.8.0.tar.gz 4257 SHA256 eec4bc1cac531c784be01bd2db5b1113c464d6bf2b84dcc9c9421a15601d7a8b SHA512 16fa193e984f1cdfba4556cc416ec9a5a6dfcf16bd359e877a920a037fe979cf97b62f1b986cf14124cc2100463d8048d7014ef4fc887415b3b56a12fe5fd5b4 WHIRLPOOL d9cc0e74ef731709ccdbb9a01ed209d837e6b6405275662fb980dd4017adb3aff5976e50f584199dc1ed4f4dad19b41e6ccac6ceda0f5c66942a1949d047ab66
diff --git a/dev-haskell/aeson-qq/aeson-qq-0.7.4.ebuild b/dev-haskell/aeson-qq/aeson-qq-0.7.4.ebuild
new file mode 100644
index 000000000000..c84df72f7359
--- /dev/null
+++ b/dev-haskell/aeson-qq/aeson-qq-0.7.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="JSON quasiquoter for Haskell"
+HOMEPAGE="http://github.com/zalora/aeson-qq"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/haskell-src-meta-0.1.0:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hspec )
+"
diff --git a/dev-haskell/aeson-qq/aeson-qq-0.8.0.ebuild b/dev-haskell/aeson-qq/aeson-qq-0.8.0.ebuild
new file mode 100644
index 000000000000..5ec01535b7f3
--- /dev/null
+++ b/dev-haskell/aeson-qq/aeson-qq-0.8.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="JSON quasiquoter for Haskell"
+HOMEPAGE="http://github.com/zalora/aeson-qq"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ >=dev-haskell/haskell-src-meta-0.1.0:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hspec )
+"
diff --git a/dev-haskell/aeson-qq/metadata.xml b/dev-haskell/aeson-qq/metadata.xml
new file mode 100644
index 000000000000..2451ef4778d9
--- /dev/null
+++ b/dev-haskell/aeson-qq/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ @aeson-qq@ provides a JSON quasiquoter for Haskell.
+
+ This package exposes the function `aesonQQ` that compile-time
+ converts a string representation of a JSON value into a
+ `Data.Aeson.Value`. `aesonQQ` has the signature
+
+ &gt;aesonQQ :: QuasiQuoter
+
+ Consult the @README@ for documentation:
+ &lt;https://github.com/zalora/aeson-qq#readme&gt;
+ </longdescription>
+ <upstream>
+ <remote-id type="github">zalora/aeson-qq</remote-id>
+ </upstream>
+</pkgmetadata>