summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/network-data
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/network-data')
-rw-r--r--dev-haskell/network-data/Manifest1
-rw-r--r--dev-haskell/network-data/metadata.xml13
-rw-r--r--dev-haskell/network-data/network-data-0.5.3.ebuild42
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-haskell/network-data/Manifest b/dev-haskell/network-data/Manifest
new file mode 100644
index 000000000000..531201f22ae1
--- /dev/null
+++ b/dev-haskell/network-data/Manifest
@@ -0,0 +1 @@
+DIST network-data-0.5.3.tar.gz 5795 SHA256 ffeb6030a4a0c4d0f2c296133b2f72c67bc550c1de8a1781a429a19c3fbd7c7d SHA512 911cd9cc5af3b0bd49939b6ce79886c8d07fb2e4700a837560f5e6b6bb2a74dca319889f01dea87f463c6ee0df2d7b9442f4ed5201ed4acd4aadceb85b69ddec WHIRLPOOL 73df461995cb81185b4acb21255aed56a4cbe498277c2baa948eb388dfa5a6fd0e1ab57f628e07917397e3edb27cc0b5c150f89386195e380649839820228839
diff --git a/dev-haskell/network-data/metadata.xml b/dev-haskell/network-data/metadata.xml
new file mode 100644
index 000000000000..60ffcb806b72
--- /dev/null
+++ b/dev-haskell/network-data/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <use>
+ <flag name="small_base">Build the split-up base package.</flag>
+ </use>
+ <longdescription>
+ This library includes definitions for common headers such as
+ Ethernet, IPv4, IPv6, UDP, TCP, etc. This code is untested for any serious
+ work - use at your own risk.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/network-data/network-data-0.5.3.ebuild b/dev-haskell/network-data/network-data-0.5.3.ebuild
new file mode 100644
index 000000000000..2c5d86c7d101
--- /dev/null
+++ b/dev-haskell/network-data/network-data-0.5.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Library for network data structures and their serialization"
+HOMEPAGE="http://hackage.haskell.org/package/network-data"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+small_base"
+
+# dev-haskell/prettyclass is not required for ghc 7.10.1, just adding
+# it for backwards compatibility with <ghc 7.10.1
+
+RDEPEND=">=dev-haskell/cereal-0.2:=[profile?]
+ >=dev-haskell/prettyclass-1.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+"
+
+src_prepare() {
+ if has_version "<dev-lang/ghc-7.10.1"; then
+ cabal_chdeps \
+ 'pretty >= 1.1.2' 'pretty >= 1.0, prettyclass >= 1.0'
+ fi
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag small_base small_base)
+}