summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/sun-httpserver-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/sun-httpserver-bin')
-rw-r--r--dev-java/sun-httpserver-bin/Manifest1
-rw-r--r--dev-java/sun-httpserver-bin/metadata.xml5
-rw-r--r--dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1-r1.ebuild40
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-java/sun-httpserver-bin/Manifest b/dev-java/sun-httpserver-bin/Manifest
new file mode 100644
index 000000000000..7359ea9daf0f
--- /dev/null
+++ b/dev-java/sun-httpserver-bin/Manifest
@@ -0,0 +1 @@
+DIST JAXWS2.0.1m1_source_20060817.jar 8993405 SHA256 9725cfb91cecff833055d7af45c3413ca9d1a818a4cfdb86211ed82f383f3865 SHA512 55454a8270310b9778c69aad8b8ace45dc4ba3059b33ac48dcfd5d771fade2d6e4c46a5a65a522ae5cca0438f159ba84c90d8e74d54731a9c6c0caa9d84a0314 WHIRLPOOL fe0727935c592b538b7042808fffa987ea5ae47554367ea0cfc91f65d765bd234713aaa142b2297988d74eec01fce9cd4bedceb0fb7b0068eb38084a1d5f5ba7
diff --git a/dev-java/sun-httpserver-bin/metadata.xml b/dev-java/sun-httpserver-bin/metadata.xml
new file mode 100644
index 000000000000..250f2d1940ea
--- /dev/null
+++ b/dev-java/sun-httpserver-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1-r1.ebuild b/dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..e37c5b8465c0
--- /dev/null
+++ b/dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+inherit java-pkg-2
+
+DESCRIPTION="Sun sun.net.httpserver classes"
+HOMEPAGE="http://jax-ws.dev.java.net/"
+DATE="20060817"
+MY_P="JAXWS${PV}m1_source_${DATE}.jar"
+SRC_URI="https://jax-ws.dev.java.net/jax-ws-201-m1/${MY_P}"
+
+LICENSE="CDDL"
+SLOT="2"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND="app-arch/unzip
+ ${RDEPEND}"
+
+S="${WORKDIR}/jaxws-si"
+
+src_unpack() {
+ MY_JAVA=$(java-config -J)
+
+ echo "A" | ${MY_JAVA} -jar "${DISTDIR}/${A}" -console > /dev/null || die "unpack failed"
+
+ unpack ./jaxws-src.zip || die "unzip failed"
+
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ java-pkg_dojar lib/http.jar
+}