summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-04-13 12:30:17 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-04-13 12:30:17 +0200
commita69dc4ba502fc196b8e498fd7c9b3edd1c2822de (patch)
tree041ffe917583665becabebfc884fbde8b6b0ca48 /dev-java
parentdev-java/xerces: MAVEN_ID (diff)
downloadgentoo-a69dc4ba502fc196b8e498fd7c9b3edd1c2822de.tar.gz
gentoo-a69dc4ba502fc196b8e498fd7c9b3edd1c2822de.tar.bz2
gentoo-a69dc4ba502fc196b8e498fd7c9b3edd1c2822de.zip
dev-java/commons-io: bump to 2.8.0
Bug: https://bugs.gentoo.org/736579 Bug: https://bugs.gentoo.org/758371 Bug: https://bugs.gentoo.org/779499 Bug: https://bugs.gentoo.org/782568 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-io/Manifest1
-rw-r--r--dev-java/commons-io/commons-io-2.8.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/commons-io/Manifest b/dev-java/commons-io/Manifest
index 83cae7deb5df..564428f27215 100644
--- a/dev-java/commons-io/Manifest
+++ b/dev-java/commons-io/Manifest
@@ -1 +1,2 @@
DIST commons-io-2.4-src.tar.gz 330961 BLAKE2B 1a1ae7c968bfc38b4a4f3c4c131de088c4efdd8fff0858e7493e057909076c74d4b0ebee1999ef01af9636d88600ecca71bb0808686a6f9c1a20f4d7a5cbe6e6 SHA512 69ac5f7b8de952d8b519ad89d4e9a33a9d269af0e68b735c0180ee8853a30e2a09147ceac362626a2fb3a041bd46eca094be2661ff280c1bab54a0548cae0aee
+DIST commons-io-2.8.0-sources.tar.gz 445833 BLAKE2B 4fc6f9b66fa88adfc110742bd3eab55cbe165552f71d665f70fd54d4b0b79c4e76b45fccdb78c6ef64e476f54efc8b51adc9b2d7e880c71dbdb6bc5883d2fe55 SHA512 6189c72eff8661bfb8cfed95dd7ee32578b24b50f6586d4628a4dbfd3618853a72eb73da311729e55742ace47b2d38d3ce130ab87b684494d8ce33d1ccf14a2d
diff --git a/dev-java/commons-io/commons-io-2.8.0.ebuild b/dev-java/commons-io/commons-io-2.8.0.ebuild
new file mode 100644
index 000000000000..f6f4ca1b4ebf
--- /dev/null
+++ b/dev-java/commons-io/commons-io-2.8.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://ftp.fau.de/apache//commons/io/source/commons-io-2.8.0-src.tar.gz --slot 1 --keywords "~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris" --ebuild commons-io-2.8.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="commons-io:commons-io:2.8.0"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Utility classes, stream implementations, file filters, and endian classes"
+HOMEPAGE="https://commons.apache.org/proper/commons-io/"
+SRC_URI="mirror://apache/commons/io/source/${P}-src.tar.gz -> ${P}-sources.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ENCODING="iso-8859-1"
+
+JAVA_SRC_DIR="src/main/java"