summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-09-03 15:00:55 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-09-03 15:01:02 +0100
commit5917f76438cba881d0e8dbf8ccb1670b453ca0bb (patch)
tree33d9e5a2610824744fee4fc65b891ef4d60814f2 /dev-libs/capstone
parentdev-python/h5py: drop rm -r _build || die (diff)
downloadgentoo-5917f76438cba881d0e8dbf8ccb1670b453ca0bb.tar.gz
gentoo-5917f76438cba881d0e8dbf8ccb1670b453ca0bb.tar.bz2
gentoo-5917f76438cba881d0e8dbf8ccb1670b453ca0bb.zip
dev-libs/capstone: respect gentoo toolchain overrides, bug #592778
Respect AR, CC, CFLAGS, LDFLAGS, RANLIB, $libdir. Thanks to Mike Auty who provided an example fix. Reported-by: Mike Auty Bug: https://bugs.gentoo.org/592778 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs/capstone')
-rw-r--r--dev-libs/capstone/capstone-3.0.4-r2.ebuild (renamed from dev-libs/capstone/capstone-3.0.4-r1.ebuild)22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/capstone/capstone-3.0.4-r1.ebuild b/dev-libs/capstone/capstone-3.0.4-r2.ebuild
index 018e9db63513..41855d162562 100644
--- a/dev-libs/capstone/capstone-3.0.4-r1.ebuild
+++ b/dev-libs/capstone/capstone-3.0.4-r2.ebuild
@@ -4,6 +4,8 @@
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="disassembly/disassembler framework + bindings"
HOMEPAGE="http://www.capstone-engine.org/"
SRC_URI="https://github.com/aquynh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -14,3 +16,23 @@ KEYWORDS="~amd64 ~x86"
RDEPEND=""
DEPEND="${RDEPEND}"
+
+src_configure() {
+ {
+ cat <<-EOF
+ # Gentoo overrides:
+ # verbose build
+ V = 1
+ # toolchain
+ AR = $(tc-getAR)
+ CC = $(tc-getCC)
+ RANLIB = $(tc-getRANLIB)
+ # toolchain flags
+ CFLAGS = ${CFLAGS}
+ LDFLAGS = ${LDFLAGS}
+ # libs
+ LIBDIRARCH = $(get_libdir)
+ EOF
+ } >> config.mk || die
+
+}