summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Carlier <devnexen@gmail.com>2017-03-24 19:55:57 +0000
committerMichał Górny <mgorny@gentoo.org>2017-07-15 08:37:41 +0200
commitc82166a3230cca521c494896387c507badd75590 (patch)
tree8fee1d2a51861dc2e9243c9078cdbfd2eb007150 /dev-libs/device-atlas-api-c
parentapp-admin/puppet: add 4.10.4 (diff)
downloadgentoo-c82166a3230cca521c494896387c507badd75590.tar.gz
gentoo-c82166a3230cca521c494896387c507badd75590.tar.bz2
gentoo-c82166a3230cca521c494896387c507badd75590.zip
dev-libs/device-atlas-api-c: Bump to 2.1.2_1 version
Closes: https://github.com/gentoo/gentoo/pull/4287
Diffstat (limited to 'dev-libs/device-atlas-api-c')
-rw-r--r--dev-libs/device-atlas-api-c/Manifest1
-rw-r--r--dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.2_p1.ebuild50
-rw-r--r--dev-libs/device-atlas-api-c/files/2.1.2-src-cmakelists.patch18
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/device-atlas-api-c/Manifest b/dev-libs/device-atlas-api-c/Manifest
index 8199f8ea1141..de4fbaa478c0 100644
--- a/dev-libs/device-atlas-api-c/Manifest
+++ b/dev-libs/device-atlas-api-c/Manifest
@@ -1 +1,2 @@
+DIST deviceatlas-enterprise-c-2.1.2_1.tgz 184432 SHA256 984e1ae3147459a4ed0a8d5053d83dd05ce8c5127cd3cb055be35a74e9217372 SHA512 4ff269c55e74688dc1c954a1d9b0fc28aa135eccd20089f4da390522644bd1c08e2bc38e4ad15a64308a0e91b007a820dcdc3998c262fa5a7cfe1038e9f0e969 WHIRLPOOL 73c1c7eec0daed7632e8a5a7ceda956ec91cc603fe45df2fdbf2b54ecc950bd72ff59fdd85ff6a0ee70d54b2099ecc3219ef55f4aecb308f254851f93fe57738
DIST deviceatlas-enterprise-c-2.1.zip 504286 SHA256 a02fc29486d245b1c8d946c663b71ba981e88fee8d037f5bc1bf255deb287974 SHA512 99a8e89f3d1c084a93b184685108ea65d1fd925e0c8b52599a42dbe70af3126103da0a9fd284b14ddf59b996204334d360a12651025413bc4d7f76054779275b WHIRLPOOL 939733a58f352cbeee852ccfea3f2f022310ceb7363a15889d9a6366532102ee700271b6008e0a57ae4d86cafe6354409f9520105e46eaabb5c41f1a7827f1b4
diff --git a/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.2_p1.ebuild b/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.2_p1.ebuild
new file mode 100644
index 000000000000..bc28a136dd90
--- /dev/null
+++ b/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.2_p1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-multilib
+
+MY_P="deviceatlas-enterprise-c-${PV/_p/_}"
+
+DESCRIPTION="API to detect devices based on the User-Agent HTTP header"
+HOMEPAGE="https://deviceatlas.com"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/libpcre[${MULTILIB_USEDEP}]"
+DEPEND="
+ ${RDEPEND}"
+
+RESTRICT="fetch mirror bindist"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-src-cmakelists.patch"
+)
+
+pkg_nofetch() {
+ eerror "Please go to https://deviceatlas.com/deviceatlas-haproxy-module"
+ eerror "And download DeviceAtlas C API"
+ eerror "Then place the file in ${DISTDIR}/${MY_P}.zip"
+}
+
+multilib_src_install_all() {
+ if use doc ; then
+ local -a HTML_DOCS=( Documentation )
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${P}/examples
+ doins examples/daexutil.h
+ doins examples/example{0,1,2,3}.c
+ doins examples/util.c
+ doins examples/EXAMPLES.USAGE
+ fi
+
+ einstalldocs
+}
diff --git a/dev-libs/device-atlas-api-c/files/2.1.2-src-cmakelists.patch b/dev-libs/device-atlas-api-c/files/2.1.2-src-cmakelists.patch
new file mode 100644
index 000000000000..b81768aba648
--- /dev/null
+++ b/dev-libs/device-atlas-api-c/files/2.1.2-src-cmakelists.patch
@@ -0,0 +1,18 @@
+--- a/Src/CMakeLists.txt.orig 2017-05-20 22:56:14.138401705 +0100
++++ b/Src/CMakeLists.txt 2017-05-20 22:58:11.376354697 +0100
+@@ -18,6 +18,7 @@
+ set(MODEL 64)
+ endif()
+
++include(GNUInstallDirs)
+ message(STATUS "${CMAKE_BUILD_TYPE} version")
+
+ include_directories(${PCRE_INCLUDE_DIR} ${CMAKE_CURRENT_SOURCE_DIR})
+@@ -37,5 +38,5 @@
+ set (CMAKE_SHARED_LINKER_FLAGS -m32)
+ endif()
+
+-install(FILES libda.so libda.so.${API_VERSION} DESTINATION /usr/local/lib)
+-install(FILES dac.h dac_json.h DESTINATION /usr/local/include)
++install(TARGETS da DESTINATION ${CMAKE_INSTALL_LIBDIR})
++install(FILES dac.h dac_json.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})