summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/jansson
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/jansson')
-rw-r--r--dev-libs/jansson/Manifest3
-rw-r--r--dev-libs/jansson/jansson-2.4.ebuild38
-rw-r--r--dev-libs/jansson/jansson-2.6.ebuild38
-rw-r--r--dev-libs/jansson/jansson-2.7.ebuild38
-rw-r--r--dev-libs/jansson/metadata.xml13
5 files changed, 130 insertions, 0 deletions
diff --git a/dev-libs/jansson/Manifest b/dev-libs/jansson/Manifest
new file mode 100644
index 000000000000..40c6956e748d
--- /dev/null
+++ b/dev-libs/jansson/Manifest
@@ -0,0 +1,3 @@
+DIST jansson-2.4.tar.gz 401597 SHA256 1fcbd1ac3d8b610644acf86a5731d760bb228c9acbace20a2ad0f23baec79b41 SHA512 52c82ea2e70b9a1b72a62e07d917e5b2f8dc1b0fd6022397cbdd60b98aee176cc02f8c65b60d371b4007c60644898667f6bc0dfd11a26a411f167fac0e4df9a0 WHIRLPOOL c028243d8ecd0763f6f6d012113cbbb6ac58698532f94563372994311650762a7eb2d7f1831779dabcce0be2c013d4cb103bde5c3ad919afeeb82f2c875c2460
+DIST jansson-2.6.tar.gz 428175 SHA256 98fa4dd0e0dff679e5085490f5fafa38bdda088f4553348c0281832d24afe541 SHA512 9781cc109c9e76bc2f15b5ad6af95f8a3b52d60424d101ff90103f33679db5c5bfe2fcc7443698e1808aaf87dce563f7c11a48aa4ac5bfa34688499cbc21277c WHIRLPOOL a8aea19e518290c8b00f8788b67d9b6efac0e03442216ce9ecc672659560854eefc71f9821abe472aec5b6abd693e41076f66678dbcab0d2c9dd4d542755bf22
+DIST jansson-2.7.tar.gz 445179 SHA256 7905e6590fb316c0ff943df3dc6a21cd81a59cff7a6d12514054c359d04d78d7 SHA512 657b715868c2fbf8da1e41befee2691524190e12255214c472652ca3e3793b03e2b384dc3aedb1071b67b0b8cb57fd495103979983fe21a2404f12cd70295a28 WHIRLPOOL 684c0a1cae8cbd86d1a4e19bcfa59f36bf6094853ce5e18bd600fcb27fb1afac250e52c1983f888fcae06437c6e142b2ea3823c911b5a2923f4775494d26690f
diff --git a/dev-libs/jansson/jansson-2.4.ebuild b/dev-libs/jansson/jansson-2.4.ebuild
new file mode 100644
index 000000000000..f07d058bda58
--- /dev/null
+++ b/dev-libs/jansson/jansson-2.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="C library for encoding, decoding and manipulating JSON data"
+HOMEPAGE="http://www.digip.org/jansson/"
+SRC_URI="http://www.digip.org/jansson/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( >=dev-python/sphinx-1.0.4 )"
+RDEPEND=""
+
+DOCS=(CHANGES README.rst)
+
+src_prepare() {
+ sed -ie 's/-Werror//' src/Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ use doc && autotools-utils_src_compile html
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/doc/_build/html/")
+ autotools-utils_src_install
+}
diff --git a/dev-libs/jansson/jansson-2.6.ebuild b/dev-libs/jansson/jansson-2.6.ebuild
new file mode 100644
index 000000000000..84638f6b2f8a
--- /dev/null
+++ b/dev-libs/jansson/jansson-2.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="C library for encoding, decoding and manipulating JSON data"
+HOMEPAGE="http://www.digip.org/jansson/"
+SRC_URI="http://www.digip.org/jansson/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( >=dev-python/sphinx-1.0.4 )"
+RDEPEND=""
+
+DOCS=(CHANGES README.rst)
+
+src_prepare() {
+ sed -ie 's/-Werror//' src/Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ use doc && autotools-utils_src_compile html
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/doc/_build/html/")
+ autotools-utils_src_install
+}
diff --git a/dev-libs/jansson/jansson-2.7.ebuild b/dev-libs/jansson/jansson-2.7.ebuild
new file mode 100644
index 000000000000..38cdb771eb52
--- /dev/null
+++ b/dev-libs/jansson/jansson-2.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="C library for encoding, decoding and manipulating JSON data"
+HOMEPAGE="http://www.digip.org/jansson/"
+SRC_URI="http://www.digip.org/jansson/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( >=dev-python/sphinx-1.0.4 )"
+RDEPEND=""
+
+DOCS=(CHANGES README.rst)
+
+src_prepare() {
+ sed -ie 's/-Werror//' src/Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ use doc && autotools-utils_src_compile html
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/doc/_build/html/")
+ autotools-utils_src_install
+}
diff --git a/dev-libs/jansson/metadata.xml b/dev-libs/jansson/metadata.xml
new file mode 100644
index 000000000000..569987a08f85
--- /dev/null
+++ b/dev-libs/jansson/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>bugs@bergstroem.nu</email>
+ <name>Johan Bergström</name>
+ <description>Maintainer. Assign bugs to him</description>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+